ExpSuite Namespace

ExpSuite
ExpSuite Namespace
Send Feedback
ExpSuite is a software framework for applications to perform psychoacoustical experiments. ExpSuite allows acoustic and electric stimulation for normal hearing and cochlear implant listeners, respectively.

Classes

 | Class | Description
Protected class | clsDataDirectory | FrameWork - Data Directory support. Only one instance of clsDataDirectory is used in FrameWork: DataDirectory.
Protected class | clsItemList | Flags to restrict the content of items.
Protected class | Config | Application Module. REQUIRED. Configuration of the ExpSuite application.
Protected class | Create | User Module. Optional. Examples of creating stimuli in ExpSuite.
Protected class | CSVParser | FrameWork - CSV files support.
Protected class | Events | Application Module. REQUIRED. General events caused by user interaction.
Protected class | EventsSettings | User Module. Optional. Example of events handling changes in Settings.
Protected class | frmAbout | FrameWork Module. Implementation of the About form.
Protected class | frmExp | FrameWork Module. Implementation of the Experiment Screen and Subject Interaction.
Protected class | frmInputBox | FrameWork Module - Programmable Input Box Form
Protected class | frmInputMultiline | FrameWork Module - Programmable Multiline Input Box Form.
Protected class | frmItemListPostfix | FrameWork Module. Implementation of the Postfix of Item Lists dialog.
Protected class | frmMain | FrameWork Module. Main Window.
Protected class | frmOptions | FrameWork Module. Implementation of the Options dialog.
Protected class | frmResult | FrameWork Module. Implementation of the Result form.
Protected class | frmSettings | FrameWork Module. Implementation of the Settings dialog.
Protected class | frmSettingsTrackRange | FrameWork Module. Implementation of the dialog to set Tracker ranges.
Protected class | frmShowStimulus | FrameWork Module. Implementation of the Show Stimulus dialog.
Protected class | frmTurntable | FrameWork Module. Implementation of the Turntable dialog.
Protected class | FWintern | FrameWork - Declarations and general methods.
Protected class | HUI | FrameWork - Internal use only.
Protected class | INIOptions | FrameWork - Handling of Options.
Protected class | INISettings | FrameWork - Handling of Settings.
Protected class | MIDI | FrameWork - Handling of MIDI devices.
Protected class | OSC | FrameWork - Open Sound Control (OSC) support
Protected class | Output | FrameWork - Handling of output devices.
Protected class | Proc | FrameWork - General tools
Protected class | Result | Application Module. REQUIRED. Events on Execution of methods.
Protected class | STIM | Stimulus creation, connection to MATLAB and logging of data.
Protected class | Tracker | FrameWork - Tracker support.
Protected class | Turntable | FrameWork - Turntable support.
Protected class | ViWo |
Protected class | ViWo..::..ViWoParameter |

Structures

 | Structure | Description
Public structure | FWintern..::..AudioSynth | Structure for the synthesizer (Settings/Audio).
Public structure | FWintern..::..ExpConstant | Structure for an experimental Constant (Settings/Constants)
Public structure | FWintern..::..ExpVariable | Structure for an experimental Variable (Settings/Variable)
Public structure | Tracker..::..TrackerSensor | Tracker Sensor data.

Enumerations

 | Enumeration | Description
Public enumeration | FWintern..::..VariableFlags | Flags to restrict the content of Constants or Variables.

Send comments on this topic to Piotr Majdak & Michael Mihocic

Acoustics Research Institute


clsDataDirectory Class

clsDataDirectory Class
Members See Also Send Feedback
FrameWork - Data Directory support. Only one instance of clsDataDirectory is used in FrameWork: DataDirectory.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class clsDataDirectory

Inheritance Hierarchy

System..::..Object
ExpSuite..::..clsDataDirectory

See Also

clsDataDirectory Members
ExpSuite Namespace
FWintern..::..DataDirectory


clsDataDirectory Members

[image]

ExpSuite
clsDataDirectory Members
clsDataDirectory Class Methods Properties See Also Send Feedback

The clsDataDirectory type exposes the following members.

Methods

 | Name | Description
Public method | AddDir | Add a new data directory.
Public method | Reset | Reset all data directories. No data directories will be defined after Reset.

Properties

 | Name | Description
Public property | Count | Get the number of data directories.
Public property | Path | Get / Set the data directory to a path.
Public property | Title | Get / Set the title of a data directory.

See Also

clsDataDirectory Class
ExpSuite Namespace


clsDataDirectory Methods

[image]

ExpSuite
clsDataDirectory Methods
clsDataDirectory Class See Also Send Feedback

The clsDataDirectory type exposes the following members.

Methods

 | Name | Description
Public method | AddDir | Add a new data directory.
Public method | Reset | Reset all data directories. No data directories will be defined after Reset.

See Also

clsDataDirectory Class


AddDir Method

clsDataDirectory..::..AddDir Method
clsDataDirectory Class See Also Send Feedback
Add a new data directory.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub AddDir ( _
    Title As String, _
    Path As String _
)

Parameters

Title
Type: System..::..String
Title of the data directory
Path
Type: System..::..String
[Optional] Default path of the data directory

See Also

clsDataDirectory Class


Reset Method

clsDataDirectory..::..Reset Method
clsDataDirectory Class See Also Send Feedback
Reset all data directories. No data directories will be defined after Reset.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub Reset

See Also

clsDataDirectory Class
ExpSuite Namespace
clsDataDirectory..::..AddDir(String, String)


clsDataDirectory Properties

[image]

ExpSuite
clsDataDirectory Properties
clsDataDirectory Class See Also Send Feedback

The clsDataDirectory type exposes the following members.

Properties

 | Name | Description
Public property | Count | Get the number of data directories.
Public property | Path | Get / Set the data directory to a path.
Public property | Title | Get / Set the title of a data directory.

See Also

clsDataDirectory Class


Count Property

clsDataDirectory..::..Count Property
clsDataDirectory Class See Also Send Feedback
Get the number of data directories.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
    Get

See Also

clsDataDirectory Class
ExpSuite Namespace
clsDataDirectory..::..AddDir(String, String)
clsDataDirectory..::..Reset()()()()


Path Property

clsDataDirectory..::..Path Property
clsDataDirectory Class Example See Also Send Feedback
Get / Set the data directory to a path.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Path ( _
    Index As Integer _
) As String
    Get
    Set

Parameters

Index
Type: System..::..Int32
Directory index

Examples

This example shows you how to GET the data directory: szString = Path(Integer) // This example shows you how to SET the data directory to a path: Path(Index) = szString

See Also

clsDataDirectory Class


Title Property

clsDataDirectory..::..Title Property
clsDataDirectory Class Example See Also Send Feedback
Get / Set the title of a data directory.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Title ( _
    Index As Integer _
) As String
    Get
    Set

Parameters

Index
Type: System..::..Int32
Directory index

Examples

This example shows you how to GET the title of a data directory: szString = Title(Integer) // This example shows you how to SET the title of a data directory: Title(Index) = szString

See Also

clsDataDirectory Class


clsItemList Class

clsItemList Class
Members See Also Send Feedback
Flags to restrict the content of items.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class clsItemList

Remarks

Select the type of content (string, numeric, directory of file name) and then use a proper restriction.
ifString Content is a string. See String flags for further restrictions.
ifNumeric Content is numeric. See Numeric flags for further restrictions.
ifDirectory Content is a directory.
ifFileName Content is a file name. See Filename flags for further restrictions. Use the Unit parameter to set the file name mask (e.g. *.txt)
ifElectrodeL Content is a left electrode from Settings/Signal. See Electrode flags for further restrictions.
ifElectrodeR Content is a right electrode from Settings/Signal. See Electrode flags for further restrictions.
ifFlagTypeMask Mask of the flag type. Use "MyFlags AND ifFlagTypeMask" to retrieve the type of the flag.
Numeric Flags:
ifInteger Restrict to integer.
ifNonZero Must not be zero.
ifMinTimeDelay Must be positive integer.
ifMin Sets a restriction to a minimum value. Use the Min parameter to set the range.
ifMax Sets a restriction to a maximum value. Use the Min parameter to set the range.
ifVectorized Content can be a vector of numeric values, separated by blank or semicolon (not both!).
Electrode Flags:
ifMin Content is numeric. See Numeric flags for further restrictions.
ifMax Content is numeric. See Numeric flags for further restrictions.
ifVectorized Content can be a vector of electrodes, separated by blank or semicolon (not both!).
ifNoTHRCheck Do not check the AMP field to be higher then the THR field (from Settings/Signal)
ifNoMCLCheck Do not check the AMP field to be lower then the MCL field (from Settings/Signal)
String Flags:
ifNonEmpty Content must not be empty.
ifEnumeration Content must be a chosen one from the list given in Unit string. Use the Unit parameter to set the list of atoms selected by ;
ifCaseSensitive Content is case sensitive.
ifUpperCase Content will be converted to upper case.
ifLowerCase Content will be converted to lower case.
File Name Flages:
ifAbsolute Absolute file name including path name.
ifRelativeDataDir1 File name, relative to the data directory #1 (index = 0)
ifRelativeDataDir2 File name, relative to the data directory #2 (index = 1)
ifRelativeDataDir3 File name, relative to the data directory #3 (index = 2)
ifRelativeDataDir4 File name, relative to the data directory #4 (index = 3)
ifRelativeDataDir5 File name, relative to the data directory #5 (index = 4)
ifRelativeDataDir6 File name, relative to the data directory #6 (index = 5)
ifRelativeDataDir7 File name, relative to the data directory #7 (index = 6)
System Flags:
ifIndex Column is an index column. Used for renumbering of index functionality.
ifDisabled Column will be disabled. Not implemented yet!

Inheritance Hierarchy

System..::..Object
ExpSuite..::..clsItemList

See Also

clsItemList Members


clsItemList Members

[image]

ExpSuite
clsItemList Members
clsItemList Class Methods Properties See Also Send Feedback

The clsItemList type exposes the following members.

Methods

 | Name | Description
Protected method | AddCol | Add a column to the item list.
Protected method | Append | Append a CSV file to the existing item list.
Protected method | CheckItem(Int32, String%) | Check the content of an item for a valid value according to defined flags of the column.
Protected method | CheckItem(String, String) | Check if value (szX) is a valid data type for column Col.
Protected method | Clear | Clears a defined item list.
Protected method | ItemStamp | Stamp the current item as "processed without errors".
Protected method | Load | Load an item list from a CSV file.
Protected method | NextItem(Single) | Notify Framework about processing of next item in experiment.
Protected method | NextItem(Int32, Single) | Notify Framework about processing of next item in experiment.
Public method | RenumberIndex | Get or set the number of columns in the item list.
Protected method | Reset | Reset item list to a new, not defined one.
Protected method | SetOptimalColWidth | Sets the optimal column width for displaying the item list.
Protected method | ShuffleItems(array<Int32>[]()[][]) | Shuffle items.
Protected method | ShuffleItems(Int32, Int32) | Shuffle items.

Properties

 | Name | Description
Protected property | AppendToItem[([( Int32, Int32, Boolean])]) | Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.
Protected property | AppendToItem[([( Int32, String, Boolean])]) | Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.
Protected property | ColCaption | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColCount | Get the number of columns in the item list.
Protected property | ColFlag | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColIndex | Get the index of a column described by caption. This property is useful with experiment depending item lists, where the position of a column may move and the caption still remains.
Protected property | ColMax | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColMin | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColUnit | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | GetIndexCol | Get the index of the column defined as the Index-column.
Protected property | Item[([( Int32, Int32])]) | Get/Set the content of item at given column.
Protected property | Item[([( Int32, String])]) | Get/Set the content of item at given column.
Protected property | ItemCount | Get the number of items in the item list.
Protected property | ItemIndex | Set the index of selected item.
Public property | ItemStatus | Get/Set the item status.
Protected property | TextMatrix | TextMatrix sets/gets the content of the item list table.

See Also

clsItemList Class


clsItemList Methods

[image]

ExpSuite
clsItemList Methods
clsItemList Class See Also Send Feedback

The clsItemList type exposes the following members.

Methods

 | Name | Description
Protected method | AddCol | Add a column to the item list.
Protected method | Append | Append a CSV file to the existing item list.
Protected method | CheckItem(Int32, String%) | Check the content of an item for a valid value according to defined flags of the column.
Protected method | CheckItem(String, String) | Check if value (szX) is a valid data type for column Col.
Protected method | Clear | Clears a defined item list.
Protected method | ItemStamp | Stamp the current item as "processed without errors".
Protected method | Load | Load an item list from a CSV file.
Protected method | NextItem(Single) | Notify Framework about processing of next item in experiment.
Protected method | NextItem(Int32, Single) | Notify Framework about processing of next item in experiment.
Public method | RenumberIndex | Get or set the number of columns in the item list.
Protected method | Reset | Reset item list to a new, not defined one.
Protected method | SetOptimalColWidth | Sets the optimal column width for displaying the item list.
Protected method | ShuffleItems(array<Int32>[]()[][]) | Shuffle items.
Protected method | ShuffleItems(Int32, Int32) | Shuffle items.

See Also

clsItemList Class


AddCol Method

clsItemList..::..AddCol Method
clsItemList Class See Also Send Feedback
Add a column to the item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Sub AddCol ( _
    szCaption As String, _
    Flag As ItemListFlags, _
    szUnit As String, _
    dMin As Double, _
    dMax As Double _
)

Parameters

szCaption
Type: System..::..String
Caption. String with the caption (case doesn't matter) or Long with the index of the column.
Flag
Type: ItemListFlags
Flag restricting the content of all items in this column.
szUnit
Type: System..::..String
Unit or string with enumerated atoms separated by ";" if Flag is ifEnumeration.
dMin
Type: System..::..Double
Minimum allowed value if Flag is ifMin.
dMax
Type: System..::..Double
Maximum allowed value if Flag is ifMax.

Remarks

A new column will be added to the end (most right) of the item list. The columns will be identyfied by its Caption or the index. Flag can be set to restrict the content of the column. See ItemListFlags for possible values. Set to ifString if not used (=column entries are string without any restrictions) Unit, Min or Max parameters may be set, which are associated with given Flag. The index column is column 0 by default, this can be changed assigning flag ifIndex to a column.

See Also

clsItemList Class


Append Method

clsItemList..::..Append Method
clsItemList Class See Also Send Feedback
Append a CSV file to the existing item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function Append ( _
    szFile As String, _
    pbStatus As ProgressBar _
) As String

Parameters

szFile
Type: System..::..String
File name.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progress bar status

Return Value

Error message. Empty if no errors.

Remarks

The number of columns and the captions will be compared between the loaded and defined item list and warnings will be displayed in case of mismatch.

See Also

clsItemList Class


CheckItem Method

[image]

ExpSuite
clsItemList..::..CheckItem Method
clsItemList Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | CheckItem(Int32, String%) | Check the content of an item for a valid value according to defined flags of the column.
Protected method | CheckItem(String, String) | Check if value (szX) is a valid data type for column Col.

See Also

clsItemList Class
clsItemList Members


CheckItem Method (Int32, String)

clsItemList..::..CheckItem Method (Int32, String%)
clsItemList Class See Also Send Feedback
Check the content of an item for a valid value according to defined flags of the column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function CheckItem ( _
    Col As Integer, _
    ByRef szX As String _
) As String

Parameters

Col
Type: System..::..Int32
Column selector. String for selection by caption or Long for selection by index.
szX
Type: System..::..String %
Value which will be checked against the restrictions. If the value should be a numeric one, it will be converted to double and back to string.

Return Value

Error message. Empty if szX suits the restrictions.

Remarks

By using CheckItem, the content of an item can be checked before writing to the item list. CheckItem checks szX according to rules set by flags for given column Col and results in a string containing an error message. If the content szX is correct, CheckItem results in an empty string.

See Also

clsItemList Class
CheckItem Overload


CheckItem Method (String, String)

clsItemList..::..CheckItem Method (String, String)
clsItemList Class See Also Send Feedback
Check if value (szX) is a valid data type for column Col.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function CheckItem ( _
    Col As String, _
    szX As String _
) As String

Parameters

Col
Type: System..::..String
Column name as string.
szX
Type: System..::..String
Value to check.

Return Value

Error message if data is not valid.

See Also

clsItemList Class
CheckItem Overload


Clear Method

clsItemList..::..Clear Method
clsItemList Class See Also Send Feedback
Clears a defined item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Sub Clear

Remarks

All items in the item list will be removed, all columns set to their default. The definitions of columns remain unchanged. Reset must have been called before executing Clear.

See Also

clsItemList Class


ItemStamp Method

clsItemList..::..ItemStamp Method
clsItemList Class See Also Send Feedback
Stamp the current item as "processed without errors".

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Sub ItemStamp ( _
    szStamp As String _
)

Parameters

szStamp
Type: System..::..String
Stamp for the first column with this string. If omited, szStamp=" *"

Remarks

This function is for backwards compatibility only. It has been used to show which item is currently being processed. Now use ItemStatus[([( Int32, String])]) to set the status of the item like fresh, processing or processed. The item list will be scrolled to ensure the stamped item to be visible for the user. Current implementation inserts the szStamp after the content of the first column.

See Also

clsItemList Class


Load Method

clsItemList..::..Load Method
clsItemList Class See Also Send Feedback
Load an item list from a CSV file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function Load ( _
    szFile As String, _
    pbStatus As ProgressBar _
) As String

Parameters

szFile
Type: System..::..String
File name of the Item list.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progress bar status.

Return Value

Error message. Empty if no errors.

Remarks

The number of columns and the captions will be compared between the loaded and defined item list and warnings will be displayed in case of mismatch.

See Also

clsItemList Class


NextItem Method

[image]

ExpSuite
clsItemList..::..NextItem Method
clsItemList Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | NextItem(Single) | Notify Framework about processing of next item in experiment.
Protected method | NextItem(Int32, Single) | Notify Framework about processing of next item in experiment.

See Also

clsItemList Class
clsItemList Members


NextItem Method (Single)

clsItemList..::..NextItem Method (Single)
clsItemList Class See Also Send Feedback
Notify Framework about processing of next item in experiment.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function NextItem ( _
    sProgress As Single _
) As Boolean

Parameters

sProgress
Type: System..::..Single
Optional value of the progress bar in percent [0...100]. The progress bars (in experiment and main screens) will be set only if the progress bar is not synced to the break.

Return Value

TRUE if the last item of the experiment hase been processed. FALSE if there are any items left.

Remarks

NextItem increases the item index and provides all functionality which depends on increasing item as breaks, beeps, logging. Call NextItem to set the next item to stimulate. NextItem returns TRUE if the end of experiment was reached and FALSE otherwise. NextItem will process following tasks:
  • Handle beeps
  • Update labels
  • Induce a break, if necessary. In this case NextItem will terminate after the break is done (or Cancel ocurs).

    • See Also

    clsItemList Class
    NextItem Overload


NextItem Method (Int32, Single)

clsItemList..::..NextItem Method (Int32, Single)
clsItemList Class See Also Send Feedback
Notify Framework about processing of next item in experiment.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function NextItem ( _
    lNrInterleaved As Integer, _
    sProgress As Single _
) As Boolean

Parameters

lNrInterleaved
Type: System..::..Int32
Number of interleaved items in experiment.
sProgress
Type: System..::..Single
Optional value of the progress bar in percent [0...100]. The progress bars (in experiment and main screens) will be set only if the progress bar is not synced to the break.

Return Value

TRUE if the last item of the experiment hase been processed. FALSE if there are any items left.

Remarks

NextItem returns the next item index within the interleaved range and provides all functionality which depends on increasing item as breaks, beeps, logging. NextItem returns TRUE if the end of experiment was reached and FALSE otherwise. NextItem will process following tasks:
  • Handle beeps
  • Update labels
  • Induce a break, if necessary. In this case NextItem will terminate after the break is done (or Cancel ocurs).

    • See Also

    clsItemList Class
    NextItem Overload


RenumberIndex Method

clsItemList..::..RenumberIndex Method
clsItemList Class See Also Send Feedback
Get or set the number of columns in the item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub RenumberIndex

Remarks

Obsolete function: For backwards compatibility only

See Also

clsItemList Class


Reset Method

clsItemList..::..Reset Method
clsItemList Class See Also Send Feedback
Reset item list to a new, not defined one.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Sub Reset

Remarks

The item list will be initialized to an undefined one. All column definitions, all items will be removed. No item list will available after Reset, thus call AddCol immediatly after Reset.

See Also

clsItemList Class


SetOptimalColWidth Method

clsItemList..::..SetOptimalColWidth Method
clsItemList Class See Also Send Feedback
Sets the optimal column width for displaying the item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Sub SetOptimalColWidth

Remarks

See Also

clsItemList Class


ShuffleItems Method

[image]

ExpSuite
clsItemList..::..ShuffleItems Method
clsItemList Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | ShuffleItems(array<Int32>[]()[][]) | Shuffle items.
Protected method | ShuffleItems(Int32, Int32) | Shuffle items.

See Also

clsItemList Class
clsItemList Members


ShuffleItems Method (Int32[])

clsItemList..::..ShuffleItems Method (array<Int32>[]()[][])
clsItemList Class See Also Send Feedback
Shuffle items.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Sub ShuffleItems ( _
    lIdx As Integer() _
)

Parameters

lIdx
Type: array< System..::..Int32 >[]()[][]
Array with indicies of items to shuffle.

Remarks

Items with the indecies given in the array lIdx.

See Also

clsItemList Class
ShuffleItems Overload


ShuffleItems Method (Int32, Int32)

clsItemList..::..ShuffleItems Method (Int32, Int32)
clsItemList Class See Also Send Feedback
Shuffle items.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Function ShuffleItems ( _
    lBeg As Integer, _
    lEnd As Integer _
) As String

Parameters

lBeg
Type: System..::..Int32
Shuffle from item index... (range).
lEnd
Type: System..::..Int32
Shuffle to item index... (end of range).

Return Value

[Missing <returns> documentation for "M:ExpSuite.clsItemList.ShuffleItems(System.Int32,System.Int32)"]

Remarks

Shuffle all items from lBeg to lEnd.

See Also

clsItemList Class
ShuffleItems Overload


clsItemList Properties

[image]

ExpSuite
clsItemList Properties
clsItemList Class See Also Send Feedback

The clsItemList type exposes the following members.

Properties

 | Name | Description
Protected property | AppendToItem[([( Int32, Int32, Boolean])]) | Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.
Protected property | AppendToItem[([( Int32, String, Boolean])]) | Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.
Protected property | ColCaption | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColCount | Get the number of columns in the item list.
Protected property | ColFlag | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColIndex | Get the index of a column described by caption. This property is useful with experiment depending item lists, where the position of a column may move and the caption still remains.
Protected property | ColMax | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColMin | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | ColUnit | Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.
Protected property | GetIndexCol | Get the index of the column defined as the Index-column.
Protected property | Item[([( Int32, Int32])]) | Get/Set the content of item at given column.
Protected property | Item[([( Int32, String])]) | Get/Set the content of item at given column.
Protected property | ItemCount | Get the number of items in the item list.
Protected property | ItemIndex | Set the index of selected item.
Public property | ItemStatus | Get/Set the item status.
Protected property | TextMatrix | TextMatrix sets/gets the content of the item list table.

See Also

clsItemList Class


AppendToItem Property

[image]

ExpSuite
clsItemList..::..AppendToItem Property
clsItemList Class See Also Send Feedback

Overload List

 | Name | Description
Protected property | AppendToItem[([( Int32, Int32, Boolean])]) | Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.
Protected property | AppendToItem[([( Int32, String, Boolean])]) | Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.

See Also

clsItemList Class
clsItemList Members


AppendToItem Property (Int32, Int32, Boolean)

clsItemList..::..AppendToItem Property (Int32, Int32, Boolean)
clsItemList Class See Also Send Feedback
Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend WriteOnly Property AppendToItem ( _
    lItem As Integer, _
    lCol As Integer, _
    AddBeforeCellContent As Boolean _
) As String
    Set

Parameters

lItem
Type: System..::..Int32
Index of the item, beginning with 0.
lCol
Type: System..::..Int32
Column selector. Integer for selection by index.
AddBeforeCellContent
Type: System..::..Boolean
Append existing content to new content (default: false).

Remarks

The column can be selected by its caption. The content won't be checked for validity.

See Also

clsItemList Class
AppendToItem Overload


AppendToItem Property (Int32, String, Boolean)

clsItemList..::..AppendToItem Property (Int32, String, Boolean)
clsItemList Class See Also Send Feedback
Add content to cell at given row and column. By default the new value will be appended to the existing item. Set 'AddBeforeCellContent' true to append existing cell content to new value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend WriteOnly Property AppendToItem ( _
    lItem As Integer, _
    Col As String, _
    AddBeforeCellContent As Boolean _
) As String
    Set

Parameters

lItem
Type: System..::..Int32
Index of the item, beginning with 0.
Col
Type: System..::..String
Column selector. String for selection by name.
AddBeforeCellContent
Type: System..::..Boolean
Append existing content to new content (default: false).

Remarks

The column can be selected by its caption. The content won't be checked for validity.

See Also

clsItemList Class
AppendToItem Overload


ColCaption Property

clsItemList..::..ColCaption Property
clsItemList Class See Also Send Feedback
Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ColCaption ( _
    lCol As Integer _
) As String
    Get
    Set

Parameters

lCol
Type: System..::..Int32
Column index.

Field Value

Return Value

Caption of the column.

Remarks

See Also

clsItemList Class


ColCount Property

clsItemList..::..ColCount Property
clsItemList Class See Also Send Feedback
Get the number of columns in the item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend ReadOnly Property ColCount As Integer
    Get

Field Value

Return Value

Number of columns in the item list.

Remarks

See Also

clsItemList Class


ColFlag Property

clsItemList..::..ColFlag Property
clsItemList Class See Also Send Feedback
Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ColFlag ( _
    lCol As Integer _
) As ItemListFlags
    Get
    Set

Parameters

lCol
Type: System..::..Int32
Column index.

Field Value

Return Value

Flag restricting the content.

Remarks

See Also

clsItemList Class


ColIndex Property

clsItemList..::..ColIndex Property
clsItemList Class See Also Send Feedback
Get the index of a column described by caption. This property is useful with experiment depending item lists, where the position of a column may move and the caption still remains.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend ReadOnly Property ColIndex ( _
    Col As String _
) As Integer
    Get

Parameters

Col
Type: System..::..String
Caption of a column

Field Value

Return Value

Column index

Remarks

ColIndex returns the index of a column, which was found for the given caption Col.

See Also

clsItemList Class


ColMax Property

clsItemList..::..ColMax Property
clsItemList Class See Also Send Feedback
Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ColMax ( _
    lCol As Integer _
) As Double
    Get
    Set

Parameters

lCol
Type: System..::..Int32
Column index.

Field Value

Return Value

Maximum allowed value.

Remarks

See Also

clsItemList Class


ColMin Property

clsItemList..::..ColMin Property
clsItemList Class See Also Send Feedback
Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ColMin ( _
    lCol As Integer _
) As Double
    Get
    Set

Parameters

lCol
Type: System..::..Int32
Column index.

Field Value

Return Value

Minimum allowed value.

Remarks

See Also

clsItemList Class


ColUnit Property

clsItemList..::..ColUnit Property
clsItemList Class See Also Send Feedback
Col[Flag, Min, Max, Unit, Caption] sets/gets the Flags, minimum value, maximum value, the unit or the caption of a column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ColUnit ( _
    lCol As Integer _
) As String
    Get
    Set

Parameters

lCol
Type: System..::..Int32
Column index.

Field Value

Return Value

Unit or string with enumerated atoms separated by ";" if flag is ifEnumeration.

Remarks

See Also

clsItemList Class


GetIndexCol Property

clsItemList..::..GetIndexCol Property
clsItemList Class See Also Send Feedback
Get the index of the column defined as the Index-column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend ReadOnly Property GetIndexCol As Integer
    Get

Field Value

Return Value

Column index.

Remarks

This column will be stamped with .ItemStamp

See Also

clsItemList Class


Item Property

[image]

ExpSuite
clsItemList..::..Item Property
clsItemList Class See Also Send Feedback

Overload List

 | Name | Description
Protected property | Item[([( Int32, Int32])]) | Get/Set the content of item at given column.
Protected property | Item[([( Int32, String])]) | Get/Set the content of item at given column.

See Also

clsItemList Class
clsItemList Members


Item Property (Int32, Int32)

clsItemList..::..Item Property (Int32, Int32)
clsItemList Class See Also Send Feedback
Get/Set the content of item at given column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property Item ( _
    lItem As Integer, _
    lCol As Integer _
) As String
    Get
    Set

Parameters

lItem
Type: System..::..Int32
Index of the item, beginning with 1.
lCol
Type: System..::..Int32
Column selector. Integer for selection by index.

Field Value

Return Value

Content of the item. Double variant if the column is a numeric scalar or electrode scalar. String variant otherwise.

Remarks

Item returns the content of an item at given column. The column can be selected by its index. The content won't be checked for validity - use CheckItem before setting items with unknown content. If the item column is set to be numeric scalar or electrode scalar, the variant returned by Item is of data type double. Otherwise Item returns a string variant.

See Also

clsItemList Class
Item Overload


Item Property (Int32, String)

clsItemList..::..Item Property (Int32, String)
clsItemList Class See Also Send Feedback
Get/Set the content of item at given column.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property Item ( _
    lItem As Integer, _
    Col As String _
) As String
    Get
    Set

Parameters

lItem
Type: System..::..Int32
Index of the item, beginning with 0.
Col
Type: System..::..String
Column selector. String for selection by name.

Field Value

Return Value

Content of the item. Double variant if the column is a numeric scalar or electrode scalar. String variant otherwise.

Remarks

Item returns the content of an item at given column. The column can be selected by its caption. The content won't be checked for validity - use CheckItem before setting items with unknown content. If the item column is set to be numeric scalar or electrode scalar, the variant returned by Item is of data type double. Otherwise Item returns a string variant.

See Also

clsItemList Class
Item Overload


ItemCount Property

clsItemList..::..ItemCount Property
clsItemList Class See Also Send Feedback
Get the number of items in the item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ItemCount As Integer
    Get
    Set

Field Value

Return Value

Number of items in the item list. Returns 0 for disabled item list.

Remarks

ItemCount returns the number of items in the item list.

See Also

clsItemList Class


ItemIndex Property

clsItemList..::..ItemIndex Property
clsItemList Class See Also Send Feedback
Set the index of selected item.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property ItemIndex As Integer
    Get
    Set

Field Value

Return Value

Item index

Remarks

ItemIndex starts with 0 and its maximum value is ItemCount-1. ItemIndex returns -1 if no item has been selected.

See Also

clsItemList Class


ItemStatus Property

clsItemList..::..ItemStatus Property
clsItemList Class See Also Send Feedback
Get/Set the item status.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property ItemStatus ( _
    lRow As Integer, _
    szStamp As String _
) As Status
    Get
    Set

Parameters

lRow
Type: System..::..Int32
Index of the item.
szStamp
Type: System..::..String

Field Value

Return Value

Remarks

See Also

clsItemList Class


TextMatrix Property

clsItemList..::..TextMatrix Property
clsItemList Class See Also Send Feedback
TextMatrix sets/gets the content of the item list table.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Property TextMatrix ( _
    lRow As Integer, _
    lCol As Integer _
) As String
    Get
    Set

Parameters

lRow
Type: System..::..Int32
lCol
Type: System..::..Int32

Field Value

Return Value

Remarks

Don't use it. TextMatrix is very similar to Item, the only difference is the row index: it refers to the row in the item list table including the first row with captions. It was implemented to provide a kind of compatibility to the TextMatrix method of the FFF object, which is used for the implementation of the item list. The column can be refered by its index only (no indexing by caption here).

See Also

clsItemList Class


Config Class

Config Class
Members See Also Send Feedback
Application Module. REQUIRED. Configuration of the ExpSuite application.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Config

Remarks

Set configuration parameters like:
  • Number of audio channels the application needs (PLAYER_MAXCHANNELS)
  • Number of experiment types available (procedures) (ExpTypeNumber)
  • Number of columns to be regarded for sorting (Main Window/Sort Item List) (FLGSORTCOLS)
  • Experiment specific global data

    • Inheritance Hierarchy

    System..::..Object
    ExpSuite..::..Config

    See Also

    Config Members


Config Members

[image]

ExpSuite
Config Members
Config Class Fields See Also Send Feedback

The Config type exposes the following members.

Fields

Name | Description
ExpTypeNumber | Number of experiment types available.
FLGSORTCOLS | Number of columns to be regarded for sorting (Main Window/Sort Item List)
PLAYER_MAXCHANNELS | Number of audio channels the application needs.

See Also

Config Class


Config Fields

[image]

ExpSuite
Config Fields
Config Class See Also Send Feedback

The Config type exposes the following members.

Fields

Name | Description
ExpTypeNumber | Number of experiment types available.
FLGSORTCOLS | Number of columns to be regarded for sorting (Main Window/Sort Item List)
PLAYER_MAXCHANNELS | Number of audio channels the application needs.

See Also

Config Class


ExpTypeNumber Field

Config..::..ExpTypeNumber Field
Config Class See Also Send Feedback
Number of experiment types available.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Const ExpTypeNumber As Short

Remarks

See Also

Config Class


FLGSORTCOLS Field

Config..::..FLGSORTCOLS Field
Config Class See Also Send Feedback
Number of columns to be regarded for sorting (Main Window/Sort Item List)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Const FLGSORTCOLS As Short

Remarks

See Also

Config Class


PLAYER_MAXCHANNELS Field

Config..::..PLAYER_MAXCHANNELS Field
Config Class See Also Send Feedback
Number of audio channels the application needs.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Const PLAYER_MAXCHANNELS As Short

Remarks

See Also

Config Class


Create Class

Create Class
Members See Also Send Feedback
User Module. Optional. Examples of creating stimuli in ExpSuite.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Create

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Create

See Also

Create Members


Create Members

[image]

ExpSuite
Create Members
Create Class Methods See Also Send Feedback

The Create type exposes the following members.

Methods

Name | Description
CreateStimFileName |
CreateStimulus |

See Also

Create Class


Create Methods

[image]

ExpSuite
Create Methods
Create Class See Also Send Feedback

The Create type exposes the following members.

Methods

Name | Description
CreateStimFileName |
CreateStimulus |

See Also

Create Class


CreateStimFileName Method

Create..::..CreateStimFileName Method
Create Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.Create.CreateStimFileName(System.Double@)"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CreateStimFileName ( _
    ByRef sFreq As Double _
) As String

Parameters

sFreq
Type: System..::..Double %

[Missing <param name="sFreq"/> documentation for "M:ExpSuite.Create.CreateStimFileName(System.Double@)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.Create.CreateStimFileName(System.Double@)"]

See Also

Create Class


CreateStimulus Method

Create..::..CreateStimulus Method
Create Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.Create.CreateStimulus(System.String@,System.String@)"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CreateStimulus ( _
    ByRef szFn As String, _
    ByRef szFreq As String _
) As String

Parameters

szFn
Type: System..::..String %

[Missing <param name="szFn"/> documentation for "M:ExpSuite.Create.CreateStimulus(System.String@,System.String@)"]

szFreq
Type: System..::..String %

[Missing <param name="szFreq"/> documentation for "M:ExpSuite.Create.CreateStimulus(System.String@,System.String@)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.Create.CreateStimulus(System.String@,System.String@)"]

See Also

Create Class


CSVParser Class

CSVParser Class
Members See Also Send Feedback
FrameWork - CSV files support.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class CSVParser

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..CSVParser

See Also

CSVParser Members


CSVParser Members

[image]

ExpSuite
CSVParser Members
CSVParser Class Methods Properties See Also Send Feedback

The CSVParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseString | Parse content of a string to a 2D-string array.
Public method | QuoteCell | Quote a single cell according to the CSV rules.
Public method | ReadArr | Read content of a CSV file to a 2D-string array.
Public method | ReadDGV | Read content of a CSV file to a DataGridView object.
Public method | UnquoteCell | Unquote a single cell - remove quotas
Public method | WriteArr | Write content of a 2D-string array to a CSV file.
Public method | WriteDGV | Write content of a DataGridView to a CSV file.

Properties

 | Name | Description
Public property | Quota | Set content quota character. Content will be quoted wiht this character if it contains a separator charachter.
Public property | Separator | Get the separator between the values.

See Also

CSVParser Class


CSVParser Methods

[image]

ExpSuite
CSVParser Methods
CSVParser Class See Also Send Feedback

The CSVParser type exposes the following members.

Methods

 | Name | Description
Public method | ParseString | Parse content of a string to a 2D-string array.
Public method | QuoteCell | Quote a single cell according to the CSV rules.
Public method | ReadArr | Read content of a CSV file to a 2D-string array.
Public method | ReadDGV | Read content of a CSV file to a DataGridView object.
Public method | UnquoteCell | Unquote a single cell - remove quotas
Public method | WriteArr | Write content of a 2D-string array to a CSV file.
Public method | WriteDGV | Write content of a DataGridView to a CSV file.

See Also

CSVParser Class


ParseString Method

CSVParser..::..ParseString Method
CSVParser Class See Also Send Feedback
Parse content of a string to a 2D-string array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function ParseString ( _
    szSource As String, _
    ByRef szArr As String(,), _
    pbStatus As ProgressBar _
) As String

Parameters

szSource
Type: System..::..String
Row in CSV format.
szArr
Type: array< System..::..String ,2>[,](,)[,][,]%
Array with values retrieved from szSource.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progressbar to show the progress of parsing. Optional.

Return Value

Error message, empty if no error ocured.

Remarks

A string of a CSV file will be parsed and all found values well be copied to szArr().
Rules (if " is Quota and , is Separator):
  • " : mszQuota
  • , : Separator
  • row : cell,cell,cell
  • not quoted cells:
  • ab,cd -> two cells: ab and cd
  • ab"cd -> ab"cd
  • ab""cd -> ab""cd
  • ab" -> ab"
  • ab"" -> ab""
  • quoted cells:
  • "ab" -> ab
  • "ab,cd" -> ab,cd
  • "ab"cd -> ab and ignore cd
  • "ab"de" -> ab and ignore cd
  • ""abcd -> empty cell and ignore abcd
  • "ab""cd" -> ab"cd
  • "ab"",cd" -> ab"cd
  • """abcd" -> "abcd
  • last quoted cell in a row:
  • "abEOL -> ab
  • "ab"EOL -> ab
  • "ab""EOL -> ab"
  • "ab"""EOL -> ab"
  • "ab""cdEOL -> ab"cd
  • Empty row -> one empty cell

    • See Also

    CSVParser Class


QuoteCell Method

CSVParser..::..QuoteCell Method
CSVParser Class See Also Send Feedback
Quote a single cell according to the CSV rules.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function QuoteCell ( _
    szCell As String _
) As String

Parameters

szCell
Type: System..::..String
Content of a single cell.

Return Value

Quoted value.

Remarks

See Also

CSVParser Class


ReadArr Method

CSVParser..::..ReadArr Method
CSVParser Class See Also Send Feedback
Read content of a CSV file to a 2D-string array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function ReadArr ( _
    szFile As String, _
    ByRef szArr As String(,), _
    pbStatus As ProgressBar _
) As String

Parameters

szFile
Type: System..::..String
File name of the CSV file.
szArr
Type: array< System..::..String ,2>[,](,)[,][,]%
Array with the content. szArr() will be resized to the correct size.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progress bar to show the progrees of parsing.

Return Value

Error message:
  • Empty: no error ocured.
  • File not found: szFile is empty or the file specified by szFile couldn't be found.
  • File is empty: File could be opened but is empty
  • System Error + Error description: A system error occured. See VB Help for the explanation of the error message.

    • Remarks

    ReadArr loads file with the file name szFile, parses the content and copies the data to szArr().
    Rules (if " is Quota and , is Separator):
  • " : mszQuota
  • , : Separator
  • row : cell,cell,cell
  • not quoted cells:
  • ab,cd -> two cells: ab and cd
  • ab"cd -> ab"cd
  • ab""cd -> ab""cd
  • ab" -> ab"
  • ab"" -> ab""
  • quoted cells:
  • "ab" -> ab
  • "ab,cd" -> ab,cd
  • "ab"cd -> ab and ignore cd
  • "ab"de" -> ab and ignore cd
  • ""abcd -> empty cell and ignore abcd
  • "ab""cd" -> ab"cd
  • "ab"",cd" -> ab"cd
  • """abcd" -> "abcd
  • last quoted cell in a row:
  • "abEOL -> ab
  • "ab"EOL -> ab
  • "ab""EOL -> ab"
  • "ab"""EOL -> ab"
  • "ab""cdEOL -> ab"cd
  • Empty row -> one empty cell

    • See Also

    CSVParser Class


ReadDGV Method

CSVParser..::..ReadDGV Method
CSVParser Class See Also Send Feedback
Read content of a CSV file to a DataGridView object.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function ReadDGV ( _
    szFile As String, _
    ByRef dgvDest As DataGridView, _
    pbStatus As ProgressBar _
) As String

Parameters

szFile
Type: System..::..String
File name of the CSV file.
dgvDest
Type: System.Windows.Forms..::..DataGridView %
Datagridview object as destination for the data.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progress bar to show the progress of parsing.

Return Value

Error message, empty if no error ocured.

Remarks

Rules (if " is Quota and , is Separator):
  • " : mszQuota
  • , : Separator
  • row : cell,cell,cell
  • not quoted cells:
  • ab,cd -> two cells: ab and cd
  • ab"cd -> ab"cd
  • ab""cd -> ab""cd
  • ab" -> ab"
  • ab"" -> ab""
  • quoted cells:
  • "ab" -> ab
  • "ab,cd" -> ab,cd
  • "ab"cd -> ab and ignore cd
  • "ab"de" -> ab and ignore cd
  • ""abcd -> empty cell and ignore abcd
  • "ab""cd" -> ab"cd
  • "ab"",cd" -> ab"cd
  • """abcd" -> "abcd
  • last quoted cell in a row:
  • "abEOL -> ab
  • "ab"EOL -> ab
  • "ab""EOL -> ab"
  • "ab"""EOL -> ab"
  • "ab""cdEOL -> ab"cd
  • Empty row -> one empty cell

    • See Also

    CSVParser Class


UnquoteCell Method

CSVParser..::..UnquoteCell Method
CSVParser Class See Also Send Feedback
Unquote a single cell - remove quotas

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function UnquoteCell ( _
    szCell As String _
) As String

Parameters

szCell
Type: System..::..String
Content of a single cell.

Return Value

Unquoted value.

Remarks

See Also

CSVParser Class


WriteArr Method

CSVParser..::..WriteArr Method
CSVParser Class See Also Send Feedback
Write content of a 2D-string array to a CSV file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function WriteArr ( _
    szFile As String, _
    szArr As String(,), _
    pbStatus As ProgressBar _
) As String

Parameters

szFile
Type: System..::..String
File Name of the new CSV file.
szArr
Type: array< System..::..String ,2>[,](,)[,][,]
Array with the data.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progress bar to show the progress of parsing.

Return Value

Error message, empty if no error ocured.

Remarks

Rules (if " is Quota and , is Separator):
  • row : cell,cell,cell
  • cell:
  • abcdef -> abcdef
  • abc,def -> "abc,def"
  • "abcdef -> """abcdef"
  • abc",def -> "abc"",def"
  • ab,cd,"ef -> "ab,cd""ef"

    • See Also

    CSVParser Class


WriteDGV Method

CSVParser..::..WriteDGV Method
CSVParser Class See Also Send Feedback
Write content of a DataGridView to a CSV file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function WriteDGV ( _
    szFile As String, _
    dgvSource As DataGridView, _
    pbStatus As ProgressBar _
) As String

Parameters

szFile
Type: System..::..String
File Name of the new CSV file.
dgvSource
Type: System.Windows.Forms..::..DataGridView
DataGridView object containing data.
pbStatus
Type: System.Windows.Forms..::..ProgressBar
Progress bar to show the progress of parsing.

Return Value

Error message, empty if no error ocured.

Remarks

Rules (if " is Quota and , is Separator):
  • row : cell,cell,cell
  • cell:
  • abcdef -> abcdef
  • abc,def -> "abc,def"
  • "abcdef -> """abcdef"
  • abc",def -> "abc"",def"
  • ab,cd,"ef -> "ab,cd""ef"

    • See Also

    CSVParser Class


CSVParser Properties

[image]

ExpSuite
CSVParser Properties
CSVParser Class See Also Send Feedback

The CSVParser type exposes the following members.

Properties

 | Name | Description
Public property | Quota | Set content quota character. Content will be quoted wiht this character if it contains a separator charachter.
Public property | Separator | Get the separator between the values.

See Also

CSVParser Class


Quota Property

CSVParser..::..Quota Property
CSVParser Class See Also Send Feedback
Set content quota character. Content will be quoted wiht this character if it contains a separator charachter.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Quota As String
    Get
    Set

Field Value

Return Value

Quota character

Remarks

See Also

CSVParser Class


Separator Property

CSVParser..::..Separator Property
CSVParser Class See Also Send Feedback
Get the separator between the values.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Separator As String
    Get
    Set

Field Value

Return Value

Separator character

Remarks

See Also

CSVParser Class


Events Class

Events Class
Members See Also Send Feedback
Application Module. REQUIRED. General events caused by user interaction.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Events

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Events

See Also

Events Members


Events Members

[image]

ExpSuite
Events Members
Events Class Methods See Also Send Feedback

The Events type exposes the following members.

Methods

Name | Description
OnConnect | Event on connect to the output devices.
OnCreateAllStimuli | Event on Create All Stimuli.
OnCreateItemList | Event on Create Item List from the main window.
OnDisconnect | Event on disconnect to the output devices
OnExpShow | Event on start of the experiment, before showing the experiment screen.
OnLoad | Event on load of the application.
OnOutputResponse | Event on a response from the output device (YAMI)
OnSnapshot | Event on Snapshot to the log file.
OnStartExperiment | Event on the Start of Experiment.
OnStimulateAll | Event on Stimulate All Stimuli.
OnStimulateSelected | Event on Stimulate Selected from the main window.

See Also

Events Class


Events Methods

[image]

ExpSuite
Events Methods
Events Class See Also Send Feedback

The Events type exposes the following members.

Methods

Name | Description
OnConnect | Event on connect to the output devices.
OnCreateAllStimuli | Event on Create All Stimuli.
OnCreateItemList | Event on Create Item List from the main window.
OnDisconnect | Event on disconnect to the output devices
OnExpShow | Event on start of the experiment, before showing the experiment screen.
OnLoad | Event on load of the application.
OnOutputResponse | Event on a response from the output device (YAMI)
OnSnapshot | Event on Snapshot to the log file.
OnStartExperiment | Event on the Start of Experiment.
OnStimulateAll | Event on Stimulate All Stimuli.
OnStimulateSelected | Event on Stimulate Selected from the main window.

See Also

Events Class


OnConnect Method

Events..::..OnConnect Method
Events Class See Also Send Feedback
Event on connect to the output devices.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnConnect

Remarks

This function will be called on a click on the "Connect" icon in the toolbar, in case the application was not connected.
Here you can disable connecting to a channel or perform some initializations you need on connect. To connect successfully to both channels, gblnConnectLeft and gblnConnectRight must be set to TRUE.

See Also

Events Class


OnCreateAllStimuli Method

Events..::..OnCreateAllStimuli Method
Events Class See Also Send Feedback
Event on Create All Stimuli.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnCreateAllStimuli

Remarks

This function will be called on a click on "Create All Stimuli" in the main window. It is expected to create all stimuli required to present the items in the item list.

See Also

Events Class


OnCreateItemList Method

Events..::..OnCreateItemList Method
Events Class See Also Send Feedback
Event on Create Item List from the main window.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function OnCreateItemList As Integer

Return Value

String describing an error or empty if an item list could be successfully created.

Remarks

This function will be called on click on the "Create List" in the main window. The item list should be created and filled with content, which is required to start an experiment. All Settings or Options, on which the item list depends must be validated to avoid run time errors.

See Also

Events Class


OnDisconnect Method

Events..::..OnDisconnect Method
Events Class See Also Send Feedback
Event on disconnect to the output devices

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnDisconnect

Remarks

This function will be called on a click on the "Connect" icon in the toolbar, in case the application was connected.

See Also

Events Class


OnExpShow Method

Events..::..OnExpShow Method
Events Class See Also Send Feedback
Event on start of the experiment, before showing the experiment screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnExpShow ( _
    lType As Integer, _
    rectPos As RECT, _
    lFlags As EXPFLAGS _
)

Parameters

lType
Type: System..::..Int32
Experiment type (from Settings/Procedure/Experiment Type).
rectPos
Type: RECT
Position/size of the experiment screen (from Settings/Experiment Screen/Screen arrangment).
lFlags
Type: EXPFLAGS
Flags for the experiment procedure (from Settings/Experiment Screen/Screen Control).

Remarks

OnExpShow will be started on start of experiment and should be used to initialize the experiment setup, such as screen or input device.
Tasks to do, calling frmExp:
  • .Init to initialize the experiment screen according the selected experiment type
  • .SetResponseNames to set the captions on response buttons
  • .SetResponseButtons to assign the response buttons of HUI to reponses
  • .SetResponseKeys to assign the keyboard keys to responses
  • .SetRequestText to assing the correct request text on the experiment screen
    • After that, the experiment screen must be shown using frmExp.Show and moved/resized to the correct position/size using frmExp.SetSize. Then, you're done.

    See Also

    Events Class


OnLoad Method

Events..::..OnLoad Method
Events Class See Also Send Feedback
Event on load of the application.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnLoad

Remarks

Put following tasks here:
  • configuration of experiment types (for the number of types defined in Config)
  • configurations of experimental variables (Resize gvalExp and configure each variable)
  • configurations of experimental constants (Resize gconstExp and configure each constant)
  • define the item list
  • set callback functions

    • See Also

    Events Class
    ExpSuite Namespace
    FWintern..::..ItemList
    frmSettings..::..SetOnChangeCallback(OnChangeDelegate)
    frmSettings..::..SetOnLoadCallback(OnLoadDelegate)
    frmSettings..::..SetOnChangeCallback(OnChangeDelegate)
    frmSettings..::..SetOnExpTypeCallback(OnExpTypeChangeDelegate)
    INISettings..::..SignalDefault(Int32, Single, Single, Single, Single, Single, Single, Int32)


OnOutputResponse Method

Events..::..OnOutputResponse Method
Events Class See Also Send Feedback
Event on a response from the output device (YAMI)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnOutputResponse ( _
    szCmd As String, _
    varArgs As Object() _
)

Parameters

szCmd
Type: System..::..String
Command (OSC address) in format aaa/bbb/ccc
varArgs
Type: array< System..::..Object >[]()[][]
Parameters

Remarks

This event will be raised after receiving and processing a response/command from YAMI. All responses are provided to Events.OnOutputResponse, regardless previous processing by FrameWork.
Use OSC.SeparateCommand szCmd, szFunc to separate the individual address parts.

See Also

Events Class


OnSnapshot Method

Events..::..OnSnapshot Method
Events Class See Also Send Feedback
Event on Snapshot to the log file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnSnapshot

Remarks

This function will be called on a click on the "Snapshot" icon in the toolbar or menu Run/Snapshot. Before executing OnSnapshot, all settings have been logged - you don't need to do that.

See Also

Events Class


OnStartExperiment Method

Events..::..OnStartExperiment Method
Events Class See Also Send Feedback
Event on the Start of Experiment.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function OnStartExperiment ( _
    lRow As Integer _
) As String

Parameters

lRow
Type: System..::..Int32
First item to be presented.

Return Value

String with error description or empty if no error ocured.

Remarks

This function will be called on a click on the "Start Experiment" button in the main window. It can be executed using the menu Run/Start experiment from selected item. In this case lRow shows the selected item. Before calling OnStartExperiment, OnExpShow will be executed to intialize the experiment form. It is expected to show the start screen, wait for begin of experiment and then perform the experiment until the end of the item list (or any other stop condition of experiment)

See Also

Events Class


OnStimulateAll Method

Events..::..OnStimulateAll Method
Events Class See Also Send Feedback
Event on Stimulate All Stimuli.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnStimulateAll

Remarks

This function will be called on a click on the "Stimulate All" button in the main window. It is expected to present all stimuli from the item list without the experimental procedure such as schowing the screen

See Also

Events Class


OnStimulateSelected Method

Events..::..OnStimulateSelected Method
Events Class See Also Send Feedback
Event on Stimulate Selected from the main window.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function OnStimulateSelected ( _
    lRow As Integer, _
    lTO As Integer, _
    szLeft As String, _
    szRight As String _
) As String

Parameters

lRow
Type: System..::..Int32
Item for which stimulation has to be performed.
lTO
Type: System..::..Int32
Not used
szLeft
Type: System..::..String
Not used
szRight
Type: System..::..String
Not used

Return Value

String with error description or empty if no error ocured

Remarks

This function will be executed on a click on the "Stimulate Selected" button in the main window. One one ore more item(s) in the item list has been selected, for which the stimulation has to be performed. If more items were selected, OnStimulateSelected will be executed succesively for each item.

See Also

Events Class


EventsSettings Class

EventsSettings Class
Members See Also Send Feedback
User Module. Optional. Example of events handling changes in Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class EventsSettings

Remarks

Enable Callbacks in Events.OnLoad to provide these events.

Inheritance Hierarchy

System..::..Object
ExpSuite..::..EventsSettings

See Also

EventsSettings Members


EventsSettings Members

[image]

ExpSuite
EventsSettings Members
EventsSettings Class Methods See Also Send Feedback

The EventsSettings type exposes the following members.

Methods

Name | Description
OnChange | Callback on immediatly change of Settings in the Settings form.
OnExpTypeChange | Callback on immediatly change of experiment type in the Settings form.
OnLoad | Callback on load of Settings.
OnSet | Callback on set of Settings

See Also

EventsSettings Class


EventsSettings Methods

[image]

ExpSuite
EventsSettings Methods
EventsSettings Class See Also Send Feedback

The EventsSettings type exposes the following members.

Methods

Name | Description
OnChange | Callback on immediatly change of Settings in the Settings form.
OnExpTypeChange | Callback on immediatly change of experiment type in the Settings form.
OnLoad | Callback on load of Settings.
OnSet | Callback on set of Settings

See Also

EventsSettings Class


OnChange Method

EventsSettings..::..OnChange Method
EventsSettings Class See Also Send Feedback
Callback on immediatly change of Settings in the Settings form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnChange ( _
    lExpType As Integer _
)

Parameters

lExpType
Type: System..::..Int32

[Missing <param name="lExpType"/> documentation for "M:ExpSuite.EventsSettings.OnChange(System.Int32)"]

Remarks

OnChange callback will be executed on change of a value in Settings dialog. A click on OK is not required to execute OnChange - e.g. a text box loses its focus and OnChange will be executed immediatly.

Examples

The global variable gvarCallbackPar1 can be used to determine the current experiment type, which may have changed. I propose following sub:
CopyVB.NET
Public Sub OnChange()
 Dim lExpType As Long
 lExpType = CLng(gvarCallbackPar1)
 ... put your code here ...
End Sub

See Also

EventsSettings Class


OnExpTypeChange Method

EventsSettings..::..OnExpTypeChange Method
EventsSettings Class See Also Send Feedback
Callback on immediatly change of experiment type in the Settings form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnExpTypeChange ( _
    lOld As Integer, _
    lNew As Integer _
)

Parameters

lOld
Type: System..::..Int32

[Missing <param name="lOld"/> documentation for "M:ExpSuite.EventsSettings.OnExpTypeChange(System.Int32,System.Int32)"]

lNew
Type: System..::..Int32

[Missing <param name="lNew"/> documentation for "M:ExpSuite.EventsSettings.OnExpTypeChange(System.Int32,System.Int32)"]

Remarks

The experiment type changes on:
  • loading setting from file, old exp. type is set to -1 in this case
  • changing the experiment type in the Settings dialog
  • clearing the settings, old exp. type is set to -1 in this case
  • cancelling the settings, old exp. type: chosen in the Procedure tab, new exp. type: type valid before opening the settings form
    • OnExpType callback will be executed on a change of experiment type.

    See Also

    EventsSettings Class


OnLoad Method

EventsSettings..::..OnLoad Method
EventsSettings Class See Also Send Feedback
Callback on load of Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnLoad

Remarks

OnLoad callback will be executed on loading of the Settings dialog.
This gives a possibility to adapt the Settings dialog, before it have been shown.

See Also

EventsSettings Class


OnSet Method

EventsSettings..::..OnSet Method
EventsSettings Class See Also Send Feedback
Callback on set of Settings

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub OnSet

Remarks

OnSet callback will be executed on:
  • Loading settings from file, just after OnExpTypeChanged
  • click on OK in the Settings form
  • clear Settings to default, just after OnExpTypeChanged

    • See Also

    EventsSettings Class


frmAbout Class

frmAbout Class
Members See Also Send Feedback
FrameWork Module. Implementation of the About form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmAbout _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmAbout

See Also

frmAbout Members


frmAbout Members

[image]

ExpSuite
frmAbout Members
frmAbout Class Constructors See Also Send Feedback

The frmAbout type exposes the following members.

Constructors

 | Name | Description
Public method | frmAbout | Initializes a new instance of the frmAbout class

See Also

frmAbout Class


frmAbout Constructor

frmAbout Constructor
frmAbout Class See Also Send Feedback
Initializes a new instance of the frmAbout class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

frmAbout Class


frmExp Class

frmExp Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Experiment Screen and Subject Interaction.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmExp _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmExp

See Also

frmExp Members


frmExp Members

[image]

ExpSuite
frmExp Members
frmExp Class Methods See Also Send Feedback

The frmExp type exposes the following members.

Methods

 | Name | Description
Public method | AllowResizing | Enable/disable resizing and moving the experiment screen.
Public method | DisableResponse | Disable response controls.
Public method | EnableResponse | Enable response controls.
Public method | GetResponse | Get the response code.
Public method | GetValue | Get the response value from the subject.
Public method | Init | Initialize EXP module.
Public method | SetBreak | Set the experimental state to "break"
Public method | SetEndOfExperimentText | Sets the end-of-experimt text.
Public method | SetOnResponseCallback | Sets the callback on subject's response.
Public method | SetProgress | Set the value of progress bar.
Public method | SetRequestText | Sets the request text in the experiment. This may be the question to the subject or something else...
Public method | SetResponse | Set the response to a given code.
Public method | SetResponseButtons | Sets the HUI codes for the response, start and next buttons.
Public method | SetResponseKeys | Set the codes for the response, start and next keys.
Public method | SetResponseNames | Sets the caption of response buttons.
Public method | SetSize | Set the size and position of the experimental screen.
Public method | SetStartOfExperimentText | Sets the start-of-experiment text.
Public method | SetVisuCaption | Sets the caption of interval visualisation boxes (lblVisu)
Public method | ShowBlankScreen | Show blank experimental screen.
Public method | ShowEndScreen | Show the end-of-experiment screen.
Public method | ShowHighlightedItem | Highlight an interval on the experimental screen.
Public method | ShowNextScreen | Show the experimental screen for the next stimulus.
Public method | ShowStartScreen()()()() | Show the experimental start screen.
Public method | ShowStartScreen(String) | Show Start screen.
Public method | ShowStimScreen | Show the experimental stimulation screen and highlight current stimulation interval.

See Also

frmExp Class


frmExp Methods

[image]

ExpSuite
frmExp Methods
frmExp Class See Also Send Feedback

The frmExp type exposes the following members.

Methods

 | Name | Description
Public method | AllowResizing | Enable/disable resizing and moving the experiment screen.
Public method | DisableResponse | Disable response controls.
Public method | EnableResponse | Enable response controls.
Public method | GetResponse | Get the response code.
Public method | GetValue | Get the response value from the subject.
Public method | Init | Initialize EXP module.
Public method | SetBreak | Set the experimental state to "break"
Public method | SetEndOfExperimentText | Sets the end-of-experimt text.
Public method | SetOnResponseCallback | Sets the callback on subject's response.
Public method | SetProgress | Set the value of progress bar.
Public method | SetRequestText | Sets the request text in the experiment. This may be the question to the subject or something else...
Public method | SetResponse | Set the response to a given code.
Public method | SetResponseButtons | Sets the HUI codes for the response, start and next buttons.
Public method | SetResponseKeys | Set the codes for the response, start and next keys.
Public method | SetResponseNames | Sets the caption of response buttons.
Public method | SetSize | Set the size and position of the experimental screen.
Public method | SetStartOfExperimentText | Sets the start-of-experiment text.
Public method | SetVisuCaption | Sets the caption of interval visualisation boxes (lblVisu)
Public method | ShowBlankScreen | Show blank experimental screen.
Public method | ShowEndScreen | Show the end-of-experiment screen.
Public method | ShowHighlightedItem | Highlight an interval on the experimental screen.
Public method | ShowNextScreen | Show the experimental screen for the next stimulus.
Public method | ShowStartScreen()()()() | Show the experimental start screen.
Public method | ShowStartScreen(String) | Show Start screen.
Public method | ShowStimScreen | Show the experimental stimulation screen and highlight current stimulation interval.

See Also

frmExp Class


AllowResizing Method

frmExp..::..AllowResizing Method
frmExp Class See Also Send Feedback
Enable/disable resizing and moving the experiment screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub AllowResizing ( _
    blnEnable As Boolean _
)

Parameters

blnEnable
Type: System..::..Boolean
TRUE: resizing/moving enabled

Remarks

See Also

frmExp Class


DisableResponse Method

frmExp..::..DisableResponse Method
frmExp Class See Also Send Feedback
Disable response controls.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub DisableResponse

Remarks

See Also

frmExp Class


EnableResponse Method

frmExp..::..EnableResponse Method
frmExp Class See Also Send Feedback
Enable response controls.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub EnableResponse ( _
    blnAutoDisable As Boolean _
)

Parameters

blnAutoDisable
Type: System..::..Boolean
If blnAutoDisable is TRUE the experimental screen will automatically turn to disabled mode after a valid response.

Remarks

In ExpMode = 1 the first button remains disable until a valid numerical value is entered.

See Also

frmExp Class


GetResponse Method

frmExp..::..GetResponse Method
frmExp Class See Also Send Feedback
Get the response code.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function GetResponse ( _
    ByRef lResponse As Integer _
) As Boolean

Parameters

lResponse
Type: System..::..Int32 %
Response code

Return Value

True if any response was given, False otherwise.

Remarks

Following codes are available:
  • 0: First response button (usually Left or OK)
  • 1: Second response button (usually Right)
  • ...
  • ...
  • N: N-th response button (maximum number defined by AFC on Init)
  • ...
  • ...
  • 15: Last possible response button
  • 256: Button "Start"
  • 257: Button "Next"
  • 258: Button "Cancel"

    • See Also

    frmExp Class


GetValue Method

frmExp..::..GetValue Method
frmExp Class See Also Send Feedback
Get the response value from the subject.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function GetValue As Double

Return Value

Value. This is defined for ExpMode 1 only and it will be a numeric value.

Remarks

See Also

frmExp Class


Init Method

frmExp..::..Init Method
frmExp Class See Also Send Feedback
Initialize EXP module.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function Init ( _
    lExpMode As Integer, _
    lAFC As Integer, _
    lIFC As Integer, _
    Flags As EXPFLAGS _
) As String

Parameters

lExpMode
Type: System..::..Int32
ExpMode sets the mode of active experiment.
lAFC
Type: System..::..Int32
Alternative Forced Choice, sets the number of visible buttons in experiment.
lIFC
Type: System..::..Int32
Interval Forced Choice, sets the number of stimuli parts in the stimulus sequence.
Flags
Type: EXPFLAGS
Flags: Bit 0: start button visible; Bit 1: response buttons visible; Bit 2: next button visible.

Return Value

Return_value_or_object

Remarks

Defined experiment modes:$EOL$
  • 0: pure AFC/IFC experiment. Visual items are arranged vertically. Response buttons are arranged horizontally below the items.$EOL$
  • 1: numeric open range combined with AFC/IFC experiment. The first button is disabled until a valid numerical value is entered in the TextBox txtNum.$EOL$
  • 2: 2AFC/2IFC, used for binaural loudness balancing. Static screen arrangment. Set AFC and IFC to 0 in this mode.$EOL$
  • 3: pure AFC/IFC experiment. Visual items are arranged horizontally. Response buttons are arranged horizontally below the items.$EOL$
  • 4: pure AFC/IFC experiment. Visual items and response buttons are arranged vertically.$EOL$
    • It's allowed to execute Init() repetitive.

    See Also

    frmExp Class


SetBreak Method

frmExp..::..SetBreak Method
frmExp Class See Also Send Feedback
Set the experimental state to "break"

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetBreak ( _
    blnBreak As Boolean _
)

Parameters

blnBreak
Type: System..::..Boolean
TRUE: break active.

Remarks

See Also

frmExp Class


SetEndOfExperimentText Method

frmExp..::..SetEndOfExperimentText Method
frmExp Class See Also Send Feedback
Sets the end-of-experimt text.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetEndOfExperimentText ( _
    szText As String _
)

Parameters

szText
Type: System..::..String
Text appears at the enf of experiment.

Remarks

See Also

frmExp Class


SetOnResponseCallback Method

frmExp..::..SetOnResponseCallback Method
frmExp Class See Also Send Feedback
Sets the callback on subject's response.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnResponseCallback ( _
    lAddr As OnResponseDelegate _
)

Parameters

lAddr
Type: OnResponseDelegate

[Missing <param name="lAddr"/> documentation for "M:ExpSuite.frmExp.SetOnResponseCallback(ExpSuite.FWintern.OnResponseDelegate)"]

Remarks

OnResponse callback will be executed on:
  • Subject pressed a HUI button
  • Subject pressed a keyboard key

    • See Also

    frmExp Class


SetProgress Method

frmExp..::..SetProgress Method
frmExp Class See Also Send Feedback
Set the value of progress bar.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetProgress ( _
    sVal As Double, _
    ByRef szX As String _
)

Parameters

sVal
Type: System..::..Double
Represents progress in percent, must be a value in [0;100].
szX
Type: System..::..String %
Optional string which will be used instead of the sVal.

Remarks

See Also

frmExp Class


SetRequestText Method

frmExp..::..SetRequestText Method
frmExp Class See Also Send Feedback
Sets the request text in the experiment. This may be the question to the subject or something else...

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetRequestText ( _
    szText As String, _
    lForeColor As Color _
)

Parameters

szText
Type: System..::..String
Request to the subject.
lForeColor
Type: System.Drawing..::..Color
Color of the text, if Nothing or Color.Empty the standard windows color is used.

Remarks

See Also

frmExp Class


SetResponse Method

frmExp..::..SetResponse Method
frmExp Class See Also Send Feedback
Set the response to a given code.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetResponse ( _
    lX As Integer _
)

Parameters

lX
Type: System..::..Int32
Code

Remarks

See SetResponse(Int32) to see the available codes.

See Also

frmExp Class


SetResponseButtons Method

frmExp..::..SetResponseButtons Method
frmExp Class See Also Send Feedback
Sets the HUI codes for the response, start and next buttons.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function SetResponseButtons ( _
    lButtons As Integer(), _
    lStart As Integer, _
    lNext As Integer _
) As String

Parameters

lButtons
Type: array< System..::..Int32 >[]()[][]
Array with the HUI codes for the responses. The array size must match the number of alternatives given by AFC. The codes can be retrieved from Settings/Experiment Screen/Get Response.
lStart
Type: System..::..Int32
HUI code for the start button.
lNext
Type: System..::..Int32
HUI code for the next-item button.

Return Value

[Missing <returns> documentation for "M:ExpSuite.frmExp.SetResponseButtons(System.Int32[],System.Int32,System.Int32)"]

Remarks

See Also

frmExp Class


SetResponseKeys Method

frmExp..::..SetResponseKeys Method
frmExp Class See Also Send Feedback
Set the codes for the response, start and next keys.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function SetResponseKeys ( _
    lKeys As Integer(), _
    lStart As Integer, _
    lNext As Integer _
) As String

Parameters

lKeys
Type: array< System..::..Int32 >[]()[][]
Array with the ASCII codes for the responses. The array size must match the number of alternatives given by AFC on Init.
lStart
Type: System..::..Int32
ASCII code for the start key.
lNext
Type: System..::..Int32
ASCII code for the next-item key.

Return Value

[Missing <returns> documentation for "M:ExpSuite.frmExp.SetResponseKeys(System.Int32[],System.Int32,System.Int32)"]

Remarks

See Also

frmExp Class


SetResponseNames Method

frmExp..::..SetResponseNames Method
frmExp Class See Also Send Feedback
Sets the caption of response buttons.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function SetResponseNames ( _
    szArgs As String(), _
    szStart As String, _
    szNext As String, _
    szCancel As String _
) As String

Parameters

szArgs
Type: array< System..::..String >[]()[][]
Required. String. The caption of response button will be set for each string in the array.
szStart
Type: System..::..String
Required. String. Text for the Start button.
szNext
Type: System..::..String
Required. String. Text for the Next button.
szCancel
Type: System..::..String
equired. String. Text for the Cancel button.

Return Value

[Missing <returns> documentation for "M:ExpSuite.frmExp.SetResponseNames(System.String[],System.String,System.String,System.String)"]

Remarks

The number of items in szArgs() must less or equal to AFC.

See Also

frmExp Class


SetSize Method

frmExp..::..SetSize Method
frmExp Class See Also Send Feedback
Set the size and position of the experimental screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetSize ( _
    lLeft As Integer, _
    lWidth As Integer, _
    lTop As Integer, _
    lHeight As Integer _
)

Parameters

lLeft
Type: System..::..Int32
Left position
lWidth
Type: System..::..Int32
Width
lTop
Type: System..::..Int32
Top position
lHeight
Type: System..::..Int32
Height

Remarks

See Also

frmExp Class


SetStartOfExperimentText Method

frmExp..::..SetStartOfExperimentText Method
frmExp Class See Also Send Feedback
Sets the start-of-experiment text.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetStartOfExperimentText ( _
    szText As String _
)

Parameters

szText
Type: System..::..String
Text which appears at the start of experiment

Remarks

See Also

frmExp Class


SetVisuCaption Method

frmExp..::..SetVisuCaption Method
frmExp Class See Also Send Feedback
Sets the caption of interval visualisation boxes (lblVisu)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function SetVisuCaption ( _
    szCaption As String() _
) As String

Parameters

szCaption
Type: array< System..::..String >[]()[][]
Captions of the interval visualisation boxes. The array size must match the number of intervals given by IFC on Init.

Return Value

[Missing <returns> documentation for "M:ExpSuite.frmExp.SetVisuCaption(System.String[])"]

Remarks

See Also

frmExp Class


ShowBlankScreen Method

frmExp..::..ShowBlankScreen Method
frmExp Class See Also Send Feedback
Show blank experimental screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowBlankScreen ( _
    blnTop As Boolean _
)

Parameters

blnTop
Type: System..::..Boolean
If blnTop is true the experimental screen always will remain on top of the screen.

Remarks

See Also

frmExp Class


ShowEndScreen Method

frmExp..::..ShowEndScreen Method
frmExp Class See Also Send Feedback
Show the end-of-experiment screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowEndScreen

Remarks

See Also

frmExp Class


ShowHighlightedItem Method

frmExp..::..ShowHighlightedItem Method
frmExp Class See Also Send Feedback
Highlight an interval on the experimental screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowHighlightedItem ( _
    lItem As Integer, _
    lForeColor As Color _
)

Parameters

lItem
Type: System..::..Int32
Index of the interval to be highlighted. Maximum value is IFC-1
lForeColor
Type: System.Drawing..::..Color
Color of the highlighted interval, otherwise use SystemColors.ControlText

Remarks

See Also

frmExp Class


ShowNextScreen Method

frmExp..::..ShowNextScreen Method
frmExp Class See Also Send Feedback
Show the experimental screen for the next stimulus.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowNextScreen ( _
    szFB As String, _
    lForeColor As Color _
)

Parameters

szFB
Type: System..::..String
Text to be displayed on the screen, f.e. as a feedback.
lForeColor
Type: System.Drawing..::..Color
The color of the text given in szFB, otherwise use SystemColors.ControlText.

Remarks

Calling ShowNextScreen, all interval will be deselected and the text szFB will be displayed. The GetResponse procedure will wait for the next button (if used in Settings).

See Also

frmExp Class


ShowStartScreen Method

[image]

ExpSuite
frmExp..::..ShowStartScreen Method
frmExp Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowStartScreen()()()() | Show the experimental start screen.
Public method | ShowStartScreen(String) | Show Start screen.

See Also

frmExp Class
frmExp Members


ShowStartScreen Method

frmExp..::..ShowStartScreen Method
frmExp Class See Also Send Feedback
Show the experimental start screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowStartScreen

Remarks

See Also

frmExp Class
ShowStartScreen Overload


ShowStartScreen Method (String)

frmExp..::..ShowStartScreen Method (String)
frmExp Class See Also Send Feedback
Show Start screen.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowStartScreen ( _
    szText As String _
)

Parameters

szText
Type: System..::..String
Show text...

Remarks

See Also

frmExp Class
ShowStartScreen Overload


ShowStimScreen Method

frmExp..::..ShowStimScreen Method
frmExp Class See Also Send Feedback
Show the experimental stimulation screen and highlight current stimulation interval.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub ShowStimScreen ( _
    lIdx As Integer, _
    lTime As Integer _
)

Parameters

lIdx
Type: System..::..Int32
Index of the highlighted interval. Use the response codes (see GetResponse) to select an interval or deselect all.
lTime
Type: System..::..Int32
ShowStimScreen (0) will be executed after lTime. If you don't want to use this feature ommit lTime or set it to zero.

Remarks

See Also

frmExp Class


frmInputBox Class

frmInputBox Class
Members See Also Send Feedback
FrameWork Module - Programmable Input Box Form

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmInputBox _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmInputBox

See Also

frmInputBox Members


frmInputBox Members

[image]

ExpSuite
frmInputBox Members
frmInputBox Class Methods Properties See Also Send Feedback

The frmInputBox type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an input item to the form Add input items before showing the form via ShowForm.
Private method | CheckValue | Check a value against its restrictions.
Public method | GetCount | Get the count of items in the form.
Public method | ShowForm | Show the input box form.

Properties

 | Name | Description
Public property | GetValue | Get the value of an item.

See Also

frmInputBox Class


frmInputBox Methods

[image]

ExpSuite
frmInputBox Methods
frmInputBox Class See Also Send Feedback

The frmInputBox type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an input item to the form Add input items before showing the form via ShowForm.
Private method | CheckValue | Check a value against its restrictions.
Public method | GetCount | Get the count of items in the form.
Public method | ShowForm | Show the input box form.

See Also

frmInputBox Class


Add Method

frmInputBox..::..Add Method
frmInputBox Class See Also Send Feedback
Add an input item to the form
Add input items before showing the form via ShowForm.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub Add ( _
    Title As String, _
    Flags As FWintern..::..VariableFlags, _
    Defaul As String, _
    Units As String, _
    Min As Double, _
    Max As Double _
)

Parameters

Title
Type: System..::..String
Title of the item.
Flags
Type: ExpSuite..::..FWintern..::..VariableFlags
Flags for the item, see VariableFlags for the possible values. ElectrodeR/L are not supported.
Defaul
Type: System..::..String
Default value (String) showed at the begin in the input box.
Units
Type: System..::..String
Units of the item, it will be shown at the right of the input box.
Min
Type: System..::..Double
Minimum value for numerical values.
Max
Type: System..::..Double
Maximum value for numerical values.

Remarks

See Also

frmInputBox Class


CheckValue Method

frmInputBox..::..CheckValue Method
frmInputBox Class See Also Send Feedback
Check a value against its restrictions.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Function CheckValue ( _
    szX As String, _
    szName As String, _
    Flags As FWintern..::..VariableFlags, _
    szUnit As String, _
    dMin As Double, _
    dMax As Double _
) As String

Parameters

szX
Type: System..::..String
Parameter_Description
szName
Type: System..::..String
Parameter_Description
Flags
Type: ExpSuite..::..FWintern..::..VariableFlags
Parameter_Description
szUnit
Type: System..::..String
Parameter_Description
dMin
Type: System..::..Double
Parameter_Description
dMax
Type: System..::..Double
Parameter_Description

Return Value

Error message.

Remarks

See Also

frmInputBox Class


GetCount Method

frmInputBox..::..GetCount Method
frmInputBox Class See Also Send Feedback
Get the count of items in the form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function GetCount As Integer

Return Value

Count of items in the form. Zero if there are no valid items.

Remarks

See Also

frmInputBox Class


ShowForm Method

frmInputBox..::..ShowForm Method
frmInputBox Class See Also Send Feedback
Show the input box form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function ShowForm ( _
    Caption As String _
) As Boolean

Parameters

Caption
Type: System..::..String
Caption of the form.

Return Value

TRUE if the data are valid, FALSE if cancel or close was clicked. The data are not valid in the latter case.

Remarks

See Also

frmInputBox Class


frmInputBox Properties

[image]

ExpSuite
frmInputBox Properties
frmInputBox Class See Also Send Feedback

The frmInputBox type exposes the following members.

Properties

 | Name | Description
Public property | GetValue | Get the value of an item.

See Also

frmInputBox Class


GetValue Property

frmInputBox..::..GetValue Property
frmInputBox Class See Also Send Feedback
Get the value of an item.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public ReadOnly Property GetValue ( _
    Index As Integer _
) As String
    Get

Parameters

Index
Type: System..::..Int32
Index of the item.

Field Value

Return Value

Value of the item with index Index.

Remarks

How to use frmInputBox:

Examples

CopyVB.NET
Dim inpX As New frmInputBox, szX As String, lX As Long

  inpX.Add "const 1", ifNumeric + ifMin, "123", "us", -10
  inpX.Add "const 2", ifString, "asdas", "text"
  inpX.Add "const 3", ifFileName, "C:/asdads", "*.wav"
  If Not inpX.ShowForm("Caption of the input box") Then Set inpX = Nothing: Exit Sub
  szX = ""
  For lX = 0 To inpX.GetCount - 1
    szX = szX + inpX.GetValue(lX) + vbCrLf
  Next
  MsgBox szX
 Set inpX = Nothing

See Also

frmInputBox Class


frmInputMultiline Class

frmInputMultiline Class
Members See Also Send Feedback
FrameWork Module - Programmable Multiline Input Box Form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmInputMultiline _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmInputMultiline

See Also

frmInputMultiline Members


frmInputMultiline Members

[image]

ExpSuite
frmInputMultiline Members
frmInputMultiline Class Methods Properties See Also Send Feedback

The frmInputMultiline type exposes the following members.

Methods

 | Name | Description
Public method | ShowForm | Show the input box form.

Properties

 | Name | Description
Public property | SetLeft | Set the left position of the input form.
Public property | SetTop | Set the top position of the input form.
Public property | Text_Renamed |
Public property | Title | Set the title of the multiline text.

See Also

frmInputMultiline Class


frmInputMultiline Methods

[image]

ExpSuite
frmInputMultiline Methods
frmInputMultiline Class See Also Send Feedback

The frmInputMultiline type exposes the following members.

Methods

 | Name | Description
Public method | ShowForm | Show the input box form.

See Also

frmInputMultiline Class


ShowForm Method

frmInputMultiline..::..ShowForm Method
frmInputMultiline Class See Also Send Feedback
Show the input box form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function ShowForm ( _
    Caption As String _
) As Boolean

Parameters

Caption
Type: System..::..String
Caption of the form.

Return Value

TRUE if the data are valid, FALSE if cancel or close was clicked. The data are not valid in the latter case.

Remarks

Call ShowForm to show the form.

See Also

frmInputMultiline Class


frmInputMultiline Properties

[image]

ExpSuite
frmInputMultiline Properties
frmInputMultiline Class See Also Send Feedback

The frmInputMultiline type exposes the following members.

Properties

 | Name | Description
Public property | SetLeft | Set the left position of the input form.
Public property | SetTop | Set the top position of the input form.
Public property | Text_Renamed |
Public property | Title | Set the title of the multiline text.

See Also

frmInputMultiline Class


SetLeft Property

frmInputMultiline..::..SetLeft Property
frmInputMultiline Class See Also Send Feedback
Set the left position of the input form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public WriteOnly Property SetLeft As Integer
    Set

Field Value

Remarks

See Also

frmInputMultiline Class


SetTop Property

frmInputMultiline..::..SetTop Property
frmInputMultiline Class See Also Send Feedback
Set the top position of the input form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public WriteOnly Property SetTop As Integer
    Set

Field Value

Remarks

See Also

frmInputMultiline Class


Text_Renamed Property

frmInputMultiline..::..Text_Renamed Property
frmInputMultiline Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.frmInputMultiline.Text_Renamed"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Text_Renamed As String
    Get
    Set

See Also

frmInputMultiline Class


Title Property

frmInputMultiline..::..Title Property
frmInputMultiline Class See Also Send Feedback
Set the title of the multiline text.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public WriteOnly Property Title As String
    Set

Field Value

Remarks

See Also

frmInputMultiline Class


frmItemListPostfix Class

frmItemListPostfix Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Postfix of Item Lists dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmItemListPostfix _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmItemListPostfix

See Also

frmItemListPostfix Members


frmItemListPostfix Members

[image]

ExpSuite
frmItemListPostfix Members
frmItemListPostfix Class Constructors See Also Send Feedback

The frmItemListPostfix type exposes the following members.

Constructors

 | Name | Description
Public method | frmItemListPostfix | Initializes a new instance of the frmItemListPostfix class

See Also

frmItemListPostfix Class


frmItemListPostfix Constructor

frmItemListPostfix Constructor
frmItemListPostfix Class See Also Send Feedback
Initializes a new instance of the frmItemListPostfix class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

frmItemListPostfix Class


frmMain Class

frmMain Class
Members See Also Send Feedback
FrameWork Module. Main Window.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmMain _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmMain

See Also

frmMain Members


frmMain Members

[image]

ExpSuite
frmMain Members
frmMain Class Methods See Also Send Feedback

The frmMain type exposes the following members.

Methods

 | Name | Description
Private method | ClearParameters | Clear all settings.
Public method | CreateAllStimuli | Creates all stimuli.
Public method | CreateItemList | Creates an item list.
Private method | CutDirName | Cut a part of a directory to get a string not longer than lWidth including an appendix szAppendix.
Public method | NextItem | NextItem: use Itemlist.NextItem instead.
Public method | SetOnBreakCallback | Sets the callback on loading Settings in the dialog.
Public method | SetOutputStatus | Set the status of the output channels.
Public method | SetProgressbar | Set the progress bar to a value.
Public method | SetResultList | Set the Result List.
Public method | SetStatus |
Private method | SetUIBusy | Set the user interface to state: busy
Public method | SetUIReady | Set the user interface to state: ready
Public method | StartExperiment | Starts an experiment.

See Also

frmMain Class


frmMain Methods

[image]

ExpSuite
frmMain Methods
frmMain Class See Also Send Feedback

The frmMain type exposes the following members.

Methods

 | Name | Description
Private method | ClearParameters | Clear all settings.
Public method | CreateAllStimuli | Creates all stimuli.
Public method | CreateItemList | Creates an item list.
Private method | CutDirName | Cut a part of a directory to get a string not longer than lWidth including an appendix szAppendix.
Public method | NextItem | NextItem: use Itemlist.NextItem instead.
Public method | SetOnBreakCallback | Sets the callback on loading Settings in the dialog.
Public method | SetOutputStatus | Set the status of the output channels.
Public method | SetProgressbar | Set the progress bar to a value.
Public method | SetResultList | Set the Result List.
Public method | SetStatus |
Private method | SetUIBusy | Set the user interface to state: busy
Public method | SetUIReady | Set the user interface to state: ready
Public method | StartExperiment | Starts an experiment.

See Also

frmMain Class


ClearParameters Method

frmMain..::..ClearParameters Method
frmMain Class See Also Send Feedback
Clear all settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Sub ClearParameters

Remarks

See Also

frmMain Class


CreateAllStimuli Method

frmMain..::..CreateAllStimuli Method
frmMain Class See Also Send Feedback
Creates all stimuli.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function CreateAllStimuli As String

Return Value

Error message or empty if no error ocured.

Remarks

This public function can be used to create all stimuli without using the button or menu.

See Also

frmMain Class


CreateItemList Method

frmMain..::..CreateItemList Method
frmMain Class See Also Send Feedback
Creates an item list.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function CreateItemList ( _
    lFlags As Integer _
) As String

Parameters

lFlags
Type: System..::..Int32
Main Automatisations Flags (mafIgnoreOptionWarnings)

Return Value

Error message or empty if no error ocured.

Remarks

This public function can be used to create an item list without using the button or menu.

See Also

frmMain Class


CutDirName Method

frmMain..::..CutDirName Method
frmMain Class See Also Send Feedback
Cut a part of a directory to get a string not longer than lWidth including an appendix szAppendix.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Function CutDirName ( _
    szDir As String, _
    lWidth As Integer, _
    szAppendix As String, _
    NoBackslash As Boolean _
) As String

Parameters

szDir
Type: System..::..String
String containing directory.
lWidth
Type: System..::..Int32
Width of the label.
szAppendix
Type: System..::..String
Additional appendix of the string. Will be considered calculating the total witdh of the caption.
NoBackslash
Type: System..::..Boolean
Optional: If boolean is true, no backslash is appended to szDir.

Return Value

Cut string

Remarks

Parts of szDir between two "\" will be removed to match the width of lWidth+Width(szAppendix). If szDir ends with a backslash, it will be removed After cutting a backslash is appended to the end of the cutted string (if optional boolean NoBackslash is not true), then the szappendix is appended. Works for frmMain only.

See Also

frmMain Class


NextItem Method

frmMain..::..NextItem Method
frmMain Class See Also Send Feedback
NextItem: use Itemlist.NextItem instead.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function NextItem ( _
    lNrInterl As Integer, _
    sProgress As Double _
) As Boolean

Parameters

lNrInterl
Type: System..::..Int32

[Missing <param name="lNrInterl"/> documentation for "M:ExpSuite.frmMain.NextItem(System.Int32,System.Double)"]

sProgress
Type: System..::..Double

[Missing <param name="sProgress"/> documentation for "M:ExpSuite.frmMain.NextItem(System.Int32,System.Double)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.frmMain.NextItem(System.Int32,System.Double)"]

Remarks

See Also

frmMain Class


SetOnBreakCallback Method

frmMain..::..SetOnBreakCallback Method
frmMain Class See Also Send Feedback
Sets the callback on loading Settings in the dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnBreakCallback ( _
    lAddr As OnBreakDelegate _
)

Parameters

lAddr
Type: OnBreakDelegate
Address of the callback function.

Remarks

OnLoad callback will be executed on loading of the Settings dialog.
This gives a possibility to adapt the Settings dialog, before it have been shown.

See Also

frmMain Class


SetOutputStatus Method

frmMain..::..SetOutputStatus Method
frmMain Class See Also Send Feedback
Set the status of the output channels.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOutputStatus ( _
    lCh As Integer, _
    lState As Integer _
)

Parameters

lCh
Type: System..::..Int32
Channel (0:left square, 1: right square)
lState
Type: System..::..Int32
State (see the list with available states)

Remarks

This function can be used to indicate the status of two channels in the bottom line of the main window, right to the status text. Depending on the lState, the background color of the squares changes. Four states are available:
  • 0: the standard case, color: grey, standard
  • 1: creating stimulation files, color: yellow
  • 2: playing or stimulating now, color: red
  • 3: intermadiate (e.g. break between stimuli), color: green

    • See Also

    frmMain Class


SetProgressbar Method

frmMain..::..SetProgressbar Method
frmMain Class See Also Send Feedback
Set the progress bar to a value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetProgressbar ( _
    sVal As Double _
)

Parameters

sVal
Type: System..::..Double
Value of the progress bar in percent. Valid range: 0..100%

Remarks

See Also

frmMain Class


SetResultList Method

frmMain..::..SetResultList Method
frmMain Class See Also Send Feedback
Set the Result List.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetResultList ( _
    szText As String _
)

Parameters

szText
Type: System..::..String
String with list items, separated by ;

Remarks

See Also

frmMain Class


SetStatus Method

frmMain..::..SetStatus Method
frmMain Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.frmMain.SetStatus(System.String)"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetStatus ( _
    szStatus As String _
)

Parameters

szStatus
Type: System..::..String

[Missing <param name="szStatus"/> documentation for "M:ExpSuite.frmMain.SetStatus(System.String)"]

See Also

frmMain Class


SetUIBusy Method

frmMain..::..SetUIBusy Method
frmMain Class See Also Send Feedback
Set the user interface to state: busy

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Sub SetUIBusy

Remarks

This function can be used to disable the user interface while processing for longer period. The most buttons but Cancel will be disabled, all menus too. The cursor changes to hour glass and item list is not available.

See Also

frmMain Class


SetUIReady Method

frmMain..::..SetUIReady Method
frmMain Class See Also Send Feedback
Set the user interface to state: ready

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetUIReady

Remarks

SetUIReady sets the main window interface to a valid state after SetUIBusy. The state of the buttons/menus depends on many parameters such as running experiment, connection to the output, opened settings window, etc...

See Also

frmMain Class


StartExperiment Method

frmMain..::..StartExperiment Method
frmMain Class See Also Send Feedback
Starts an experiment.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function StartExperiment ( _
    lFlags As AutomatisationFlags _
) As String

Parameters

lFlags
Type: AutomatisationFlags
Main Automatisations Flags (mafIgnoreOptionWarnings, mafIgnoreHUIWarnings)

Return Value

Error message or empty if no error ocured.

Remarks

This public function can be used to start an experiment without using the button or menu.

See Also

frmMain Class


frmOptions Class

frmOptions Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Options dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmOptions _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmOptions

See Also

frmOptions Members


frmOptions Members

[image]

ExpSuite
frmOptions Members
frmOptions Class Constructors See Also Send Feedback

The frmOptions type exposes the following members.

Constructors

 | Name | Description
Public method | frmOptions | Initializes a new instance of the frmOptions class

See Also

frmOptions Class


frmOptions Constructor

frmOptions Constructor
frmOptions Class See Also Send Feedback
Initializes a new instance of the frmOptions class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

frmOptions Class


frmResult Class

frmResult Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Result form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmResult _
    Inherits Form

Remarks

This form can be multiply created and used to show results in form of a grid or table. The functionality such as sorting, copy to clipboard, ploting and saving is provided.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmResult

See Also

frmResult Members


frmResult Members

[image]

ExpSuite
frmResult Members
frmResult Class Properties See Also Send Feedback

The frmResult type exposes the following members.

Properties

 | Name | Description
Public property | PostFix | Set the postfix of the result file.

See Also

frmResult Class


frmResult Properties

[image]

ExpSuite
frmResult Properties
frmResult Class See Also Send Feedback

The frmResult type exposes the following members.

Properties

 | Name | Description
Public property | PostFix | Set the postfix of the result file.

See Also

frmResult Class


PostFix Property

frmResult..::..PostFix Property
frmResult Class See Also Send Feedback
Set the postfix of the result file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property PostFix As String
    Get
    Set

Field Value

Return Value

Postfix

Remarks

Clicking on "Save As..." use can save the content of the result list to a CSV file. Postfix defines the postfix of this file, it will be saved in format: name_postfix.rsl.csv User is allowed to change the postfix in a window.

See Also

frmResult Class


frmSettings Class

frmSettings Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Settings dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmSettings _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmSettings

See Also

frmSettings Members


frmSettings Members

[image]

ExpSuite
frmSettings Members
frmSettings Class Methods See Also Send Feedback

The frmSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantValues | Copies the values of all Constants to an array.
Private method | GetTempViWoParameter | Get value of a parameter.
Private method | MsgBoxOnTop | Show a message box on the top of all windows.
Public method | SetOnChangeCallback | Sets the callback on change of Settings.
Public method | SetOnExpTypeCallback | Sets the callback on change of the experiment type in the Settings dialog.
Public method | SetOnLoadCallback | Sets the callback on loading Settings in the dialog.
Public method | SetOnOutputDeviceChangeCallback | Sets the callback on change of the output device.
Public method | SetOnSetCallback | Sets the callback on Set of new Settings.
Private method | SetTempViWoParameter | Set a temporary parameter value.
Public method | UpdateConstants | Update Constants in the Settings dialog.
Public method | UpdateVariables | Update Variables in the Settings dialog.

See Also

frmSettings Class


frmSettings Methods

[image]

ExpSuite
frmSettings Methods
frmSettings Class See Also Send Feedback

The frmSettings type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantValues | Copies the values of all Constants to an array.
Private method | GetTempViWoParameter | Get value of a parameter.
Private method | MsgBoxOnTop | Show a message box on the top of all windows.
Public method | SetOnChangeCallback | Sets the callback on change of Settings.
Public method | SetOnExpTypeCallback | Sets the callback on change of the experiment type in the Settings dialog.
Public method | SetOnLoadCallback | Sets the callback on loading Settings in the dialog.
Public method | SetOnOutputDeviceChangeCallback | Sets the callback on change of the output device.
Public method | SetOnSetCallback | Sets the callback on Set of new Settings.
Private method | SetTempViWoParameter | Set a temporary parameter value.
Public method | UpdateConstants | Update Constants in the Settings dialog.
Public method | UpdateVariables | Update Variables in the Settings dialog.

See Also

frmSettings Class


GetConstantValues Method

frmSettings..::..GetConstantValues Method
frmSettings Class See Also Send Feedback
Copies the values of all Constants to an array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub GetConstantValues ( _
    ByRef varArr As String() _
)

Parameters

varArr
Type: array< System..::..String >[]()[][]%
Array to be resized and filled.

Remarks

See Also

frmSettings Class


GetTempViWoParameter Method

frmSettings..::..GetTempViWoParameter Method
frmSettings Class See Also Send Feedback
Get value of a parameter.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Function GetTempViWoParameter ( _
    lIdx As Integer _
) As String

Parameters

lIdx
Type: System..::..Int32
Index to a preview parameter.

Return Value

Value of this parameter.

Remarks

lIdx is the index to a preview parameter. If a corresponding temporary parameter can be found, its value will be returned. Otherwise, the value of the preview parameter, which is the default value will be returned.

See Also

frmSettings Class


MsgBoxOnTop Method

frmSettings..::..MsgBoxOnTop Method
frmSettings Class See Also Send Feedback
Show a message box on the top of all windows.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Function MsgBoxOnTop ( _
    szPrompt As String, _
    lButtons As MsgBoxStyle, _
    szTitle As String _
) As Integer

Parameters

szPrompt
Type: System..::..String
Prompt
lButtons
Type: Microsoft.VisualBasic..::..MsgBoxStyle
Buttons options
szTitle
Type: System..::..String
Title

Return Value

Button clicked

Remarks

MsgBoxOnTop is equivalent to MsgBox with the difference, that it will show the message box on the top of all windows. See the description of MsgBox for details on parameters.

See Also

frmSettings Class


SetOnChangeCallback Method

frmSettings..::..SetOnChangeCallback Method
frmSettings Class See Also Send Feedback
Sets the callback on change of Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnChangeCallback ( _
    lAddr As OnChangeDelegate _
)

Parameters

lAddr
Type: OnChangeDelegate

[Missing <param name="lAddr"/> documentation for "M:ExpSuite.frmSettings.SetOnChangeCallback(ExpSuite.FWintern.OnChangeDelegate)"]

Remarks

OnChange callback will be executed on change of a value in Settings dialog. A click on OK is not required to execute OnChange - e.g. a text box loses its focus and OnChange will be executed immediatly. The delegate is OnChangeDelegate(ByVal ExpType As Integer) where ExpType is the current experiment type

See Also

frmSettings Class


SetOnExpTypeCallback Method

frmSettings..::..SetOnExpTypeCallback Method
frmSettings Class See Also Send Feedback
Sets the callback on change of the experiment type in the Settings dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnExpTypeCallback ( _
    lAddr As OnExpTypeChangeDelegate _
)

Parameters

lAddr
Type: OnExpTypeChangeDelegate
Address of the callback function

Remarks

OnExpType callback will be executed on a change of experiment type. The delegate is OnExpTypeChangeDelegate(ByVal lOld As Integer, ByVal lNew As Integer) where:
  • lOld: old experiment type
  • lNew: new experiment type

    • The experiment type changes on:
  • loading setting from file, old exp. type is set to -1 in this case
  • changing the experiment type in the Settings dialog
  • clearing the settings, old exp. type is set to -1 in this case

    • See Also

    frmSettings Class


SetOnLoadCallback Method

frmSettings..::..SetOnLoadCallback Method
frmSettings Class See Also Send Feedback
Sets the callback on loading Settings in the dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnLoadCallback ( _
    lAddr As OnLoadDelegate _
)

Parameters

lAddr
Type: OnLoadDelegate
Address of the callback function.

Remarks

OnLoad callback will be executed on loading of the Settings dialog. This gives a possibility to adapt the Settings dialog, before it have been shown.

See Also

frmSettings Class


SetOnOutputDeviceChangeCallback Method

frmSettings..::..SetOnOutputDeviceChangeCallback Method
frmSettings Class See Also Send Feedback
Sets the callback on change of the output device.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnOutputDeviceChangeCallback ( _
    lAddr As OnOutputDeviceChangeDelegate _
)

Parameters

lAddr
Type: OnOutputDeviceChangeDelegate
Address of the callback function

Remarks

See Also

frmSettings Class


SetOnSetCallback Method

frmSettings..::..SetOnSetCallback Method
frmSettings Class See Also Send Feedback
Sets the callback on Set of new Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub SetOnSetCallback ( _
    lAddr As OnSetDelegate _
)

Parameters

lAddr
Type: OnSetDelegate
Address of the callback function.

Remarks

OnSet callback will be executed on:
  • Loading settings from file, just after OnExpTypeChanged
  • click on OK in the Settings form
  • clear Settings to default, just after OnExpTypeChanged

    • See Also

    frmSettings Class


SetTempViWoParameter Method

frmSettings..::..SetTempViWoParameter Method
frmSettings Class See Also Send Feedback
Set a temporary parameter value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Sub SetTempViWoParameter ( _
    lIdx As Integer, _
    szVal As String _
)

Parameters

lIdx
Type: System..::..Int32
Index to a preview parameter
szVal
Type: System..::..String
New value

Remarks

lIdx is the index to a preview parameter. If a corresponding temporary parameter exists, its value will be set to szVal and it will be marked as dirty. Otherwise, a new temporary parameter will be created based on the preview parameter. Its new value will be szVal, too. The parameter list in the window will be updated to show that a new parameter is available now.

See Also

frmSettings Class


UpdateConstants Method

frmSettings..::..UpdateConstants Method
frmSettings Class See Also Send Feedback
Update Constants in the Settings dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub UpdateConstants

Remarks

UpdateConstants can be used when the constants changes and need to be updated in the Settings dialog. UpdateConstant will be executed on the change of experiment type, right after the OnExpTypeChanged callback

See Also

frmSettings Class


UpdateVariables Method

frmSettings..::..UpdateVariables Method
frmSettings Class See Also Send Feedback
Update Variables in the Settings dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub UpdateVariables

Remarks

UpdateVariables can be used when the variables changes and need to be updated in the Settings dialog. UpdateVariables will be executed on the change of experiment type, right after the OnExpTypeChanged callback and UpdateConstant

See Also

frmSettings Class


frmSettingsTrackRange Class

frmSettingsTrackRange Class
Members See Also Send Feedback
FrameWork Module. Implementation of the dialog to set Tracker ranges.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmSettingsTrackRange _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmSettingsTrackRange

See Also

frmSettingsTrackRange Members


frmSettingsTrackRange Members

[image]

ExpSuite
frmSettingsTrackRange Members
frmSettingsTrackRange Class Constructors See Also Send Feedback

The frmSettingsTrackRange type exposes the following members.

Constructors

 | Name | Description
Public method | frmSettingsTrackRange | Initializes a new instance of the frmSettingsTrackRange class

See Also

frmSettingsTrackRange Class


frmSettingsTrackRange Constructor

frmSettingsTrackRange Constructor
frmSettingsTrackRange Class See Also Send Feedback
Initializes a new instance of the frmSettingsTrackRange class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

frmSettingsTrackRange Class


frmShowStimulus Class

frmShowStimulus Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Show Stimulus dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmShowStimulus _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmShowStimulus

See Also

frmShowStimulus Members


frmShowStimulus Members

[image]

ExpSuite
frmShowStimulus Members
frmShowStimulus Class Constructors See Also Send Feedback

The frmShowStimulus type exposes the following members.

Constructors

 | Name | Description
Public method | frmShowStimulus | Initializes a new instance of the frmShowStimulus class

See Also

frmShowStimulus Class


frmShowStimulus Constructor

frmShowStimulus Constructor
frmShowStimulus Class See Also Send Feedback
Initializes a new instance of the frmShowStimulus class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

frmShowStimulus Class


frmTurntable Class

frmTurntable Class
Members See Also Send Feedback
FrameWork Module. Implementation of the Turntable dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class frmTurntable _
    Inherits Form

Remarks

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
ExpSuite..::..frmTurntable

See Also

frmTurntable Members


frmTurntable Members

[image]

ExpSuite
frmTurntable Members
frmTurntable Class Constructors See Also Send Feedback

The frmTurntable type exposes the following members.

Constructors

 | Name | Description
Public method | frmTurntable | Initializes a new instance of the frmTurntable class

See Also

frmTurntable Class


frmTurntable Constructor

frmTurntable Constructor
frmTurntable Class See Also Send Feedback
Initializes a new instance of the frmTurntable class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

frmTurntable Class


FWintern Class

FWintern Class
Members See Also Send Feedback
FrameWork - Declarations and general methods.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class FWintern

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..FWintern

See Also

FWintern Members


FWintern Members

[image]

ExpSuite
FWintern Members
FWintern Class Methods Fields See Also Send Feedback

The FWintern type exposes the following members.

Methods

Name | Description
CheckConstant | Check a Constant against restrictions.
CheckElectrode | Check Electrode.
CheckValue | Check a value against from Variables or Constants its restrictions. Don't use CheckValue directly, use FWIntern.CheckVariable or FWIntern.CheckConstant instead.
CheckVariable | Check a Variable against restrictions.
GetNextFileVersion | Get the next file version and number the file name.
GetUboundConstants | Get the number of experimental constants.
GetUboundVariables | Get the number of experimental variables.
WaitHP | High Precision Counter support.
WaitSleepHP | High Precision Counter support with deactivation.

Fields

Name | Description
AppResourcesDirectory | Data Directory (Instance of clsDataDirectory)
DataDirectory | Data Directory (Instance of clsDataDirectory)
F4FL | Fitt4Fun instances .
F4FR | Fitt4Fun instances .
gblnCancel | Cancel an action?
gblnConnectLeft | Must be TRUE to continue connection. See Events.OnConnect.
gblnConnectRight | Must be TRUE to continue connection. See Events.OnConnect.
gblnExperiment | Experiment running?
gblnIsDotNETSetting | Do we need to convert the VB6-framework settings to the .NET-framework settings?
gblnMIDIIgnore | Ignore MIDI Messages.
gblnOutputStable | Connected to output?
gblnSettingsForm | Settings dialog visible/unvisible.
gblnShowStimulus | Show Stimulus before stimulation activated?
glExpAFC | Alternative Forced Choices, number of possible responses.
glExpIFC | Number of intervals in a stimulus sequence
glExpMode | Mode of experiment for frmExp, contact Piotr...
glPlayerSampleRate | Sampling Rate of YAMI (Settings/Audio)
gszExpRequestText | Request text, appears in the experiment form.
gszExpResponseNames | Descriptions of response buttons, separated by ;
gszExpTypeNames | Array with names of experiment types.
gszSettingFileName | File name of Settings.
gszSettingTitle | Title of Settings.
ItemList | Item List (Instance of clsItemList)

See Also

FWintern Class


FWintern Fields

[image]

ExpSuite
FWintern Fields
FWintern Class See Also Send Feedback

The FWintern type exposes the following members.

Fields

Name | Description
AppResourcesDirectory | Data Directory (Instance of clsDataDirectory)
DataDirectory | Data Directory (Instance of clsDataDirectory)
F4FL | Fitt4Fun instances .
F4FR | Fitt4Fun instances .
gblnCancel | Cancel an action?
gblnConnectLeft | Must be TRUE to continue connection. See Events.OnConnect.
gblnConnectRight | Must be TRUE to continue connection. See Events.OnConnect.
gblnExperiment | Experiment running?
gblnIsDotNETSetting | Do we need to convert the VB6-framework settings to the .NET-framework settings?
gblnMIDIIgnore | Ignore MIDI Messages.
gblnOutputStable | Connected to output?
gblnSettingsForm | Settings dialog visible/unvisible.
gblnShowStimulus | Show Stimulus before stimulation activated?
glExpAFC | Alternative Forced Choices, number of possible responses.
glExpIFC | Number of intervals in a stimulus sequence
glExpMode | Mode of experiment for frmExp, contact Piotr...
glPlayerSampleRate | Sampling Rate of YAMI (Settings/Audio)
gszExpRequestText | Request text, appears in the experiment form.
gszExpResponseNames | Descriptions of response buttons, separated by ;
gszExpTypeNames | Array with names of experiment types.
gszSettingFileName | File name of Settings.
gszSettingTitle | Title of Settings.
ItemList | Item List (Instance of clsItemList)

See Also

FWintern Class


AppResourcesDirectory Field

FWintern..::..AppResourcesDirectory Field
FWintern Class See Also Send Feedback
Data Directory (Instance of clsDataDirectory)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared AppResourcesDirectory As String

Remarks

See Also

FWintern Class


DataDirectory Field

FWintern..::..DataDirectory Field
FWintern Class See Also Send Feedback
Data Directory (Instance of clsDataDirectory)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared DataDirectory As clsDataDirectory

Remarks

See Also

FWintern Class


F4FL Field

FWintern..::..F4FL Field
FWintern Class See Also Send Feedback
Fitt4Fun instances .

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Shared F4FL As Implant

Remarks

See Also

FWintern Class


F4FR Field

FWintern..::..F4FR Field
FWintern Class See Also Send Feedback
Fitt4Fun instances .

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared F4FR As Implant

Remarks

See Also

FWintern Class


gblnCancel Field

FWintern..::..gblnCancel Field
FWintern Class See Also Send Feedback
Cancel an action?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnCancel As Boolean

Remarks

Cancel is: click on Cancel button (main form), ESC in an experiment

See Also

FWintern Class


gblnConnectLeft Field

FWintern..::..gblnConnectLeft Field
FWintern Class See Also Send Feedback
Must be TRUE to continue connection. See Events.OnConnect.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnConnectLeft As Boolean

Remarks

See Also

FWintern Class


gblnConnectRight Field

FWintern..::..gblnConnectRight Field
FWintern Class See Also Send Feedback
Must be TRUE to continue connection. See Events.OnConnect.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnConnectRight As Boolean

Remarks

See Also

FWintern Class


gblnExperiment Field

FWintern..::..gblnExperiment Field
FWintern Class See Also Send Feedback
Experiment running?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnExperiment As Boolean

Remarks

See Also

FWintern Class


gblnIsDotNETSetting Field

FWintern..::..gblnIsDotNETSetting Field
FWintern Class See Also Send Feedback
Do we need to convert the VB6-framework settings to the .NET-framework settings?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnIsDotNETSetting As Boolean

Remarks

See Also

FWintern Class


gblnMIDIIgnore Field

FWintern..::..gblnMIDIIgnore Field
FWintern Class See Also Send Feedback
Ignore MIDI Messages.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnMIDIIgnore As Boolean

Remarks

See Also

FWintern Class


gblnOutputStable Field

FWintern..::..gblnOutputStable Field
FWintern Class See Also Send Feedback
Connected to output?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnOutputStable As Boolean

Remarks

See Also

FWintern Class


gblnSettingsForm Field

FWintern..::..gblnSettingsForm Field
FWintern Class See Also Send Feedback
Settings dialog visible/unvisible.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnSettingsForm As Boolean

Remarks

See Also

FWintern Class


gblnShowStimulus Field

FWintern..::..gblnShowStimulus Field
FWintern Class See Also Send Feedback
Show Stimulus before stimulation activated?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnShowStimulus As Boolean

Remarks

See Also

FWintern Class


glExpAFC Field

FWintern..::..glExpAFC Field
FWintern Class See Also Send Feedback
Alternative Forced Choices, number of possible responses.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExpAFC As Integer()

Remarks

See Also

FWintern Class


glExpIFC Field

FWintern..::..glExpIFC Field
FWintern Class See Also Send Feedback
Number of intervals in a stimulus sequence

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExpIFC As Integer()

Remarks

See Also

FWintern Class


glExpMode Field

FWintern..::..glExpMode Field
FWintern Class See Also Send Feedback
Mode of experiment for frmExp, contact Piotr...

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExpMode As Integer()

Remarks

See Also

FWintern Class


glPlayerSampleRate Field

FWintern..::..glPlayerSampleRate Field
FWintern Class See Also Send Feedback
Sampling Rate of YAMI (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerSampleRate As Integer

Remarks

See Also

FWintern Class


gszExpRequestText Field

FWintern..::..gszExpRequestText Field
FWintern Class See Also Send Feedback
Request text, appears in the experiment form.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszExpRequestText As String()

Remarks

See Also

FWintern Class


gszExpResponseNames Field

FWintern..::..gszExpResponseNames Field
FWintern Class See Also Send Feedback
Descriptions of response buttons, separated by ;

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszExpResponseNames As String()

Remarks

See Also

FWintern Class


gszExpTypeNames Field

FWintern..::..gszExpTypeNames Field
FWintern Class See Also Send Feedback
Array with names of experiment types.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszExpTypeNames As String()

Remarks

See Also

FWintern Class


gszSettingFileName Field

FWintern..::..gszSettingFileName Field
FWintern Class See Also Send Feedback
File name of Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszSettingFileName As String

Remarks

See Also

FWintern Class


gszSettingTitle Field

FWintern..::..gszSettingTitle Field
FWintern Class See Also Send Feedback
Title of Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszSettingTitle As String

Remarks

See Also

FWintern Class


ItemList Field

FWintern..::..ItemList Field
FWintern Class See Also Send Feedback
Item List (Instance of clsItemList)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared ItemList As clsItemList

Remarks

See Also

FWintern Class


FWintern Methods

[image]

ExpSuite
FWintern Methods
FWintern Class See Also Send Feedback

The FWintern type exposes the following members.

Methods

Name | Description
CheckConstant | Check a Constant against restrictions.
CheckElectrode | Check Electrode.
CheckValue | Check a value against from Variables or Constants its restrictions. Don't use CheckValue directly, use FWIntern.CheckVariable or FWIntern.CheckConstant instead.
CheckVariable | Check a Variable against restrictions.
GetNextFileVersion | Get the next file version and number the file name.
GetUboundConstants | Get the number of experimental constants.
GetUboundVariables | Get the number of experimental variables.
WaitHP | High Precision Counter support.
WaitSleepHP | High Precision Counter support with deactivation.

See Also

FWintern Class


CheckConstant Method

FWintern..::..CheckConstant Method
FWintern Class See Also Send Feedback
Check a Constant against restrictions.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CheckConstant ( _
    szX As String, _
    constExp As FWintern..::..ExpConstant, _
    freqParL As clsFREQUENCY(), _
    freqParR As clsFREQUENCY() _
) As String

Parameters

szX
Type: System..::..String
String with the context to be checked. Caution: if the Constant should be of numeric type, the variant data type will change to Double.
constExp
Type: ExpSuite..::..FWintern..::..ExpConstant
onstant with all restriction data.
freqParL
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParL"/> documentation for "M:ExpSuite.FWintern.CheckConstant(System.String,ExpSuite.FWintern.ExpConstant,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

freqParR
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParR"/> documentation for "M:ExpSuite.FWintern.CheckConstant(System.String,ExpSuite.FWintern.ExpConstant,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Return Value

String with error descriptions or empty if the content passed the check.

Remarks

See Also

FWintern Class


CheckElectrode Method

FWintern..::..CheckElectrode Method
FWintern Class See Also Send Feedback
Check Electrode.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Shared Function CheckElectrode ( _
    varX As String, _
    szName As String, _
    Flags As FWintern..::..VariableFlags, _
    dMin As Double, _
    dMax As Double, _
    freqParL As clsFREQUENCY(), _
    freqParR As clsFREQUENCY() _
) As String

Parameters

varX
Type: System..::..String
Value to check.
szName
Type: System..::..String
Name of the Variable/Constant.
Flags
Type: ExpSuite..::..FWintern..::..VariableFlags
Flags of the Variable/Constant.
dMin
Type: System..::..Double
Lower limit
dMax
Type: System..::..Double
Upper limit.
freqParL
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParL"/> documentation for "M:ExpSuite.FWintern.CheckElectrode(System.String,System.String,ExpSuite.FWintern.VariableFlags,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

freqParR
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParR"/> documentation for "M:ExpSuite.FWintern.CheckElectrode(System.String,System.String,ExpSuite.FWintern.VariableFlags,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.FWintern.CheckElectrode(System.String,System.String,ExpSuite.FWintern.VariableFlags,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Remarks

See Also

FWintern Class


CheckValue Method

FWintern..::..CheckValue Method
FWintern Class See Also Send Feedback
Check a value against from Variables or Constants its restrictions.
Don't use CheckValue directly, use FWIntern.CheckVariable or FWIntern.CheckConstant instead.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Private Shared Function CheckValue ( _
    ByRef szX As String, _
    szName As String, _
    Flags As FWintern..::..VariableFlags, _
    szUnit As String, _
    dMin As Double, _
    dMax As Double, _
    freqParL As clsFREQUENCY(), _
    freqParR As clsFREQUENCY() _
) As String

Parameters

szX
Type: System..::..String %

[Missing <param name="szX"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

szName
Type: System..::..String

[Missing <param name="szName"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Flags
Type: ExpSuite..::..FWintern..::..VariableFlags

[Missing <param name="Flags"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

szUnit
Type: System..::..String

[Missing <param name="szUnit"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

dMin
Type: System..::..Double

[Missing <param name="dMin"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

dMax
Type: System..::..Double

[Missing <param name="dMax"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

freqParL
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParL"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

freqParR
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParR"/> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.FWintern.CheckValue(System.String@,System.String,ExpSuite.FWintern.VariableFlags,System.String,System.Double,System.Double,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Remarks

See Also

FWintern Class


CheckVariable Method

FWintern..::..CheckVariable Method
FWintern Class See Also Send Feedback
Check a Variable against restrictions.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CheckVariable ( _
    ByRef szX As String, _
    ByRef varExp As FWintern..::..ExpVariable, _
    freqParL As clsFREQUENCY(), _
    freqParR As clsFREQUENCY() _
) As String

Parameters

szX
Type: System..::..String %
String with the context to be checked. Caution: if the Variable should be of numeric type, the variant data type will change to Double.
varExp
Type: ExpSuite..::..FWintern..::..ExpVariable %
Variable with all restriction data.
freqParL
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParL"/> documentation for "M:ExpSuite.FWintern.CheckVariable(System.String@,ExpSuite.FWintern.ExpVariable@,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

freqParR
Type: array<clsFREQUENCY>[]()[][]

[Missing <param name="freqParR"/> documentation for "M:ExpSuite.FWintern.CheckVariable(System.String@,ExpSuite.FWintern.ExpVariable@,ExpSuite.clsFREQUENCY[],ExpSuite.clsFREQUENCY[])"]

Return Value

String with error descriptions or empty if the content passed the check.

Remarks

See Also

FWintern Class


GetNextFileVersion Method

FWintern..::..GetNextFileVersion Method
FWintern Class See Also Send Feedback
Get the next file version and number the file name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub GetNextFileVersion ( _
    ByRef szFile As String, _
    szExt As String _
)

Parameters

szFile
Type: System..::..String %
File name to search, will be updated to the next available version.
szExt
Type: System..::..String
Extension of the file.

Remarks

GetNextFileVersion seeks for all files with the file name szFile and returns the file name labeled with next available version.
E.g. Given szName = "test" and szExt=".txt", if files "test.txt" and "test (2).txt" exist the new szName will be "test (2).txt".

See Also

FWintern Class


GetUboundConstants Method

FWintern..::..GetUboundConstants Method
FWintern Class See Also Send Feedback
Get the number of experimental constants.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetUboundConstants As Integer

Return Value

Number of experimental constants.

Remarks

See Also

FWintern Class


GetUboundVariables Method

FWintern..::..GetUboundVariables Method
FWintern Class See Also Send Feedback
Get the number of experimental variables.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetUboundVariables As Integer

Return Value

Number of experimental variables.

Remarks

See Also

FWintern Class


WaitHP Method

FWintern..::..WaitHP Method
FWintern Class See Also Send Feedback
High Precision Counter support.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function WaitHP ( _
    ByRef curStart As Long, _
    lDelay As Integer _
) As Boolean

Parameters

curStart
Type: System..::..Int64 %
Old value of HP counter, WaitHP updates curStart to the new.
lDelay
Type: System..::..Int32
Optional delay in ms. If not given, WaitHP returns immediatly updating curStart only.

Return Value

Boolean. Canceled or not.

Remarks

WaitHP returns with the current value of the High Precision (HP) counter of Windows and/or waits a given delay lDelay.
Cancel button on the main window or HUI/Keyboard cancel the waiting.

See Also

FWintern Class


WaitSleepHP Method

FWintern..::..WaitSleepHP Method
FWintern Class See Also Send Feedback
High Precision Counter support with deactivation.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function WaitSleepHP ( _
    ByRef curStart As Long, _
    lDelay As Integer _
) As Boolean

Parameters

curStart
Type: System..::..Int64 %
ld value of HP counter, WaitHP updates curStart to the new.
lDelay
Type: System..::..Int32
Optional delay in ms. If not given, WaitHP returns immediatly updating curStart only.

Return Value

Boolean. Canceled or not.

Remarks

WaitHP returns with the current value of the High Precision (HP) counter of Windows and/or waits a given delay lDelay.
Cancel button on the main window or HUI/Keyboard cancel the waiting. Additional, the thread will be deactivated while waiting.

See Also

FWintern Class


FWintern.AudioSynth Structure

FWintern..::..AudioSynth Structure
FWintern Class Members See Also Send Feedback
Structure for the synthesizer (Settings/Audio).

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Structure AudioSynth

Remarks

This structure describes all parameters of a synthesizer unit, which can be set in Settings/Audio. There are 2 synthesizer units available via YAMI at the moment. The parameters are saved in gAudioSynth() with the number of synthesizer unit as index. Depending on the type of signal addition parameter Par1 may be used. The signal is band passed with between LowCut and HighCut frequencies.

See Also

FWintern..::..AudioSynth Members


FWintern.AudioSynth Members

[image]

ExpSuite
FWintern..::..AudioSynth Members
FWintern..::..AudioSynth Structure Fields See Also Send Feedback

FrameWork - Declarations and general methods.

The FWintern..::..AudioSynth type exposes the following members.

Fields

 | Name | Description
Public field | HighCut | Upper cut off frequency [Hz]
Public field | LowCut | LowCut Lower cut off frequency [Hz]
Public field | Par1 | Additional parameter depending on Signal. Frequency [Hz] for Signal = Cosine; Low cut off frequency [Hz] for Signal = LP white noise.
Public field | Signal | Signal Type of signal to generate: 0: Not used 1: Pink noise 2: White noise 3: Cosine 4: Low pass filtered white noise, 4th order butterworth 5: Low pass filtered white noise, 16th order butterworth
Public field | Vol | Volume in dB FS.

See Also

FWintern..::..AudioSynth Structure


FWintern.AudioSynth Fields

[image]

ExpSuite
FWintern..::..AudioSynth Fields
FWintern..::..AudioSynth Structure See Also Send Feedback

The FWintern..::..AudioSynth type exposes the following members.

Fields

 | Name | Description
Public field | HighCut | Upper cut off frequency [Hz]
Public field | LowCut | LowCut Lower cut off frequency [Hz]
Public field | Par1 | Additional parameter depending on Signal. Frequency [Hz] for Signal = Cosine; Low cut off frequency [Hz] for Signal = LP white noise.
Public field | Signal | Signal Type of signal to generate: 0: Not used 1: Pink noise 2: White noise 3: Cosine 4: Low pass filtered white noise, 4th order butterworth 5: Low pass filtered white noise, 16th order butterworth
Public field | Vol | Volume in dB FS.

See Also

FWintern..::..AudioSynth Structure


HighCut Field

FWintern..::..AudioSynth..::..HighCut Field
FWintern..::..AudioSynth Structure See Also Send Feedback
Upper cut off frequency [Hz]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public HighCut As Double

Remarks

See Also

FWintern..::..AudioSynth Structure


LowCut Field

FWintern..::..AudioSynth..::..LowCut Field
FWintern..::..AudioSynth Structure See Also Send Feedback
LowCut Lower cut off frequency [Hz]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public LowCut As Double

Remarks

See Also

FWintern..::..AudioSynth Structure


Par1 Field

FWintern..::..AudioSynth..::..Par1 Field
FWintern..::..AudioSynth Structure See Also Send Feedback
Additional parameter depending on Signal. Frequency [Hz] for Signal = Cosine; Low cut off frequency [Hz] for Signal = LP white noise.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Par1 As Double

Remarks

See Also

FWintern..::..AudioSynth Structure


Signal Field

FWintern..::..AudioSynth..::..Signal Field
FWintern..::..AudioSynth Structure See Also Send Feedback
Signal Type of signal to generate:
  • 0: Not used
  • 1: Pink noise
  • 2: White noise
  • 3: Cosine
  • 4: Low pass filtered white noise, 4th order butterworth
  • 5: Low pass filtered white noise, 16th order butterworth

    • Namespace: ExpSuite
    Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

    Syntax

    Visual Basic
    Public Signal As Integer

    Remarks

    See Also

    FWintern..::..AudioSynth Structure


Vol Field

FWintern..::..AudioSynth..::..Vol Field
FWintern..::..AudioSynth Structure See Also Send Feedback
Volume in dB FS.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Vol As Double

Remarks

See Also

FWintern..::..AudioSynth Structure


FWintern.ExpConstant Structure

FWintern..::..ExpConstant Structure
FWintern Class Members See Also Send Feedback
Structure for an experimental Constant (Settings/Constants)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Structure ExpConstant

Remarks

This structure describes all properties of a constant which can be found in Settings/Constants. The data are saved in gconstExp() with the constant index as index. gconstExp() must be resized to the proper length and set correctly in:
  • Events.OnLoad
  • Callback on change or load of settings
  • Callback on change of experiment type

    • See Also

    FWintern..::..ExpConstant Members


FWintern.ExpConstant Members

[image]

ExpSuite
FWintern..::..ExpConstant Members
FWintern..::..ExpConstant Structure Fields See Also Send Feedback

FrameWork - Declarations and general methods.

The FWintern..::..ExpConstant type exposes the following members.

Fields

 | Name | Description
Public field | dMax | Maximum value, if the restriction vfMax was set.
Public field | dMin | Minimum value, if the restriction vfMin was set.
Public field | Flags | Flags restricting the values, see VariableFlags for more details.
Public field | szDescription | Description of the constant, appears in a tooltip of the constant.
Public field | szName | Name of the constant. Use a short name.
Public field | szUnit | Unit of the constant. Leave blank if not used.
Public field | varDefault | Default value.
Public field | varValue | The values set in Settings/Constants.

See Also

FWintern..::..ExpConstant Structure


FWintern.ExpConstant Fields

[image]

ExpSuite
FWintern..::..ExpConstant Fields
FWintern..::..ExpConstant Structure See Also Send Feedback

The FWintern..::..ExpConstant type exposes the following members.

Fields

 | Name | Description
Public field | dMax | Maximum value, if the restriction vfMax was set.
Public field | dMin | Minimum value, if the restriction vfMin was set.
Public field | Flags | Flags restricting the values, see VariableFlags for more details.
Public field | szDescription | Description of the constant, appears in a tooltip of the constant.
Public field | szName | Name of the constant. Use a short name.
Public field | szUnit | Unit of the constant. Leave blank if not used.
Public field | varDefault | Default value.
Public field | varValue | The values set in Settings/Constants.

See Also

FWintern..::..ExpConstant Structure


dMax Field

FWintern..::..ExpConstant..::..dMax Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Maximum value, if the restriction vfMax was set.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public dMax As Double

Remarks

See Also

FWintern..::..ExpConstant Structure


dMin Field

FWintern..::..ExpConstant..::..dMin Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Minimum value, if the restriction vfMin was set.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public dMin As Double

Remarks

See Also

FWintern..::..ExpConstant Structure


Flags Field

FWintern..::..ExpConstant..::..Flags Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Flags restricting the values, see VariableFlags for more details.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Flags As FWintern..::..VariableFlags

Remarks

See Also

FWintern..::..ExpConstant Structure


szDescription Field

FWintern..::..ExpConstant..::..szDescription Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Description of the constant, appears in a tooltip of the constant.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szDescription As String

Remarks

See Also

FWintern..::..ExpConstant Structure


szName Field

FWintern..::..ExpConstant..::..szName Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Name of the constant. Use a short name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szName As String

Remarks

See Also

FWintern..::..ExpConstant Structure


szUnit Field

FWintern..::..ExpConstant..::..szUnit Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Unit of the constant. Leave blank if not used.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szUnit As String

Remarks

See Also

FWintern..::..ExpConstant Structure


varDefault Field

FWintern..::..ExpConstant..::..varDefault Field
FWintern..::..ExpConstant Structure See Also Send Feedback
Default value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public varDefault As String

Remarks

See Also

FWintern..::..ExpConstant Structure


varValue Field

FWintern..::..ExpConstant..::..varValue Field
FWintern..::..ExpConstant Structure See Also Send Feedback
The values set in Settings/Constants.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public varValue As String

Remarks

See Also

FWintern..::..ExpConstant Structure


FWintern.ExpVariable Structure

FWintern..::..ExpVariable Structure
FWintern Class Members See Also Send Feedback
Structure for an experimental Variable (Settings/Variable)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Structure ExpVariable

Remarks

This structure describes all properties of a variable which can be found in Settings/Variables. The data are saved in gvarExp() with the variable index as index. gvarExp() must be resized to the proper length and set correctly in:
  • Events.OnLoad
  • Callback on change or load of settings
  • Callback on change of experiment type

    • See Also

    FWintern..::..ExpVariable Members
    ExpSuite Namespace
    INISettings..::..gvarExp


FWintern.ExpVariable Members

[image]

ExpSuite
FWintern..::..ExpVariable Members
FWintern..::..ExpVariable Structure Fields See Also Send Feedback

FrameWork - Declarations and general methods.

The FWintern..::..ExpVariable type exposes the following members.

Fields

 | Name | Description
Public field | dMax | Maximum value, if the restriction vfMax was set.
Public field | dMin | Minimum value, if the restriction vfMin was set.
Public field | Flags | Flags restricting the values, see VariableFlags for more details.
Public field | szDefault | Default values. Leave blank if not used. Separate by ; for more values.
Public field | szDescription | Description of the variable, more than one line allowed.
Public field | szName | Name of the variable. Use a short name.
Public field | szUnit | Unit of the variable. Leave blank if not used.
Public field | varValue | Array containing the values set in Settings/Variables.

See Also

FWintern..::..ExpVariable Structure


FWintern.ExpVariable Fields

[image]

ExpSuite
FWintern..::..ExpVariable Fields
FWintern..::..ExpVariable Structure See Also Send Feedback

The FWintern..::..ExpVariable type exposes the following members.

Fields

 | Name | Description
Public field | dMax | Maximum value, if the restriction vfMax was set.
Public field | dMin | Minimum value, if the restriction vfMin was set.
Public field | Flags | Flags restricting the values, see VariableFlags for more details.
Public field | szDefault | Default values. Leave blank if not used. Separate by ; for more values.
Public field | szDescription | Description of the variable, more than one line allowed.
Public field | szName | Name of the variable. Use a short name.
Public field | szUnit | Unit of the variable. Leave blank if not used.
Public field | varValue | Array containing the values set in Settings/Variables.

See Also

FWintern..::..ExpVariable Structure


dMax Field

FWintern..::..ExpVariable..::..dMax Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Maximum value, if the restriction vfMax was set.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public dMax As Double

Remarks

See Also

FWintern..::..ExpVariable Structure


dMin Field

FWintern..::..ExpVariable..::..dMin Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Minimum value, if the restriction vfMin was set.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public dMin As Double

Remarks

See Also

FWintern..::..ExpVariable Structure


Flags Field

FWintern..::..ExpVariable..::..Flags Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Flags restricting the values, see VariableFlags for more details.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Flags As FWintern..::..VariableFlags

Remarks

See Also

FWintern..::..ExpVariable Structure


szDefault Field

FWintern..::..ExpVariable..::..szDefault Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Default values. Leave blank if not used. Separate by ; for more values.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szDefault As String

Remarks

See Also

FWintern..::..ExpVariable Structure


szDescription Field

FWintern..::..ExpVariable..::..szDescription Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Description of the variable, more than one line allowed.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szDescription As String

Remarks

See Also

FWintern..::..ExpVariable Structure


szName Field

FWintern..::..ExpVariable..::..szName Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Name of the variable. Use a short name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szName As String

Remarks

See Also

FWintern..::..ExpVariable Structure


szUnit Field

FWintern..::..ExpVariable..::..szUnit Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Unit of the variable. Leave blank if not used.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public szUnit As String

Remarks

See Also

FWintern..::..ExpVariable Structure


varValue Field

FWintern..::..ExpVariable..::..varValue Field
FWintern..::..ExpVariable Structure See Also Send Feedback
Array containing the values set in Settings/Variables.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public varValue As String()

Remarks

See Also

FWintern..::..ExpVariable Structure


FWintern.VariableFlags Enumeration

FWintern..::..VariableFlags Enumeration
FWintern Class See Also Send Feedback
Flags to restrict the content of Constants or Variables.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Enumeration VariableFlags

Members

Member name | Value | Description
vfString | 0 | Constant/Variable is a string. See String flags for further restrictions.
vfNumeric | 3 | Constant/Variable is numeric. See Numeric flags for further restrictions.
vfDirectory | 2 | Constant/Variable is a directory.
vfFileName | 1 | Constant/Variable is a file name. See Filename flags for further restrictions. Use the Unit parameter to set the file name mask (e.g. *.txt)
vfElectrodeL | 4 | Constant/Variable is a left electrode from Settings/Signal. On default, the AMP is checked to be between THR and MCL.
vfElectrodeR | 5 | Constant/Variable is a right electrode from Settings/Signal. See Electrode flags for further restrictions.
vfFlagTypeMask | 15 | Mask of the flag type. Use "MyFlags AND vfFlagTypeMask" to retrieve the type of the flag.
vfInteger | 16 | Restrict to integer.
vfNonZero | 32 | Numeric Flags: Must not be zero.
vfMinTimeDelay | 256 | Numeric Flags: Must be positive integer.
vfMin | 512 | Numeric/Electrode Flags: Sets a restriction to a minimum value. Use the Min parameter to set the range.
vfMax | 1024 | Numeric/Electrode Flags: Sets a restriction to a maximum value. Use the Max parameter to set the range.
vfOffsetDependent | 2048 | Numeric Flags: The value is dependent on the Offset parameter in Settings/Procedure.
vfVectorized | 4096 | Electrode Flags: Content can be a vector of electrodes, separated by blank or semicolon (not both!).
vfNoTHRCheck | 16 | Electrode Flags: Do not check the AMP field to be higher then the THR field (from Settings/Signal)
vfNoMCLCheck | 32 | Electrode Flags: Do not check the AMP field to be higher then the MCL field (from Settings/Signal)
vfNonEmpty | 16 | String Flags: Content must not be empty.
vfEnumeration | 32 | String Flags: Content must be chosen one from a list given in Unit string. Use the Unit parameter to set the list of atoms selected by ;
vfCaseSensitive | 64 | String Flags: Content is case sensitive.
vfUpperCase | 128 | String Flags: Content will be converted to upper case.
vfLowerCase | 256 | String Flags: Content will be converted to lower case.
vfAbsolute | 0 | File name Flags: Absolute file name including path name.
vfRelativeDataDir1 | 16 | File name Flags: File name, relative to the data directory #1 (index = 0)
vfRelativeDataDir2 | 32 | File name Flags: File name, relative to the data directory #2 (index = 1)
vfRelativeDataDir3 | 48 | File name Flags: File name, relative to the data directory #3 (index = 2)
vfRelativeDataDir4 | 64 | File name Flags: File name, relative to the data directory #4 (index = 3)
vfRelativeDataDir5 | 80 | File name Flags: File name, relative to the data directory #5 (index = 4)
vfRelativeDataDir6 | 96 | File name Flags: File name, relative to the data directory #6 (index = 5)
vfRelativeDataDir7 | 112 | File name Flags: File name, relative to the data directory #7 (index = 6)
vfHidden | 16384 | System Flags: Constant will be hidden. Works for Constants only, use vfDisabled for Variables instead.
vfDisabled | 32768 | System Flags: Constant/Variable will be disabled.
vfLinked | 65536 | Link Flags: Use this flag to link variables to each other by multiplying this flag with the (index+1) of the linked variable. E.g. If the Amplitude is the third variable (gvarExp(2)) and you want to link Electrode to Amplitude, then the flag will be: vfLinked * 3. The link only to the first 15 variables is allowed.

Remarks

Select the type of content (string, numeric, directory of file name) and then use a proper restriction. The Variables can be linked to each other, which means, that number of values in one variable must match the number of values in another one. E.g. link Amplitude and Electrode, if for every electrode another amplitude must exist.

See Also

ExpSuite Namespace

Send comments on this topic to Piotr Majdak & Michael Mihocic

Acoustics Research Institute


HUI Class

HUI Class
Members See Also Send Feedback
FrameWork - Internal use only.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class HUI

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..HUI

See Also

HUI Members


HUI Members

[image]

ExpSuite
HUI Members
HUI Class Constructors See Also Send Feedback

Constructors

Name | Description
HUI |

See Also

HUI Class


HUI Constructor

HUI Constructor
HUI Class See Also Send Feedback
Initializes the static fields of the HUI class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Shared Sub New

See Also

HUI Class


INIOptions Class

INIOptions Class
Members See Also Send Feedback
FrameWork - Handling of Options.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class INIOptions

Remarks

This module allows to use parameter files to read/write global parameters used in a project. Once defined all parameters, simple functions to read and write the complete parameter files are provided.
How to use:
  • complete all tasks marked as TODO in this module
  • set all parameters to default values before reading the file (Form_Load is a good place to do that task)
  • to read the parameter file call ReadFile "myparameterfile.ini"
  • to write the parameter file call WriteFile "myparameterfile.ini"
  • to search for a key call FindKey "myparameterfile.ini", "wantedkey"

    • Inheritance Hierarchy

    System..::..Object
    ExpSuite..::..INIOptions

    See Also

    INIOptions Members


INIOptions Members

[image]

ExpSuite
INIOptions Members
INIOptions Class Fields See Also Send Feedback

The INIOptions type exposes the following members.

Fields

Name | Description
gblnAutoBackupItemList | Auto Backup Item List? (Options/General)
gblnAutoBackupLogFile | Auto Backup Log File? (Options/General)
gblnCheckForUpdates | Enable automatic check for updates when starting program
gblnDisableSetOptimalColWidth | Disable automatic setting of column width
gblnPlayWaveExp | Play wave file in break or when finishing experiment (Options/General)
gblnRIB2Simulation | Simulate the RIB2 device? (Options/RIB2)
gblnRIBSimulation | Simulate the RIB server? (Options/RIB)
gblnTrackerSimulation | Simulate tracker? (Options/Tracker)
gblnUseFileNaming | Use File Naming rules? See: File naming system.sxw (Options/General)
gblnUseMATLAB | Use MATLAB?
gbShowDR | Show Dynamic Range in LevelDancer
gLastUpdateCheck | Last check for updates
glCOMLeft | COM port for the left RIB (Options/RIB)
glCOMRight | COM port for the right RIB (Options/RIB)
glCSVDelimiter | Delimiter between arguments in a CSV file (Options/CSV Export)
glCSVQuota | Quota for arguments containing delimiter in a CSV file (Options(CSV Export)
glFileNamingFlags | Flags of the post fix naming of the item list (frmItemListPostFix, appears on Save Item List)
glFlagBeepExp | Use Beeps in Experiment (Options/General)
glLocalNetPort | Port of the application from the point of view of YAMI (Options/Audio)
glLogMode | Mode of logging the experiment (Options/STIM)
glPlayerAudioDevice | Index of the audio device used by YAMI (Options/Audio)
glPlayerChannels | Number of channels used by YAMI (Options/Audio)
glPlayerFlags | Flags of YAMI (Options/Audio)
glPlayerHPLeft | Headphones: Left channel
glPlayerHPRight | Headphones: Right channel
glPlayerMIDIInDevice | Index of MIDI In Device used by YAMI (Options/Audio)
glPlayerMIDIOutDevice | Index of MIDI Out Device used by YAMI (Options/Audio)
glPlayerNetPort | Port of YAMI (Options/Audio)
glShowStimulusFlags | Stimulus Flags (Show Stimulus or Matlab/ShowStimulus.m)
glTrackerBaudrate | Tracker: Baudrate of the communication (Options/Tracker)
glTrackerCOM | COM port for tracker (Options/Tracker). 0=deactivated
glTrackerSensorCount | Tracker: Number of sensors connected available (Options/Tracker)
glTrackerSettingsInterval | Tracker: Interval of data update in the Settings/Tracker form (Options/Tracker)
glTTLPT | LPT (Printer port) for Turntable (Options/Turntable). 0=deactivated
glViWoPort | Port of the service listening on the computer running ViWo
glWarningSwitches | Warning Switches (Options/General)
grectFitt4Fun | Position/size of the Level Dancer dialog
grectLevelDancer | Position/size of the Level Dancer dialog.
grectMain | Position/size of the main window
grectOptions | Position/size of the Options dialog.
grectSettings | Position/size of the Settings dialog.
gsngTTOffset | Offset of the turntable, this azimuth corresponds to real zero (Options/Turntable)
gsngTTResolution | Resolution of the Turntable (n.a. in a form, hardware depended)
gszCurrentDir | Current active directory (not available in any form)
gszItemListPostFix | User post fix of the item list (frmItemListPostFix, appears on Save Item List)
gszLocalNetAddr | IP Address of the application from the point of view of YAMI (Options/Audio)
gszMATLABPath | Path to MATLAB scripts
gszNICPath | Path to NIC files (Options/NIC)
gszOptionsFile | Full path and file name of options file
gszPlayerFileName | File name of the YAMI application (Options/Audio)
gszPlayerNetAddr | IP Address of YAMI (Options/Audio)
gszRIB2DeviceName | Device name for IO-card for RIB2 (Options/RIB2)
gszRIB2Path | Path to RIB2 files (Options/RIB2)
gszRIBPath | Path to RIB files (Options/RIB)
gszRIBServer | Filename of the RIB server application (Options/RIB)
gszShowStimulusAxes | Axes Parameters (Show Stimulus or Matlab/ShowStimulus.m)
gszShowStimulusParameter | Parameters (Show Stimulus or Matlab/ShowStimulus.m)
gszViWoAddress | IP Address (or name) of the computer running ViWo
gUpdateInterval | Interval to check for updates (days)
JoyPads |

See Also

INIOptions Class


INIOptions Fields

[image]

ExpSuite
INIOptions Fields
INIOptions Class See Also Send Feedback

The INIOptions type exposes the following members.

Fields

Name | Description
gblnAutoBackupItemList | Auto Backup Item List? (Options/General)
gblnAutoBackupLogFile | Auto Backup Log File? (Options/General)
gblnCheckForUpdates | Enable automatic check for updates when starting program
gblnDisableSetOptimalColWidth | Disable automatic setting of column width
gblnPlayWaveExp | Play wave file in break or when finishing experiment (Options/General)
gblnRIB2Simulation | Simulate the RIB2 device? (Options/RIB2)
gblnRIBSimulation | Simulate the RIB server? (Options/RIB)
gblnTrackerSimulation | Simulate tracker? (Options/Tracker)
gblnUseFileNaming | Use File Naming rules? See: File naming system.sxw (Options/General)
gblnUseMATLAB | Use MATLAB?
gbShowDR | Show Dynamic Range in LevelDancer
gLastUpdateCheck | Last check for updates
glCOMLeft | COM port for the left RIB (Options/RIB)
glCOMRight | COM port for the right RIB (Options/RIB)
glCSVDelimiter | Delimiter between arguments in a CSV file (Options/CSV Export)
glCSVQuota | Quota for arguments containing delimiter in a CSV file (Options(CSV Export)
glFileNamingFlags | Flags of the post fix naming of the item list (frmItemListPostFix, appears on Save Item List)
glFlagBeepExp | Use Beeps in Experiment (Options/General)
glLocalNetPort | Port of the application from the point of view of YAMI (Options/Audio)
glLogMode | Mode of logging the experiment (Options/STIM)
glPlayerAudioDevice | Index of the audio device used by YAMI (Options/Audio)
glPlayerChannels | Number of channels used by YAMI (Options/Audio)
glPlayerFlags | Flags of YAMI (Options/Audio)
glPlayerHPLeft | Headphones: Left channel
glPlayerHPRight | Headphones: Right channel
glPlayerMIDIInDevice | Index of MIDI In Device used by YAMI (Options/Audio)
glPlayerMIDIOutDevice | Index of MIDI Out Device used by YAMI (Options/Audio)
glPlayerNetPort | Port of YAMI (Options/Audio)
glShowStimulusFlags | Stimulus Flags (Show Stimulus or Matlab/ShowStimulus.m)
glTrackerBaudrate | Tracker: Baudrate of the communication (Options/Tracker)
glTrackerCOM | COM port for tracker (Options/Tracker). 0=deactivated
glTrackerSensorCount | Tracker: Number of sensors connected available (Options/Tracker)
glTrackerSettingsInterval | Tracker: Interval of data update in the Settings/Tracker form (Options/Tracker)
glTTLPT | LPT (Printer port) for Turntable (Options/Turntable). 0=deactivated
glViWoPort | Port of the service listening on the computer running ViWo
glWarningSwitches | Warning Switches (Options/General)
grectFitt4Fun | Position/size of the Level Dancer dialog
grectLevelDancer | Position/size of the Level Dancer dialog.
grectMain | Position/size of the main window
grectOptions | Position/size of the Options dialog.
grectSettings | Position/size of the Settings dialog.
gsngTTOffset | Offset of the turntable, this azimuth corresponds to real zero (Options/Turntable)
gsngTTResolution | Resolution of the Turntable (n.a. in a form, hardware depended)
gszCurrentDir | Current active directory (not available in any form)
gszItemListPostFix | User post fix of the item list (frmItemListPostFix, appears on Save Item List)
gszLocalNetAddr | IP Address of the application from the point of view of YAMI (Options/Audio)
gszMATLABPath | Path to MATLAB scripts
gszNICPath | Path to NIC files (Options/NIC)
gszOptionsFile | Full path and file name of options file
gszPlayerFileName | File name of the YAMI application (Options/Audio)
gszPlayerNetAddr | IP Address of YAMI (Options/Audio)
gszRIB2DeviceName | Device name for IO-card for RIB2 (Options/RIB2)
gszRIB2Path | Path to RIB2 files (Options/RIB2)
gszRIBPath | Path to RIB files (Options/RIB)
gszRIBServer | Filename of the RIB server application (Options/RIB)
gszShowStimulusAxes | Axes Parameters (Show Stimulus or Matlab/ShowStimulus.m)
gszShowStimulusParameter | Parameters (Show Stimulus or Matlab/ShowStimulus.m)
gszViWoAddress | IP Address (or name) of the computer running ViWo
gUpdateInterval | Interval to check for updates (days)
JoyPads |

See Also

INIOptions Class


gblnAutoBackupItemList Field

INIOptions..::..gblnAutoBackupItemList Field
INIOptions Class See Also Send Feedback
Auto Backup Item List? (Options/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnAutoBackupItemList As Boolean

Remarks

Automatically backup (save) item list in output folder

See Also

INIOptions Class


gblnAutoBackupLogFile Field

INIOptions..::..gblnAutoBackupLogFile Field
INIOptions Class See Also Send Feedback
Auto Backup Log File? (Options/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnAutoBackupLogFile As Boolean

Remarks

Automatically backup (save) log file when disconnecting

See Also

INIOptions Class


gblnCheckForUpdates Field

INIOptions..::..gblnCheckForUpdates Field
INIOptions Class See Also Send Feedback
Enable automatic check for updates when starting program

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnCheckForUpdates As Boolean

Remarks

See Also

INIOptions Class


gblnDisableSetOptimalColWidth Field

INIOptions..::..gblnDisableSetOptimalColWidth Field
INIOptions Class See Also Send Feedback
Disable automatic setting of column width

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnDisableSetOptimalColWidth As Boolean

Remarks

See Also

INIOptions Class


gblnPlayWaveExp Field

INIOptions..::..gblnPlayWaveExp Field
INIOptions Class See Also Send Feedback
Play wave file in break or when finishing experiment (Options/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnPlayWaveExp As Boolean

Remarks

See Also

INIOptions Class


gblnRIB2Simulation Field

INIOptions..::..gblnRIB2Simulation Field
INIOptions Class See Also Send Feedback
Simulate the RIB2 device? (Options/RIB2)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnRIB2Simulation As Boolean

Remarks

See Also

INIOptions Class


gblnRIBSimulation Field

INIOptions..::..gblnRIBSimulation Field
INIOptions Class See Also Send Feedback
Simulate the RIB server? (Options/RIB)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnRIBSimulation As Boolean

Remarks

See Also

INIOptions Class


gblnTrackerSimulation Field

INIOptions..::..gblnTrackerSimulation Field
INIOptions Class See Also Send Feedback
Simulate tracker? (Options/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnTrackerSimulation As Boolean

Remarks

See Also

INIOptions Class


gblnUseFileNaming Field

INIOptions..::..gblnUseFileNaming Field
INIOptions Class See Also Send Feedback
Use File Naming rules? See: File naming system.sxw (Options/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnUseFileNaming As Boolean

Remarks

See Also

INIOptions Class


gblnUseMATLAB Field

INIOptions..::..gblnUseMATLAB Field
INIOptions Class See Also Send Feedback
Use MATLAB?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnUseMATLAB As Boolean

Remarks

See Also

INIOptions Class


gbShowDR Field

INIOptions..::..gbShowDR Field
INIOptions Class See Also Send Feedback
Show Dynamic Range in LevelDancer

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gbShowDR As Boolean

Remarks

See Also

INIOptions Class


gLastUpdateCheck Field

INIOptions..::..gLastUpdateCheck Field
INIOptions Class See Also Send Feedback
Last check for updates

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gLastUpdateCheck As String

Remarks

See Also

INIOptions Class


glCOMLeft Field

INIOptions..::..glCOMLeft Field
INIOptions Class See Also Send Feedback
COM port for the left RIB (Options/RIB)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glCOMLeft As Integer

Remarks

See Also

INIOptions Class


glCOMRight Field

INIOptions..::..glCOMRight Field
INIOptions Class See Also Send Feedback
COM port for the right RIB (Options/RIB)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glCOMRight As Integer

Remarks

See Also

INIOptions Class


glCSVDelimiter Field

INIOptions..::..glCSVDelimiter Field
INIOptions Class See Also Send Feedback
Delimiter between arguments in a CSV file (Options/CSV Export)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glCSVDelimiter As Integer

Remarks

See Also

INIOptions Class


glCSVQuota Field

INIOptions..::..glCSVQuota Field
INIOptions Class See Also Send Feedback
Quota for arguments containing delimiter in a CSV file (Options(CSV Export)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glCSVQuota As Integer

Remarks

See Also

INIOptions Class


glFileNamingFlags Field

INIOptions..::..glFileNamingFlags Field
INIOptions Class See Also Send Feedback
Flags of the post fix naming of the item list (frmItemListPostFix, appears on Save Item List)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glFileNamingFlags As Integer

Remarks

See Also

INIOptions Class


glFlagBeepExp Field

INIOptions..::..glFlagBeepExp Field
INIOptions Class See Also Send Feedback
Use Beeps in Experiment (Options/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glFlagBeepExp As Integer

Remarks

See Also

INIOptions Class


glLocalNetPort Field

INIOptions..::..glLocalNetPort Field
INIOptions Class See Also Send Feedback
Port of the application from the point of view of YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glLocalNetPort As Integer

Remarks

See Also

INIOptions Class


glLogMode Field

INIOptions..::..glLogMode Field
INIOptions Class See Also Send Feedback
Mode of logging the experiment (Options/STIM)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glLogMode As Integer

Remarks

See Also

INIOptions Class


glPlayerAudioDevice Field

INIOptions..::..glPlayerAudioDevice Field
INIOptions Class See Also Send Feedback
Index of the audio device used by YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerAudioDevice As Integer

Remarks

See Also

INIOptions Class


glPlayerChannels Field

INIOptions..::..glPlayerChannels Field
INIOptions Class See Also Send Feedback
Number of channels used by YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerChannels As Integer

Remarks

See Also

INIOptions Class


glPlayerFlags Field

INIOptions..::..glPlayerFlags Field
INIOptions Class See Also Send Feedback
Flags of YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerFlags As PLAYERFLAGS

Remarks

See Also

INIOptions Class


glPlayerHPLeft Field

INIOptions..::..glPlayerHPLeft Field
INIOptions Class See Also Send Feedback
Headphones: Left channel

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerHPLeft As Integer

Remarks

See Also

INIOptions Class


glPlayerHPRight Field

INIOptions..::..glPlayerHPRight Field
INIOptions Class See Also Send Feedback
Headphones: Right channel

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerHPRight As Integer

Remarks

See Also

INIOptions Class


glPlayerMIDIInDevice Field

INIOptions..::..glPlayerMIDIInDevice Field
INIOptions Class See Also Send Feedback
Index of MIDI In Device used by YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerMIDIInDevice As Integer

Remarks

See Also

INIOptions Class


glPlayerMIDIOutDevice Field

INIOptions..::..glPlayerMIDIOutDevice Field
INIOptions Class See Also Send Feedback
Index of MIDI Out Device used by YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerMIDIOutDevice As Integer

Remarks

See Also

INIOptions Class


glPlayerNetPort Field

INIOptions..::..glPlayerNetPort Field
INIOptions Class See Also Send Feedback
Port of YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPlayerNetPort As Integer

Remarks

See Also

INIOptions Class


glShowStimulusFlags Field

INIOptions..::..glShowStimulusFlags Field
INIOptions Class See Also Send Feedback
Stimulus Flags (Show Stimulus or Matlab/ShowStimulus.m)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glShowStimulusFlags As Integer

Remarks

See Also

INIOptions Class


glTrackerBaudrate Field

INIOptions..::..glTrackerBaudrate Field
INIOptions Class See Also Send Feedback
Tracker: Baudrate of the communication (Options/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glTrackerBaudrate As Integer

Remarks

See Also

INIOptions Class


glTrackerCOM Field

INIOptions..::..glTrackerCOM Field
INIOptions Class See Also Send Feedback
COM port for tracker (Options/Tracker). 0=deactivated

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glTrackerCOM As Integer

Remarks

See Also

INIOptions Class


glTrackerSensorCount Field

INIOptions..::..glTrackerSensorCount Field
INIOptions Class See Also Send Feedback
Tracker: Number of sensors connected available (Options/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glTrackerSensorCount As Integer

Remarks

See Also

INIOptions Class


glTrackerSettingsInterval Field

INIOptions..::..glTrackerSettingsInterval Field
INIOptions Class See Also Send Feedback
Tracker: Interval of data update in the Settings/Tracker form (Options/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glTrackerSettingsInterval As Integer

Remarks

See Also

INIOptions Class


glTTLPT Field

INIOptions..::..glTTLPT Field
INIOptions Class See Also Send Feedback
LPT (Printer port) for Turntable (Options/Turntable). 0=deactivated

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glTTLPT As Integer

Remarks

See Also

INIOptions Class


glViWoPort Field

INIOptions..::..glViWoPort Field
INIOptions Class See Also Send Feedback
Port of the service listening on the computer running ViWo

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glViWoPort As Integer

Remarks

See Also

INIOptions Class


glWarningSwitches Field

INIOptions..::..glWarningSwitches Field
INIOptions Class See Also Send Feedback
Warning Switches (Options/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glWarningSwitches As WarningSwitches

Remarks

See Also

INIOptions Class


grectFitt4Fun Field

INIOptions..::..grectFitt4Fun Field
INIOptions Class See Also Send Feedback
Position/size of the Level Dancer dialog

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared grectFitt4Fun As RECT

Remarks

See Also

INIOptions Class


grectLevelDancer Field

INIOptions..::..grectLevelDancer Field
INIOptions Class See Also Send Feedback
Position/size of the Level Dancer dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared grectLevelDancer As RECT

Remarks

See Also

INIOptions Class


grectMain Field

INIOptions..::..grectMain Field
INIOptions Class See Also Send Feedback
Position/size of the main window

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared grectMain As RECT

Remarks

See Also

INIOptions Class


grectOptions Field

INIOptions..::..grectOptions Field
INIOptions Class See Also Send Feedback
Position/size of the Options dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared grectOptions As RECT

Remarks

See Also

INIOptions Class


grectSettings Field

INIOptions..::..grectSettings Field
INIOptions Class See Also Send Feedback
Position/size of the Settings dialog.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared grectSettings As RECT

Remarks

See Also

INIOptions Class


gsngTTOffset Field

INIOptions..::..gsngTTOffset Field
INIOptions Class See Also Send Feedback
Offset of the turntable, this azimuth corresponds to real zero (Options/Turntable)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsngTTOffset As Double

Remarks

See Also

INIOptions Class


gsngTTResolution Field

INIOptions..::..gsngTTResolution Field
INIOptions Class See Also Send Feedback
Resolution of the Turntable (n.a. in a form, hardware depended)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsngTTResolution As Double

Remarks

See Also

INIOptions Class


gszCurrentDir Field

INIOptions..::..gszCurrentDir Field
INIOptions Class See Also Send Feedback
Current active directory (not available in any form)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszCurrentDir As String

Remarks

See Also

INIOptions Class


gszItemListPostFix Field

INIOptions..::..gszItemListPostFix Field
INIOptions Class See Also Send Feedback
User post fix of the item list (frmItemListPostFix, appears on Save Item List)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszItemListPostFix As String

Remarks

See Also

INIOptions Class


gszLocalNetAddr Field

INIOptions..::..gszLocalNetAddr Field
INIOptions Class See Also Send Feedback
IP Address of the application from the point of view of YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszLocalNetAddr As String

Remarks

See Also

INIOptions Class


gszMATLABPath Field

INIOptions..::..gszMATLABPath Field
INIOptions Class See Also Send Feedback
Path to MATLAB scripts

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszMATLABPath As String

Remarks

See Also

INIOptions Class


gszNICPath Field

INIOptions..::..gszNICPath Field
INIOptions Class See Also Send Feedback
Path to NIC files (Options/NIC)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszNICPath As String

Remarks

See Also

INIOptions Class


gszOptionsFile Field

INIOptions..::..gszOptionsFile Field
INIOptions Class See Also Send Feedback
Full path and file name of options file

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszOptionsFile As String

Remarks

See Also

INIOptions Class


gszPlayerFileName Field

INIOptions..::..gszPlayerFileName Field
INIOptions Class See Also Send Feedback
File name of the YAMI application (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszPlayerFileName As String

Remarks

See Also

INIOptions Class


gszPlayerNetAddr Field

INIOptions..::..gszPlayerNetAddr Field
INIOptions Class See Also Send Feedback
IP Address of YAMI (Options/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszPlayerNetAddr As String

Remarks

See Also

INIOptions Class


gszRIB2DeviceName Field

INIOptions..::..gszRIB2DeviceName Field
INIOptions Class See Also Send Feedback
Device name for IO-card for RIB2 (Options/RIB2)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszRIB2DeviceName As String

Remarks

See Also

INIOptions Class


gszRIB2Path Field

INIOptions..::..gszRIB2Path Field
INIOptions Class See Also Send Feedback
Path to RIB2 files (Options/RIB2)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszRIB2Path As String

Remarks

See Also

INIOptions Class


gszRIBPath Field

INIOptions..::..gszRIBPath Field
INIOptions Class See Also Send Feedback
Path to RIB files (Options/RIB)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszRIBPath As String

Remarks

See Also

INIOptions Class


gszRIBServer Field

INIOptions..::..gszRIBServer Field
INIOptions Class See Also Send Feedback
Filename of the RIB server application (Options/RIB)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszRIBServer As String

Remarks

See Also

INIOptions Class


gszShowStimulusAxes Field

INIOptions..::..gszShowStimulusAxes Field
INIOptions Class See Also Send Feedback
Axes Parameters (Show Stimulus or Matlab/ShowStimulus.m)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszShowStimulusAxes As String

Remarks

See Also

INIOptions Class


gszShowStimulusParameter Field

INIOptions..::..gszShowStimulusParameter Field
INIOptions Class See Also Send Feedback
Parameters (Show Stimulus or Matlab/ShowStimulus.m)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszShowStimulusParameter As String

Remarks

See Also

INIOptions Class


gszViWoAddress Field

INIOptions..::..gszViWoAddress Field
INIOptions Class See Also Send Feedback
IP Address (or name) of the computer running ViWo

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszViWoAddress As String

Remarks

See Also

INIOptions Class


gUpdateInterval Field

INIOptions..::..gUpdateInterval Field
INIOptions Class See Also Send Feedback
Interval to check for updates (days)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gUpdateInterval As Integer

Remarks

See Also

INIOptions Class


JoyPads Field

INIOptions..::..JoyPads Field
INIOptions Class See Also Send Feedback

[Missing <summary> documentation for "F:ExpSuite.INIOptions.JoyPads"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared JoyPads As JoyPad()

See Also

INIOptions Class


INISettings Class

INISettings Class
Members See Also Send Feedback
FrameWork - Handling of Settings.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class INISettings

Remarks

This module allows to use parameter files to read/write settings used in a project. Once defined all parameters, simple functions to read and write the complete parameter files are provided.
Author: Piotr Majdak

How to use:
  • complete all tasks marked as TODO in this module
  • set all parameters to default values before reading the file
    • (Form_Load is a good place to do that task)
  • to read the parameter file call ReadFile "myparameterfile.ini"
  • to write the parameter file call WriteFile "myparameterfile.ini"
  • to search for a key call FindKey "myparameterfile.ini", "wantedkey"

    • Inheritance Hierarchy

    System..::..Object
    ExpSuite..::..INISettings

    See Also

    INISettings Members


INISettings Members

[image]

ExpSuite
INISettings Members
INISettings Class Methods Fields See Also Send Feedback

The INISettings type exposes the following members.

Methods

Name | Description
RemoteParseLine |
SignalDefault | Set the default values for new electrodes in Settings/Signal

Fields

Name | Description
gAudioSynth | Synthesizer parameters (Settings/Audio)
gblnDestinationDir | Use the windows temporary directory as the root directory? (Settings/General/Output directory)
gblnDoNotConnectToDevice | Do not connect to device (no pd player for acoustical stimulation and no RIB/NIC server for electrical stimulation)
gblnExpOnTop | Show the experiment form alwyas on the top? (Settings/Experiment Screen)
gblnNewWorkDir | Create a new work directory? (Settings/General/Output directory)
gblnSilentMode | Silent Mode (=no logging to files or list, logging mode will be 0)
gblnTrackerUse | Use tracker? (Settings/Tracker)
gblnTTUse | Use Turntable? (Settings/General/Turntable)
gconstExp | All experimental constants (Settings/Constants)
gfreqParL | Parameters of defined electrodes or acoust. channels (Setting/Signal)
gfreqParR | Parameters of defined electrodes or acoust. channels (Setting/Signal)
glAudioDACAddStream | Connect a synthesizer to an output channel (Settings/Audio)
glBreakFlags | Flags to specify the break interval (Settings/Procedure)
glBreakInterval | Break after a given interval (Settings/Procedure)
glElectrodeL | Selected electrode left (Settings/Signal/[Electrode | Acoust. Channel])
glElectrodeR | Selected electrode right (Settings/Signal/[Electrode | Acoust. Channel])
glExperimentEndItem | End item of the experiment
glExperimentStartItem | Start item of the experiment
glExpFlags | Experiment Flags (Settings/Experiment Screen)
glExpHUIID | Selected Human Interface Device (Settings/Experiment Screen)
glExpType | Selected experiment type (Settings/Procedure)
glImpLeft | Left implant used (RIB2)
glImpRight | Right implant used (RIB2)
glInterStimBreak | Interstimulus break (Settings/Procedure)
glOffsetL | Stimulus Offset Left (Settings/Procedure)
glOffsetR | Stimulus Offset Right (Settings/Procedure)
glPostStimVisu | Poststimulus Visual Offset (Settings/Procedure)
glPreStimBreak | Prestimulus break (Settings/Procedure)
glPreStimVisu | Prestimulus Visual Offset (Settings/Procedure)
glRepetition | Repetitions of a block of items (Settings/Procedure)
glResolution | Resolution (quantization) of the audio output signal (Settings/Audio)
glSamplingRate | Sampling rate of the audio device (Settings/Audio)
glTrackerRepRate | Repetition Rate of the tracker data (Settings/Tracker)
grectExp | Position and size of the experimental form (Settings/Experiment Screen)
gsFadeIn | Fade in every audio signal (Settings/Audio)
gsFadeOut | Fade out every audio signal (Settings/Audio)
gsLDPulsePeriodL |
gsLDPulsePeriodR |
gsngTrackerPosScaling | Position Scaling (max. range) of the tracker data (Settings/Tracker)
gsngViWoAvgHead | Averaging window for the data of the head sensor
gsngViWoAvgPointer | Averaging window for the data of the pointer sensor
gStimOutput | How to present the stimuli? (Settings/General)
gszDescription | Description of the experiment (Settings/Description)
gszDestinationDir | Root Directory (Settings/General/Output directory)
gszExpID | The ID of the experiment (Settings/Description)
gszFittFileLeft | File name of the fitting file left (Settings/Fitting Left)
gszFittFileRight | File name of the fitting file right (Settings/Fitting Right)
gszItemListTitle | The title (file name without path) of the item list linked to the settings (Main Window/General information)
gszSourceDir | Source Directory of fitting files (Settings/Fitting Left)
gszViWoWorld | Name of the selected world.
gtsTrackerMax | Maximum ranges of a tracker sensor (Settings/Tracker/Click on a position/angle)
gtsTrackerMin | Minimum ranges of a tracker sensor (Settings/Tracker/Click on a position/angle)
gtsTrackerOffset | Offset of a tracker sensor (Settings/Tracker/Set Offset)
gtsTrackerValues | Default Values of a tracker sensor (Settings/Tracker/Set Values)
gvarExp | All experimental variables (Settings/Variables)

See Also

INISettings Class


INISettings Fields

[image]

ExpSuite
INISettings Fields
INISettings Class See Also Send Feedback

The INISettings type exposes the following members.

Fields

Name | Description
gAudioSynth | Synthesizer parameters (Settings/Audio)
gblnDestinationDir | Use the windows temporary directory as the root directory? (Settings/General/Output directory)
gblnDoNotConnectToDevice | Do not connect to device (no pd player for acoustical stimulation and no RIB/NIC server for electrical stimulation)
gblnExpOnTop | Show the experiment form alwyas on the top? (Settings/Experiment Screen)
gblnNewWorkDir | Create a new work directory? (Settings/General/Output directory)
gblnSilentMode | Silent Mode (=no logging to files or list, logging mode will be 0)
gblnTrackerUse | Use tracker? (Settings/Tracker)
gblnTTUse | Use Turntable? (Settings/General/Turntable)
gconstExp | All experimental constants (Settings/Constants)
gfreqParL | Parameters of defined electrodes or acoust. channels (Setting/Signal)
gfreqParR | Parameters of defined electrodes or acoust. channels (Setting/Signal)
glAudioDACAddStream | Connect a synthesizer to an output channel (Settings/Audio)
glBreakFlags | Flags to specify the break interval (Settings/Procedure)
glBreakInterval | Break after a given interval (Settings/Procedure)
glElectrodeL | Selected electrode left (Settings/Signal/[Electrode | Acoust. Channel])
glElectrodeR | Selected electrode right (Settings/Signal/[Electrode | Acoust. Channel])
glExperimentEndItem | End item of the experiment
glExperimentStartItem | Start item of the experiment
glExpFlags | Experiment Flags (Settings/Experiment Screen)
glExpHUIID | Selected Human Interface Device (Settings/Experiment Screen)
glExpType | Selected experiment type (Settings/Procedure)
glImpLeft | Left implant used (RIB2)
glImpRight | Right implant used (RIB2)
glInterStimBreak | Interstimulus break (Settings/Procedure)
glOffsetL | Stimulus Offset Left (Settings/Procedure)
glOffsetR | Stimulus Offset Right (Settings/Procedure)
glPostStimVisu | Poststimulus Visual Offset (Settings/Procedure)
glPreStimBreak | Prestimulus break (Settings/Procedure)
glPreStimVisu | Prestimulus Visual Offset (Settings/Procedure)
glRepetition | Repetitions of a block of items (Settings/Procedure)
glResolution | Resolution (quantization) of the audio output signal (Settings/Audio)
glSamplingRate | Sampling rate of the audio device (Settings/Audio)
glTrackerRepRate | Repetition Rate of the tracker data (Settings/Tracker)
grectExp | Position and size of the experimental form (Settings/Experiment Screen)
gsFadeIn | Fade in every audio signal (Settings/Audio)
gsFadeOut | Fade out every audio signal (Settings/Audio)
gsLDPulsePeriodL |
gsLDPulsePeriodR |
gsngTrackerPosScaling | Position Scaling (max. range) of the tracker data (Settings/Tracker)
gsngViWoAvgHead | Averaging window for the data of the head sensor
gsngViWoAvgPointer | Averaging window for the data of the pointer sensor
gStimOutput | How to present the stimuli? (Settings/General)
gszDescription | Description of the experiment (Settings/Description)
gszDestinationDir | Root Directory (Settings/General/Output directory)
gszExpID | The ID of the experiment (Settings/Description)
gszFittFileLeft | File name of the fitting file left (Settings/Fitting Left)
gszFittFileRight | File name of the fitting file right (Settings/Fitting Right)
gszItemListTitle | The title (file name without path) of the item list linked to the settings (Main Window/General information)
gszSourceDir | Source Directory of fitting files (Settings/Fitting Left)
gszViWoWorld | Name of the selected world.
gtsTrackerMax | Maximum ranges of a tracker sensor (Settings/Tracker/Click on a position/angle)
gtsTrackerMin | Minimum ranges of a tracker sensor (Settings/Tracker/Click on a position/angle)
gtsTrackerOffset | Offset of a tracker sensor (Settings/Tracker/Set Offset)
gtsTrackerValues | Default Values of a tracker sensor (Settings/Tracker/Set Values)
gvarExp | All experimental variables (Settings/Variables)

See Also

INISettings Class


gAudioSynth Field

INISettings..::..gAudioSynth Field
INISettings Class See Also Send Feedback
Synthesizer parameters (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gAudioSynth As FWintern..::..AudioSynth()

Remarks

See Also

INISettings Class


gblnDestinationDir Field

INISettings..::..gblnDestinationDir Field
INISettings Class See Also Send Feedback
Use the windows temporary directory as the root directory? (Settings/General/Output directory)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnDestinationDir As Boolean

Remarks

See Also

INISettings Class


gblnDoNotConnectToDevice Field

INISettings..::..gblnDoNotConnectToDevice Field
INISettings Class See Also Send Feedback
Do not connect to device (no pd player for acoustical stimulation and no RIB/NIC server for electrical stimulation)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnDoNotConnectToDevice As Boolean

Remarks

See Also

INISettings Class


gblnExpOnTop Field

INISettings..::..gblnExpOnTop Field
INISettings Class See Also Send Feedback
Show the experiment form alwyas on the top? (Settings/Experiment Screen)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnExpOnTop As Boolean

Remarks

See Also

INISettings Class


gblnNewWorkDir Field

INISettings..::..gblnNewWorkDir Field
INISettings Class See Also Send Feedback
Create a new work directory? (Settings/General/Output directory)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnNewWorkDir As Boolean

Remarks

See Also

INISettings Class


gblnSilentMode Field

INISettings..::..gblnSilentMode Field
INISettings Class See Also Send Feedback
Silent Mode (=no logging to files or list, logging mode will be 0)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnSilentMode As Boolean

Remarks

See Also

INISettings Class


gblnTrackerUse Field

INISettings..::..gblnTrackerUse Field
INISettings Class See Also Send Feedback
Use tracker? (Settings/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnTrackerUse As Boolean

Remarks

See Also

INISettings Class


gblnTTUse Field

INISettings..::..gblnTTUse Field
INISettings Class See Also Send Feedback
Use Turntable? (Settings/General/Turntable)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gblnTTUse As Boolean

Remarks

See Also

INISettings Class


gconstExp Field

INISettings..::..gconstExp Field
INISettings Class See Also Send Feedback
All experimental constants (Settings/Constants)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gconstExp As FWintern..::..ExpConstant()

Remarks

See Also

INISettings Class


gfreqParL Field

INISettings..::..gfreqParL Field
INISettings Class See Also Send Feedback
Parameters of defined electrodes or acoust. channels (Setting/Signal)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gfreqParL As clsFREQUENCY()

Remarks

See Also

INISettings Class


gfreqParR Field

INISettings..::..gfreqParR Field
INISettings Class See Also Send Feedback
Parameters of defined electrodes or acoust. channels (Setting/Signal)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gfreqParR As clsFREQUENCY()

Remarks

See Also

INISettings Class


glAudioDACAddStream Field

INISettings..::..glAudioDACAddStream Field
INISettings Class See Also Send Feedback
Connect a synthesizer to an output channel (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glAudioDACAddStream As Integer()

Remarks

See Also

INISettings Class


glBreakFlags Field

INISettings..::..glBreakFlags Field
INISettings Class See Also Send Feedback
Flags to specify the break interval (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glBreakFlags As Integer

Remarks

Bit 0: break/no break, Bit 1,2: 0:break on minutes, 1:break on items.

See Also

INISettings Class


glBreakInterval Field

INISettings..::..glBreakInterval Field
INISettings Class See Also Send Feedback
Break after a given interval (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glBreakInterval As Integer

Remarks

See Also

INISettings Class


glElectrodeL Field

INISettings..::..glElectrodeL Field
INISettings Class See Also Send Feedback
Selected electrode left (Settings/Signal/[Electrode | Acoust. Channel])

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glElectrodeL As Integer

Remarks

See Also

INISettings Class


glElectrodeR Field

INISettings..::..glElectrodeR Field
INISettings Class See Also Send Feedback
Selected electrode right (Settings/Signal/[Electrode | Acoust. Channel])

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glElectrodeR As Integer

Remarks

See Also

INISettings Class


glExperimentEndItem Field

INISettings..::..glExperimentEndItem Field
INISettings Class See Also Send Feedback
End item of the experiment

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExperimentEndItem As Integer

Remarks

See Also

INISettings Class


glExperimentStartItem Field

INISettings..::..glExperimentStartItem Field
INISettings Class See Also Send Feedback
Start item of the experiment

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExperimentStartItem As Integer

Remarks

See Also

INISettings Class


glExpFlags Field

INISettings..::..glExpFlags Field
INISettings Class See Also Send Feedback
Experiment Flags (Settings/Experiment Screen)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExpFlags As EXPFLAGS

Remarks

See Also

INISettings Class


glExpHUIID Field

INISettings..::..glExpHUIID Field
INISettings Class See Also Send Feedback
Selected Human Interface Device (Settings/Experiment Screen)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExpHUIID As Integer

Remarks

See Also

INISettings Class


glExpType Field

INISettings..::..glExpType Field
INISettings Class See Also Send Feedback
Selected experiment type (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glExpType As Integer

Remarks

See Also

INISettings Class


glImpLeft Field

INISettings..::..glImpLeft Field
INISettings Class See Also Send Feedback
Left implant used (RIB2)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glImpLeft As Integer

Remarks

See Also

INISettings Class


glImpRight Field

INISettings..::..glImpRight Field
INISettings Class See Also Send Feedback
Right implant used (RIB2)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glImpRight As Integer

Remarks

See Also

INISettings Class


glInterStimBreak Field

INISettings..::..glInterStimBreak Field
INISettings Class See Also Send Feedback
Interstimulus break (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glInterStimBreak As Integer

Remarks

See Also

INISettings Class


glOffsetL Field

INISettings..::..glOffsetL Field
INISettings Class See Also Send Feedback
Stimulus Offset Left (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glOffsetL As Integer

Remarks

See Also

INISettings Class


glOffsetR Field

INISettings..::..glOffsetR Field
INISettings Class See Also Send Feedback
Stimulus Offset Right (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glOffsetR As Integer

Remarks

See Also

INISettings Class


glPostStimVisu Field

INISettings..::..glPostStimVisu Field
INISettings Class See Also Send Feedback
Poststimulus Visual Offset (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPostStimVisu As Integer

Remarks

See Also

INISettings Class


glPreStimBreak Field

INISettings..::..glPreStimBreak Field
INISettings Class See Also Send Feedback
Prestimulus break (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPreStimBreak As Integer

Remarks

See Also

INISettings Class


glPreStimVisu Field

INISettings..::..glPreStimVisu Field
INISettings Class See Also Send Feedback
Prestimulus Visual Offset (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glPreStimVisu As Integer

Remarks

See Also

INISettings Class


glRepetition Field

INISettings..::..glRepetition Field
INISettings Class See Also Send Feedback
Repetitions of a block of items (Settings/Procedure)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glRepetition As Integer

Remarks

See Also

INISettings Class


glResolution Field

INISettings..::..glResolution Field
INISettings Class See Also Send Feedback
Resolution (quantization) of the audio output signal (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glResolution As Integer

Remarks

See Also

INISettings Class


glSamplingRate Field

INISettings..::..glSamplingRate Field
INISettings Class See Also Send Feedback
Sampling rate of the audio device (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glSamplingRate As Integer

Remarks

See Also

INISettings Class


glTrackerRepRate Field

INISettings..::..glTrackerRepRate Field
INISettings Class See Also Send Feedback
Repetition Rate of the tracker data (Settings/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared glTrackerRepRate As Integer

Remarks

See Also

INISettings Class


grectExp Field

INISettings..::..grectExp Field
INISettings Class See Also Send Feedback
Position and size of the experimental form (Settings/Experiment Screen)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared grectExp As RECT

Remarks

See Also

INISettings Class


gsFadeIn Field

INISettings..::..gsFadeIn Field
INISettings Class See Also Send Feedback
Fade in every audio signal (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsFadeIn As Double

Remarks

See Also

INISettings Class


gsFadeOut Field

INISettings..::..gsFadeOut Field
INISettings Class See Also Send Feedback
Fade out every audio signal (Settings/Audio)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsFadeOut As Double

Remarks

See Also

INISettings Class


gsLDPulsePeriodL Field

INISettings..::..gsLDPulsePeriodL Field
INISettings Class See Also Send Feedback

[Missing <summary> documentation for "F:ExpSuite.INISettings.gsLDPulsePeriodL"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsLDPulsePeriodL As Double

See Also

INISettings Class


gsLDPulsePeriodR Field

INISettings..::..gsLDPulsePeriodR Field
INISettings Class See Also Send Feedback

[Missing <summary> documentation for "F:ExpSuite.INISettings.gsLDPulsePeriodR"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsLDPulsePeriodR As Double

See Also

INISettings Class


gsngTrackerPosScaling Field

INISettings..::..gsngTrackerPosScaling Field
INISettings Class See Also Send Feedback
Position Scaling (max. range) of the tracker data (Settings/Tracker)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsngTrackerPosScaling As Double

Remarks

See Also

INISettings Class


gsngViWoAvgHead Field

INISettings..::..gsngViWoAvgHead Field
INISettings Class See Also Send Feedback
Averaging window for the data of the head sensor

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsngViWoAvgHead As Double

Remarks

See Also

INISettings Class


gsngViWoAvgPointer Field

INISettings..::..gsngViWoAvgPointer Field
INISettings Class See Also Send Feedback
Averaging window for the data of the pointer sensor

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gsngViWoAvgPointer As Double

Remarks

See Also

INISettings Class


gStimOutput Field

INISettings..::..gStimOutput Field
INISettings Class See Also Send Feedback
How to present the stimuli? (Settings/General)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gStimOutput As GENMODE

Remarks

See Also

INISettings Class


gszDescription Field

INISettings..::..gszDescription Field
INISettings Class See Also Send Feedback
Description of the experiment (Settings/Description)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszDescription As String

Remarks

See Also

INISettings Class


gszDestinationDir Field

INISettings..::..gszDestinationDir Field
INISettings Class See Also Send Feedback
Root Directory (Settings/General/Output directory)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszDestinationDir As String

Remarks

See Also

INISettings Class


gszExpID Field

INISettings..::..gszExpID Field
INISettings Class See Also Send Feedback
The ID of the experiment (Settings/Description)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszExpID As String

Remarks

See Also

INISettings Class


gszFittFileLeft Field

INISettings..::..gszFittFileLeft Field
INISettings Class See Also Send Feedback
File name of the fitting file left (Settings/Fitting Left)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszFittFileLeft As String

Remarks

See Also

INISettings Class


gszFittFileRight Field

INISettings..::..gszFittFileRight Field
INISettings Class See Also Send Feedback
File name of the fitting file right (Settings/Fitting Right)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszFittFileRight As String

Remarks

See Also

INISettings Class


gszItemListTitle Field

INISettings..::..gszItemListTitle Field
INISettings Class See Also Send Feedback
The title (file name without path) of the item list linked to the settings (Main Window/General information)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszItemListTitle As String

Remarks

See Also

INISettings Class


gszSourceDir Field

INISettings..::..gszSourceDir Field
INISettings Class See Also Send Feedback
Source Directory of fitting files (Settings/Fitting Left)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszSourceDir As String

Remarks

See Also

INISettings Class


gszViWoWorld Field

INISettings..::..gszViWoWorld Field
INISettings Class See Also Send Feedback
Name of the selected world.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gszViWoWorld As String

Remarks

See Also

INISettings Class


gtsTrackerMax Field

INISettings..::..gtsTrackerMax Field
INISettings Class See Also Send Feedback
Maximum ranges of a tracker sensor (Settings/Tracker/Click on a position/angle)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gtsTrackerMax As Tracker..::..TrackerSensor()

Remarks

See Also

INISettings Class


gtsTrackerMin Field

INISettings..::..gtsTrackerMin Field
INISettings Class See Also Send Feedback
Minimum ranges of a tracker sensor (Settings/Tracker/Click on a position/angle)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gtsTrackerMin As Tracker..::..TrackerSensor()

Remarks

See Also

INISettings Class


gtsTrackerOffset Field

INISettings..::..gtsTrackerOffset Field
INISettings Class See Also Send Feedback
Offset of a tracker sensor (Settings/Tracker/Set Offset)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gtsTrackerOffset As Tracker..::..TrackerSensor()

Remarks

See Also

INISettings Class


gtsTrackerValues Field

INISettings..::..gtsTrackerValues Field
INISettings Class See Also Send Feedback
Default Values of a tracker sensor (Settings/Tracker/Set Values)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gtsTrackerValues As Tracker..::..TrackerSensor()

Remarks

See Also

INISettings Class


gvarExp Field

INISettings..::..gvarExp Field
INISettings Class See Also Send Feedback
All experimental variables (Settings/Variables)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared gvarExp As FWintern..::..ExpVariable()

Remarks

See Also

INISettings Class


INISettings Methods

[image]

ExpSuite
INISettings Methods
INISettings Class See Also Send Feedback

The INISettings type exposes the following members.

Methods

Name | Description
RemoteParseLine |
SignalDefault | Set the default values for new electrodes in Settings/Signal

See Also

INISettings Class


RemoteParseLine Method

INISettings..::..RemoteParseLine Method
INISettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.INISettings.RemoteParseLine(System.String)"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub RemoteParseLine ( _
    szData As String _
)

Parameters

szData
Type: System..::..String

[Missing <param name="szData"/> documentation for "M:ExpSuite.INISettings.RemoteParseLine(System.String)"]

See Also

INISettings Class


SignalDefault Method

INISettings..::..SignalDefault Method
INISettings Class See Also Send Feedback
Set the default values for new electrodes in Settings/Signal

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub SignalDefault ( _
    lCh As Integer, _
    sAmp As Single, _
    sSPLOffset As Single, _
    sCenterFreq As Single, _
    sBandwidth As Single, _
    sTHR As Single, _
    sMCL As Single, _
    lPhDur As Integer _
)

Parameters

lCh
Type: System..::..Int32
0 for the left electrodes, 1 for the right electrodes.
sAmp
Type: System..::..Single
Default value for the field "Amplitude"
sSPLOffset
Type: System..::..Single
Default value for the field "FS to SPL offset"
sCenterFreq
Type: System..::..Single
Default value for the field "Center freq."
sBandwidth
Type: System..::..Single
Default value for the field "Bandwidth"
sTHR
Type: System..::..Single
Default value for the field "THR"
sMCL
Type: System..::..Single
Default value for the field "MCL"
lPhDur
Type: System..::..Int32
Default value for the field "Phase dur." in µs. This value will be showed in samples and as the true quantized value. This value must be different than zero to set the default values as valid.

Remarks

Separate default values can be set for the left and right electrodes. SignalDefault can be called any time, e.g. after the exp. type changed. Then, if the user click on "new electrode" the default values are applied.

See Also

INISettings Class


MIDI Class

MIDI Class
Members See Also Send Feedback
FrameWork - Handling of MIDI devices.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class MIDI

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..MIDI

See Also

MIDI Members


MIDI Members

[image]

ExpSuite
MIDI Members
MIDI Class Methods See Also Send Feedback

The MIDI type exposes the following members.

Methods

Name | Description
Out | Send a command to MIDI Out.

See Also

MIDI Class


MIDI Methods

[image]

ExpSuite
MIDI Methods
MIDI Class See Also Send Feedback

The MIDI type exposes the following members.

Methods

Name | Description
Out | Send a command to MIDI Out.

See Also

MIDI Class


Out Method

MIDI..::..Out Method
MIDI Class See Also Send Feedback
Send a command to MIDI Out.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Out ( _
    lCh As Integer, _
    lCtrl As Integer, _
    lVal As Integer _
)

Parameters

lCh
Type: System..::..Int32
Channel number.
lCtrl
Type: System..::..Int32
Controller number
lVal
Type: System..::..Int32
Value

Remarks

FrameWork is connected to MIDI via YAMI, the devices are set in Options/Audio. Use MIDI.Out to send a message to your MIDI device. Any response of the device (via MIDI In) will be forwarded to Events.OnOutputResponse

See Also

MIDI Class


OSC Class

OSC Class
Members See Also Send Feedback
FrameWork - Open Sound Control (OSC) support

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class OSC

Remarks

OSC module provides an access to the OSC protocol (written by Matt Wright)
Author: Piotr Majdak piotr@majdak.com

Inheritance Hierarchy

System..::..Object
ExpSuite..::..OSC

See Also

OSC Members


OSC Members

[image]

ExpSuite
OSC Members
OSC Class Methods See Also Send Feedback

The OSC type exposes the following members.

Methods

Name | Description
ParseBuffer | Parse the OSC buffer and retrieve response consisting of COMMAND and ARGUMENTS.
SeparateCommand | Separate a command string in a OSC message to root and the rest.

See Also

OSC Class


OSC Methods

[image]

ExpSuite
OSC Methods
OSC Class See Also Send Feedback

The OSC type exposes the following members.

Methods

Name | Description
ParseBuffer | Parse the OSC buffer and retrieve response consisting of COMMAND and ARGUMENTS.
SeparateCommand | Separate a command string in a OSC message to root and the rest.

See Also

OSC Class


ParseBuffer Method

OSC..::..ParseBuffer Method
OSC Class See Also Send Feedback
Parse the OSC buffer and retrieve response consisting of COMMAND and ARGUMENTS.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function ParseBuffer ( _
    bytData As Byte(), _
    ByRef szCmd As String, _
    ByRef varArgs As Object() _
) As String

Parameters

bytData
Type: array< System..::..Byte >[]()[][]
Buffer
szCmd
Type: System..::..String %
Command
varArgs
Type: array< System..::..Object >[]()[][]%
Array with parameters

Return Value

Error message, empty if no error ocured.

Remarks

Format: COMMAND \0 ,tags \0 arg1 arg2 arg3 ...
Tags:
  • i: integer, will be a Long
  • f: float, will be a single
  • s: string

    • Examples

    Example for 3 integers: COMMAND \0 ,iii \0 I1 I2 I3

    Examples

    Example for 2 integers and string: COMMAND \0 ,iis I1 I2 STRING

    All \0 are 32 filled up to a word (4 bytes)

    See Also

    OSC Class


SeparateCommand Method

OSC..::..SeparateCommand Method
OSC Class See Also Send Feedback
Separate a command string in a OSC message to root and the rest.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub SeparateCommand ( _
    ByRef szCmd As String, _
    ByRef szRoot As String _
)

Parameters

szCmd
Type: System..::..String %
Command. The root szRoot will be separated and the rest of the command will be returned in szCmd.
szRoot
Type: System..::..String %
Root of command szCmd.

Remarks

Examples

Example:
szCmd="ROOT/CMD1/CMD2"

SeparateCommand(szCmd,szRoot)

szCmd="CMD1/CMD2"

szRoot="ROOT"

SeparateCommand(szCmd,szRoot)

szCmd="CMD2"

szRoot="CMD1"

SeparateCommand(szCmd,szRoot)

szCmd="CMD1"

szRoot=""

See Also

OSC Class


Output Class

Output Class
Members See Also Send Feedback
FrameWork - Handling of output devices.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Output

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Output

See Also

Output Members


Output Members

[image]

ExpSuite
Output Members
Output Class Methods See Also Send Feedback

The Output type exposes the following members.

Methods

Name | Description
GetStimulusDuration | Get Stimulus Duration in ms.
LoadStimulationFile | Load Stimulation Files to YAMI or RIBs
PrepareStimulationFile | Prepare Stimulation Files for YAMI or RIBs.
Send | Send an OSC command to YAMI.
Start | Start stimulation with any command.
StartStimulation | Start Stimulation.
WaitForReady | Wait until the output device gets ready.

See Also

Output Class


Output Methods

[image]

ExpSuite
Output Methods
Output Class See Also Send Feedback

The Output type exposes the following members.

Methods

Name | Description
GetStimulusDuration | Get Stimulus Duration in ms.
LoadStimulationFile | Load Stimulation Files to YAMI or RIBs
PrepareStimulationFile | Prepare Stimulation Files for YAMI or RIBs.
Send | Send an OSC command to YAMI.
Start | Start stimulation with any command.
StartStimulation | Start Stimulation.
WaitForReady | Wait until the output device gets ready.

See Also

Output Class


GetStimulusDuration Method

Output..::..GetStimulusDuration Method
Output Class See Also Send Feedback
Get Stimulus Duration in ms.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetStimulusDuration ( _
    szFile As String _
) As Integer

Parameters

szFile
Type: System..::..String
File name.

Return Value

Duration in ms. -1 if an error ocured.

Remarks

See Also

Output Class


LoadStimulationFile Method

Output..::..LoadStimulationFile Method
Output Class See Also Send Feedback
Load Stimulation Files to YAMI or RIBs

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function LoadStimulationFile ( _
    szLeft As String, _
    szRight As String, _
    lChLeft As Integer, _
    lChRight As Integer _
) As String

Parameters

szLeft
Type: System..::..String
File name of the left stimulus. The File name can contain an absolute path beginning with "\\" or a drive. The work directory will be used in other cases. If no extension is given, it will be appended depending on stimulation mode.
szRight
Type: System..::..String
File name of an optional right stimulus. The File name can contain an absolute path beginning with "\\" or a drive. The work directory will be used in other cases. If no extension is given, it will be appended depending on stimulation mode.
lChLeft
Type: System..::..Int32
Audio channel through which the stimulus szLeft will be played. If ommited or set to zero, the left channel for headphones presentation (Options/Audio) will be used.
lChRight
Type: System..::..Int32
Audio channel through which the stimulus szRight will be played. If ommited or set to zero, the right channel for headphones presentation (Options/Audio) will be used.

Return Value

Error message or empty if no error ocured.

Remarks

Using lChLeft and/or lChRight the left/right stimulus will assigned to the given DAC channel. This assignment will be not removed, causing playing via multiple channels on repeated calls using different lChLeft or lChRight. To avoid this problem, reset existing assignments from all channels available using for example code like this:
CopyVB.NET
Dim lX as Long
For lX = 0 To glPlayerChannels - 1
  Output.Send "/DAC/SetStream/" + TStr(lX), "set", "silence"
Next

See Also

Output Class


PrepareStimulationFile Method

Output..::..PrepareStimulationFile Method
Output Class See Also Send Feedback
Prepare Stimulation Files for YAMI or RIBs.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function PrepareStimulationFile ( _
    ByRef szFile As String _
) As String

Parameters

szFile
Type: System..::..String %
File Name.

Return Value

New File Name.

Remarks

Creates full file name including directory and checks for existency returns the new file name in szFile.

See Also

Output Class


Send Method

Output..::..Send Method
Output Class See Also Send Feedback
Send an OSC command to YAMI.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Send ( _
    szAddr As String, _
    ParamArray varArgs As Object() _
) As String

Parameters

szAddr
Type: System..::..String
OSC address in format "/root/tree1/obj2/method3"
varArgs
Type: array< System..::..Object >[]()[][]
Parameters in an array.

Return Value

[Missing <returns> documentation for "M:ExpSuite.Output.Send(System.String,System.Object[])"]

Remarks

See Also

Output Class


Start Method

Output..::..Start Method
Output Class See Also Send Feedback
Start stimulation with any command.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Start ( _
    szCmd As String _
) As String

Parameters

szCmd
Type: System..::..String
OSC Command to YAMI.

Return Value

Nothing will be returned at the moment.

Remarks

See Also

Output Class


StartStimulation Method

Output..::..StartStimulation Method
Output Class See Also Send Feedback
Start Stimulation.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function StartStimulation As String

Return Value

Error message or empty if no error ocured.

Remarks

See Also

Output Class


WaitForReady Method

Output..::..WaitForReady Method
Output Class See Also Send Feedback
Wait until the output device gets ready.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function WaitForReady ( _
    lTimeOut As Integer, _
    lSleepInt As Integer _
) As String

Parameters

lTimeOut
Type: System..::..Int32
Time Out in ms.
lSleepInt
Type: System..::..Int32
If given, the application thread will be halted for the duration of lSleepInt (in ms) to save CPU load.

Return Value

Empty if no error ocured

Remarks

See Also

Output Class


Proc Class

Proc Class
Members See Also Send Feedback
FrameWork - General tools

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Proc

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Proc

See Also

Proc Members


Proc Members

[image]

ExpSuite
Proc Members
Proc Class Methods See Also Send Feedback

The Proc type exposes the following members.

Methods

Name | Description
ArcCos | Calculate the acrcosine of a value
ArcSin | Calculate the acrsine of a value.
Bytes2Float | Convert 4 bytes to a 32-bit float number (Single)
Bytes2Long | Convert 4 Bytes to a 32-integer (Long)
ChangeDir | Change directory.
ClipCursorToWindow | Clip the mouse cursor to an area in a window.
CloseApplication | Close application.
Deg2Rad | Convert from degrees to radians.
GetCommandLine | Get the command line parameters.
GetProcessID |
GetSystemDir | Get the System Directory of Windows.
GetUbound(array<clsFREQUENCY>[]()[][]) | Get the unbound of an array.
GetUbound(array<Double>[]()[][]) | Get the unbound of an array.
GetUbound(array<Int32>[]()[][]) | Get the unbound of an array.
GetUbound(array<String>[]()[][]) | Get the unbound of an array.
GetWindowsDir | Get Windows Directory.
Log10 | Calculate LOG based on 10
Log2 | Calculate LOG based on 2
Long2Bytes | Convert a 32-bit integer (Long) to 4 bytes.
Mean | Calculate the arithmetic average (mean) value.
Rad2Deg | Convert from radians to degrees.
RMSError | Calculate the root mean square error between two series.
SngMod | Calculate the remainder of division.
StartApplication | Start Application by the file name
Std | Calculate the standard deviation of a series.
TextBoxState | Disable/Enable a textbox control.

See Also

Proc Class


Proc Methods

[image]

ExpSuite
Proc Methods
Proc Class See Also Send Feedback

The Proc type exposes the following members.

Methods

Name | Description
ArcCos | Calculate the acrcosine of a value
ArcSin | Calculate the acrsine of a value.
Bytes2Float | Convert 4 bytes to a 32-bit float number (Single)
Bytes2Long | Convert 4 Bytes to a 32-integer (Long)
ChangeDir | Change directory.
ClipCursorToWindow | Clip the mouse cursor to an area in a window.
CloseApplication | Close application.
Deg2Rad | Convert from degrees to radians.
GetCommandLine | Get the command line parameters.
GetProcessID |
GetSystemDir | Get the System Directory of Windows.
GetUbound(array<clsFREQUENCY>[]()[][]) | Get the unbound of an array.
GetUbound(array<Double>[]()[][]) | Get the unbound of an array.
GetUbound(array<Int32>[]()[][]) | Get the unbound of an array.
GetUbound(array<String>[]()[][]) | Get the unbound of an array.
GetWindowsDir | Get Windows Directory.
Log10 | Calculate LOG based on 10
Log2 | Calculate LOG based on 2
Long2Bytes | Convert a 32-bit integer (Long) to 4 bytes.
Mean | Calculate the arithmetic average (mean) value.
Rad2Deg | Convert from radians to degrees.
RMSError | Calculate the root mean square error between two series.
SngMod | Calculate the remainder of division.
StartApplication | Start Application by the file name
Std | Calculate the standard deviation of a series.
TextBoxState | Disable/Enable a textbox control.

See Also

Proc Class


ArcCos Method

Proc..::..ArcCos Method
Proc Class See Also Send Feedback
Calculate the acrcosine of a value

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function ArcCos ( _
    sValue As Double _
) As Double

Parameters

sValue
Type: System..::..Double
Value

Return Value

arccosine of value sValue

Remarks

See Also

Proc Class


ArcSin Method

Proc..::..ArcSin Method
Proc Class See Also Send Feedback
Calculate the acrsine of a value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function ArcSin ( _
    sValue As Double _
) As Double

Parameters

sValue
Type: System..::..Double
Value

Return Value

arcsine of value sValue

Remarks

See Also

Proc Class


Bytes2Float Method

Proc..::..Bytes2Float Method
Proc Class See Also Send Feedback
Convert 4 bytes to a 32-bit float number (Single)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Bytes2Float ( _
    b0 As Byte, _
    b1 As Byte, _
    b2 As Byte, _
    b3 As Byte _
) As Single

Parameters

b0
Type: System..::..Byte
Byte #0
b1
Type: System..::..Byte
Byte #1
b2
Type: System..::..Byte
Byte #2
b3
Type: System..::..Byte
Byte #3

Return Value

Float number. The Float number must have been saved in IEEE format.

Remarks

See Also

Proc Class


Bytes2Long Method

Proc..::..Bytes2Long Method
Proc Class See Also Send Feedback
Convert 4 Bytes to a 32-integer (Long)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Bytes2Long ( _
    b0 As Byte, _
    b1 As Byte, _
    b2 As Byte, _
    b3 As Byte _
) As Integer

Parameters

b0
Type: System..::..Byte
Byte #0
b1
Type: System..::..Byte
Byte #1
b2
Type: System..::..Byte
Byte #2
b3
Type: System..::..Byte
Byte #3

Return Value

Long number.

Remarks

See Also

Proc Class


ChangeDir Method

Proc..::..ChangeDir Method
Proc Class See Also Send Feedback
Change directory.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function ChangeDir ( _
    szDir As String _
) As Boolean

Parameters

szDir
Type: System..::..String
Path name

Return Value

  • FALSE: Directory changed
  • TRUE: Couldn't change, as error ocured.

    • Remarks

    Difference to ChDir: Drive will be changed if it's a local drive

    See Also

    Proc Class


ClipCursorToWindow Method

Proc..::..ClipCursorToWindow Method
Proc Class See Also Send Feedback
Clip the mouse cursor to an area in a window.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub ClipCursorToWindow ( _
    hWnd As Integer, _
    lLeft As Integer, _
    lTop As Integer, _
    lWidth As Integer, _
    lHeight As Integer _
)

Parameters

hWnd
Type: System..::..Int32
Handle of the window. Set hWnd to 0 to release the clipping area.
lLeft
Type: System..::..Int32
Left corner [pixels]
lTop
Type: System..::..Int32
Top corner [pixels]
lWidth
Type: System..::..Int32
Width of the area.
lHeight
Type: System..::..Int32
Height of the area.

Remarks

See Also

Proc Class


CloseApplication Method

Proc..::..CloseApplication Method
Proc Class See Also Send Feedback
Close application.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CloseApplication ( _
    sWindowName As String _
) As Integer

Parameters

sWindowName
Type: System..::..String
Name of the Window without extension.

Return Value

  • -1: error ocured
  • 0: process not found
  • 1: window found and closed
  • 2: process has been killed

    • Remarks

    See Also

    Proc Class


Deg2Rad Method

Proc..::..Deg2Rad Method
Proc Class See Also Send Feedback
Convert from degrees to radians.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Deg2Rad ( _
    sAngle As Double _
) As Double

Parameters

sAngle
Type: System..::..Double
Angle in degress.

Return Value

Angle in radians.

Remarks

See Also

Proc Class


GetCommandLine Method

Proc..::..GetCommandLine Method
Proc Class See Also Send Feedback
Get the command line parameters.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetCommandLine ( _
    MaxArgs As Integer _
) As String()

Parameters

MaxArgs
Type: System..::..Int32
Maximum number of arguments. If not given, the number will be 11.

Return Value

Array containing parsed parameters. Array is empty if no parameter could be found in the command line.

Remarks

Parameters can be separated by blank or tab, if a parameter is quoted it may contain blanks or tabs. Parameters must not contain quotas.

See Also

Proc Class


GetProcessID Method

Proc..::..GetProcessID Method
Proc Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.Proc.GetProcessID(System.String)"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetProcessID ( _
    szName As String _
) As Integer

Parameters

szName
Type: System..::..String

[Missing <param name="szName"/> documentation for "M:ExpSuite.Proc.GetProcessID(System.String)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.Proc.GetProcessID(System.String)"]

See Also

Proc Class


GetSystemDir Method

Proc..::..GetSystemDir Method
Proc Class See Also Send Feedback
Get the System Directory of Windows.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetSystemDir As String

Return Value

Path to the System Directory of Windows.

Remarks

See Also

Proc Class


GetUbound Method

[image]

ExpSuite
Proc..::..GetUbound Method
Proc Class See Also Send Feedback

Overload List

Name | Description
GetUbound(array<clsFREQUENCY>[]()[][]) | Get the unbound of an array.
GetUbound(array<Double>[]()[][]) | Get the unbound of an array.
GetUbound(array<Int32>[]()[][]) | Get the unbound of an array.
GetUbound(array<String>[]()[][]) | Get the unbound of an array.

See Also

Proc Class
Proc Members


GetUbound Method ([])

Proc..::..GetUbound Method (array<>[]()[][])
Proc Class See Also Send Feedback
Get the unbound of an array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetUbound ( _
    lArray As clsFREQUENCY() _
) As Integer

Parameters

lArray
Type: array<clsFREQUENCY>[]()[][]
Array

Return Value

Number of elements in the array, -1 if empty

Remarks

Difference to Ubound() of VB: Works for empty arrays, resulting in -1.

See Also

Proc Class
GetUbound Overload


GetUbound Method (Double[])

Proc..::..GetUbound Method (array<Double>[]()[][])
Proc Class See Also Send Feedback
Get the unbound of an array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetUbound ( _
    lArray As Double() _
) As Integer

Parameters

lArray
Type: array< System..::..Double >[]()[][]
Array

Return Value

Number of elements in the array, -1 if empty

Remarks

Difference to Ubound() of VB: Works for empty arrays, resulting in -1.

See Also

Proc Class
GetUbound Overload


GetUbound Method (Int32[])

Proc..::..GetUbound Method (array<Int32>[]()[][])
Proc Class See Also Send Feedback
Get the unbound of an array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetUbound ( _
    lArray As Integer() _
) As Integer

Parameters

lArray
Type: array< System..::..Int32 >[]()[][]
Array

Return Value

Number of elements in the array, -1 if empty

Remarks

Difference to Ubound() of VB: Works for empty arrays, resulting in -1.

See Also

Proc Class
GetUbound Overload


GetUbound Method (String[])

Proc..::..GetUbound Method (array<String>[]()[][])
Proc Class See Also Send Feedback
Get the unbound of an array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetUbound ( _
    lArray As String() _
) As Integer

Parameters

lArray
Type: array< System..::..String >[]()[][]
Array

Return Value

Number of elements in the array, -1 if empty

Remarks

Difference to Ubound() of VB: Works for empty arrays, resulting in -1.

See Also

Proc Class
GetUbound Overload


GetWindowsDir Method

Proc..::..GetWindowsDir Method
Proc Class See Also Send Feedback
Get Windows Directory.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetWindowsDir As String

Return Value

Path to the Windows Directory

Remarks

See Also

Proc Class


Log10 Method

Proc..::..Log10 Method
Proc Class See Also Send Feedback
Calculate LOG based on 10

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Log10 ( _
    sX As Double _
) As Double

Parameters

sX
Type: System..::..Double
Number

Return Value

Log10(sX)

Remarks

See Also

Proc Class


Log2 Method

Proc..::..Log2 Method
Proc Class See Also Send Feedback
Calculate LOG based on 2

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Log2 ( _
    sX As Double _
) As Double

Parameters

sX
Type: System..::..Double
Number

Return Value

Log2(sX)

Remarks

See Also

Proc Class


Long2Bytes Method

Proc..::..Long2Bytes Method
Proc Class See Also Send Feedback
Convert a 32-bit integer (Long) to 4 bytes.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Long2Bytes ( _
    l0 As Integer, _
    ByRef b0 As Byte, _
    ByRef b1 As Byte, _
    ByRef b2 As Byte, _
    ByRef b3 As Byte _
)

Parameters

l0
Type: System..::..Int32
Long number.
b0
Type: System..::..Byte %
Byte #0 as result.
b1
Type: System..::..Byte %
Byte #1 as result.
b2
Type: System..::..Byte %
Byte #2 as result.
b3
Type: System..::..Byte %
Byte #3 as result.

Remarks

See Also

Proc Class


Mean Method

Proc..::..Mean Method
Proc Class See Also Send Feedback
Calculate the arithmetic average (mean) value.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Mean ( _
    sData As Double() _
) As Double

Parameters

sData
Type: array< System..::..Double >[]()[][]
Array with data.

Return Value

Mean (=arithmetic average) value of sData()

Remarks

See Also

Proc Class


Rad2Deg Method

Proc..::..Rad2Deg Method
Proc Class See Also Send Feedback
Convert from radians to degrees.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Rad2Deg ( _
    sAngle As Double _
) As Double

Parameters

sAngle
Type: System..::..Double
Angle in radians.

Return Value

Angle in degress.

Remarks

See Also

Proc Class


RMSError Method

Proc..::..RMSError Method
Proc Class See Also Send Feedback
Calculate the root mean square error between two series.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function RMSError ( _
    sResponse As Double(), _
    sTarget As Double() _
) As Double

Parameters

sResponse
Type: array< System..::..Double >[]()[][]
Series 1
sTarget
Type: array< System..::..Double >[]()[][]
Series 2

Return Value

RMS error

Remarks

See Also

Proc Class


SngMod Method

Proc..::..SngMod Method
Proc Class See Also Send Feedback
Calculate the remainder of division.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function SngMod ( _
    sA As Single, _
    sB As Single _
) As Single

Parameters

sA
Type: System..::..Single
Number to divide.
sB
Type: System..::..Single
Divisor

Return Value

Remainder

Remarks

Obsolete function, use MOD instead

See Also

Proc Class


StartApplication Method

Proc..::..StartApplication Method
Proc Class See Also Send Feedback
Start Application by the file name

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function StartApplication ( _
    szName As String _
) As Integer

Parameters

szName
Type: System..::..String
File Name of the Application.

Return Value

???

Remarks

See Also

Proc Class


Std Method

Proc..::..Std Method
Proc Class See Also Send Feedback
Calculate the standard deviation of a series.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Std ( _
    sData As Double(), _
    sMean As Double _
) As Double

Parameters

sData
Type: array< System..::..Double >[]()[][]
Array with data.
sMean
Type: System..::..Double
Mean value of the series, must be calculated before.

Return Value

Standard deviation of the series sData()

Remarks

See Also

Proc Class


TextBoxState Method

Proc..::..TextBoxState Method
Proc Class See Also Send Feedback
Disable/Enable a textbox control.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub TextBoxState ( _
    txtControl As TextBox, _
    blnState As Boolean _
)

Parameters

txtControl
Type: System.Windows.Forms..::..TextBox
txtControl Name of the control
blnState
Type: System..::..Boolean
TRUE: Enabled
FALSE: Disabled.

Remarks

The Textbox control will be locked and disabled and the background color set to windows background.

See Also

Proc Class


Result Class

Result Class
Members See Also Send Feedback
Application Module. REQUIRED. Events on Execution of methods.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Result

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Result

See Also

Result Members


Result Members

[image]

ExpSuite
Result Members
Result Class Methods See Also Send Feedback

The Result type exposes the following members.

Methods

Name | Description
Execute | Execute a method from the "Execute" section in the main window. Only required function in module.

See Also

Result Class


Result Methods

[image]

ExpSuite
Result Methods
Result Class See Also Send Feedback

The Result type exposes the following members.

Methods

Name | Description
Execute | Execute a method from the "Execute" section in the main window. Only required function in module.

See Also

Result Class


Execute Method

Result..::..Execute Method
Result Class See Also Send Feedback
Execute a method from the "Execute" section in the main window. Only required function in module.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Execute ( _
    ByRef lIndex As Integer _
)

Parameters

lIndex
Type: System..::..Int32 %
Chosen method to be executed

Remarks

The drop down list above the "Execute" button contains methods set by frmMain.SetResultList. This function will called on a click on the "Execute" button with lIndex, which is the index of the chosen method.

See Also

Result Class


STIM Class

STIM Class
Members See Also Send Feedback
Stimulus creation, connection to MATLAB and logging of data.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class STIM

Remarks

Important Properties of STIM

  • GenerationMode*: 0: genElectricalRIB; 1: genAcoustical; 2: genElectricalNIC; 3: genElectricalRIB2
  • LoggingMode*: 0: don '''t log to disk (not recommended); 15: log everything to disk
  • DestinationDir*: root directory for disk access, work dir will be created here
  • WorkDir: working directory, all files are created here
  • ID*: name of experiment, work directory will begin with ID
  • Description: description of experiment, may contain blanks and special characters. Description will be encoded (UUE) and logged
  • FirstName: first name of subject
  • LastName: last name of subject
  • Caption: caption of the STIM-list in the parent application
  • MATLABServer*: name of the MATLAB-Server. Leave empty for local server. A nonlocal server can'''t use graphical functions as plot and figure.
  • ShowStimulusFlags: Flags which are passed to ShowStimulus.
  • SourceDir*: Fitting files are copied from this directory
  • UseMatlab*: Set false if you don'''t want to connect to the Matlab server. All Matlab functionality will be disabled.
  • CreateWorkDir*: set false if you don'''t want to create a new work directory. Caution: a new log file with a time stamp will be created, but the stimlog.csv will be overwritten!

    • *: required before Init()

    Created directory structure

    Root

    |

    - source directory [SourceDir]

    |

    - fitting files

    ...

    - destination directory [DestinationDir]

    |

    - working directory [work] (ID_YYYYMMDD_HHmmss)

    |

    - current fitting file left [fittL] (.fitt)

    - current fitting file right [fittR] (.fitt)

    - generated stimulation files (stimXXXX.EXT)

    - generated parameter file (stimXXXX.csv)

    - generated logfile [logfile] (ID_YYYYMMDD_HHmmss.csv)

    Auto naming of files:
  • YYYYMMDD: Year, month, day
  • HHmmss: hour, minute, second
  • XXXX: serial number, 4 digits
  • EXT: ".stim" in electricalRIB and ".wav" in acoustical mode

    • Inheritance Hierarchy

    System..::..Object
    ExpSuite..::..STIM

    See Also

    STIM Members


STIM Members

[image]

ExpSuite
STIM Members
STIM Class Methods Properties See Also Send Feedback

The STIM type exposes the following members.

Methods

Name | Description
AppendExtension | Append correct extension to the stimulation file name.
AssembleStimulus | Assemble a stimulation file.
CheckStimulationFile | Check for stimulation file.
CloseStimulus | Close a stimulus.
Finish | Finish work with STIM.
Init | Initialization of STIM.
Log(array<String>[]()[][]) | Log items to the log file.
Log(String, array<String>[]()[][]) | Log items to the log file.
Matlab | Execute a MATLAB command.
MatlabGetMatrixSize | Get the size of a matrix.
MatlabGetRealMatrix2 | Get real values from a 2D-Matrix from Matlab.
MatlabStimulus(String, array<Object>[]()[][]) | Create/Change stimulus using MATLAB functions.
MatlabStimulus(String, array<clsSTIMULUS>[]()[][], array<Object>[]()[][]) | Create/Change stimulus using MATLAB functions.
NewStimulus | Start a new stimulus. The stimulus array/vector will be cleared.
RegisterChannel | Registers a channel (left, right or multichannel).
ShowStimulus | Show the stimulation vector.

Properties

Name | Description
CreateWorkDir | Create Work directory on Init() (FrameWork: on connect)
DestinationDir | Root Directory (Settings/General/Output directory)
ID | Get the experiment ID.
MATLABServer | Set the computer name providing the Matlab object.
SourceDir | Source Directory of fitting files (Settings/Fitting Left)
UseMatlab | Use Matlab on Init() (FrameWork: on connect)?
WorkDir | Get the Work Directory.

See Also

STIM Class


STIM Methods

[image]

ExpSuite
STIM Methods
STIM Class See Also Send Feedback

The STIM type exposes the following members.

Methods

Name | Description
AppendExtension | Append correct extension to the stimulation file name.
AssembleStimulus | Assemble a stimulation file.
CheckStimulationFile | Check for stimulation file.
CloseStimulus | Close a stimulus.
Finish | Finish work with STIM.
Init | Initialization of STIM.
Log(array<String>[]()[][]) | Log items to the log file.
Log(String, array<String>[]()[][]) | Log items to the log file.
Matlab | Execute a MATLAB command.
MatlabGetMatrixSize | Get the size of a matrix.
MatlabGetRealMatrix2 | Get real values from a 2D-Matrix from Matlab.
MatlabStimulus(String, array<Object>[]()[][]) | Create/Change stimulus using MATLAB functions.
MatlabStimulus(String, array<clsSTIMULUS>[]()[][], array<Object>[]()[][]) | Create/Change stimulus using MATLAB functions.
NewStimulus | Start a new stimulus. The stimulus array/vector will be cleared.
RegisterChannel | Registers a channel (left, right or multichannel).
ShowStimulus | Show the stimulation vector.

See Also

STIM Class


AppendExtension Method

STIM..::..AppendExtension Method
STIM Class See Also Send Feedback
Append correct extension to the stimulation file name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function AppendExtension ( _
    szFileName As String _
) As String

Parameters

szFileName
Type: System..::..String
Original File Name without extension.

Return Value

File name with extension.

Remarks

Appends the correct extension to the stimulation file name:
  • .wav in acoustical mode
  • .stim in electrical RIB mode

    • See Also

    STIM Class


AssembleStimulus Method

STIM..::..AssembleStimulus Method
STIM Class See Also Send Feedback
Assemble a stimulation file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function AssembleStimulus ( _
    blnShow As Boolean _
) As String

Parameters

blnShow
Type: System..::..Boolean
Set to true if you want to show the stimulus before assembling. FRAMEWORK: This flag can be received from mblnShowStimulus

Return Value

If no error occured the return value is "". In any error case the error message will be set to the return string.

Remarks

In electrical RIB mode the MATLAB function assemble() is used.
In acoustical mode the MATLAB vector will be written as a WAV file.

See Also

STIM Class


CheckStimulationFile Method

STIM..::..CheckStimulationFile Method
STIM Class See Also Send Feedback
Check for stimulation file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CheckStimulationFile ( _
    ByRef szFile As String _
) As Boolean

Parameters

szFile
Type: System..::..String %
File name of the stimulation file, without any path. Extension will be added if not found.

Return Value

TRUE if the stimulation file can be found.

Remarks

See Also

STIM Class


CloseStimulus Method

STIM..::..CloseStimulus Method
STIM Class See Also Send Feedback
Close a stimulus.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CloseStimulus As String

Return Value

Zero-length string if no errors occured.

Remarks

After creating stimulus with AssembleStimulus call this function before creating a new one.

See Also

STIM Class


Finish Method

STIM..::..Finish Method
STIM Class See Also Send Feedback
Finish work with STIM.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Finish As String

Return Value

If no error occured the return value is "".

Remarks

Using STIM after Finish() requires Init().
this function will be called on disconnect by Framework. Don't call it again!

See Also

STIM Class


Init Method

STIM..::..Init Method
STIM Class See Also Send Feedback
Initialization of STIM.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Init ( _
    lSamplingRate As Integer, _
    lResolution As Integer _
) As String

Parameters

lSamplingRate
Type: System..::..Int32
Sampling Rate of the audio signal.
lResolution
Type: System..::..Int32
Resolution of the audio signal.

Return Value

Zero-length if no error occured.

Remarks

Init is called on connect from framework. Don't call it again. Activities:
  • Create a MATLAB object
  • create the directory structure
  • logging of some parameters, depending on the LoggingMode property.
    • Set before calling:
  • SourceDir to the directory of fitting files
  • DestinationDir: to the directory where STIM will write
  • ID: to the ID of your experiment
  • GenerationMode: to the mode you want to create all stimuli
  • LoggingMode: to the level of logging (only logEverything support now)
  • Description: to the description of your experiment, this string will be logged
  • UseMatlab: If UseMATLAB property is TRUE, MATLAB object will be created.
  • CreateWorkDir: If TRUE, working directory will be creating according to the directory structure.
    • Usage:
  • Call it just once. If you want to call it repetitive you must execute Finish() inbetween, STIM will stuck otherwise.
  • Init allows two optional parameters: Sampling rate and Resolution. If given, stimPar is created in Matlab immediatly after the start of Matlab

    • See Also

    STIM Class


Log Method

[image]

ExpSuite
STIM..::..Log Method
STIM Class See Also Send Feedback

Overload List

Name | Description
Log(array<String>[]()[][]) | Log items to the log file.
Log(String, array<String>[]()[][]) | Log items to the log file.

See Also

STIM Class
STIM Members


Log Method (String[])

STIM..::..Log Method (array<String>[]()[][])
STIM Class See Also Send Feedback
Log items to the log file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Log ( _
    szItems As String() _
)

Parameters

szItems
Type: array< System..::..String >[]()[][]
Each string will be quoted (if necessary) and written to the log file.

Remarks

See Also

STIM Class
Log Overload


Log Method (String, String[])

STIM..::..Log Method (String, array<String>[]()[][])
STIM Class See Also Send Feedback
Log items to the log file.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Log ( _
    szY As String, _
    ParamArray szItems As String() _
)

Parameters

szY
Type: System..::..String

[Missing <param name="szY"/> documentation for "M:ExpSuite.STIM.Log(System.String,System.String[])"]

szItems
Type: array< System..::..String >[]()[][]
Each string will be quoted (if necessary) and written to the log file.

Remarks

See Also

STIM Class
Log Overload


Matlab Method

STIM..::..Matlab Method
STIM Class See Also Send Feedback
Execute a MATLAB command.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Matlab ( _
    szCmd As String _
) As String

Parameters

szCmd
Type: System..::..String
Command sent to MATLAB.

Return Value

Response string from MATLAB. Contains "" if no errors occured.

Remarks

See Also

STIM Class


MatlabGetMatrixSize Method

STIM..::..MatlabGetMatrixSize Method
STIM Class See Also Send Feedback
Get the size of a matrix.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function MatlabGetMatrixSize ( _
    szName As String, _
    ByRef lRow As Integer, _
    ByRef lCol As Integer _
) As String

Parameters

szName
Type: System..::..String
Name of the Vector/Matrix or, general, Variable.
lRow
Type: System..::..Int32 %
Number of Rows as result.
lCol
Type: System..::..Int32 %
Number of Columns as result.

Return Value

Error message or empty if no error ocured.

Remarks

This function retrieves the size of a variable in Matlab.

See Also

STIM Class


MatlabGetRealMatrix2 Method

STIM..::..MatlabGetRealMatrix2 Method
STIM Class See Also Send Feedback
Get real values from a 2D-Matrix from Matlab.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function MatlabGetRealMatrix2 ( _
    szName As String, _
    ByRef dblReal As Double(,) _
) As String

Parameters

szName
Type: System..::..String
Matrix/Variable name.
dblReal
Type: array< System..::..Double ,2>[,](,)[,][,]%
Array to which the matrix will be copied. The proper size must be set before calling MatlabGetRealMatrix2 (see MatlabGetMatrixSize)

Return Value

Zero-length if no error ocured. Error message otherwise.

Remarks

This function gets the 2D-matrix szName from Matlab, disgards the imaginery values and copies the real values to dblReal().

See Also

STIM Class


MatlabStimulus Method

[image]

ExpSuite
STIM..::..MatlabStimulus Method
STIM Class See Also Send Feedback

Overload List

Name | Description
MatlabStimulus(String, array<Object>[]()[][]) | Create/Change stimulus using MATLAB functions.
MatlabStimulus(String, array<clsSTIMULUS>[]()[][], array<Object>[]()[][]) | Create/Change stimulus using MATLAB functions.

See Also

STIM Class
STIM Members


MatlabStimulus Method (String, Object[])

STIM..::..MatlabStimulus Method (String, array<Object>[]()[][])
STIM Class See Also Send Feedback
Create/Change stimulus using MATLAB functions.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function MatlabStimulus ( _
    szFunc As String, _
    ParamArray varPar As Object() _
) As String

Parameters

szFunc
Type: System..::..String
Name of the MATLAB function you want to call (case sensitive!)
varPar
Type: array< System..::..Object >[]()[][]
Comma-delimited list of variant values with parameters of called MATLAB function. Numeric, string or empty data types will be accepted. Strings without valid MATLAB quoting ('...') will be quoted. Any value containing the data type 'Empty' will be converted to an empty vector ([]).

Return Value

Zero-length if MATLAB function was executed without any errors. Contains the error message if any error occured.

Remarks

On MatlabStimulus the function szFunc will be executed in MATLAB.
Passed parameters are:
  • stimVec: Stimulus vector. Empty vector on the first call after NewStimulus, result of previous calls. Appending of stimulus parts can achieved calling successively .MatlabStimulus.
  • stimPar: Stimulation parameters. Contains the structure STIMULUSPARAMETER, which is valid after .NewStimulus
  • all parameters in varPar()
    • The MATLAB function must have the following header: [newstimVec, newstimPar] = szFunc(stimVec,stimPar,varPar...)

    See Also

    STIM Class
    MatlabStimulus Overload


MatlabStimulus Method (String, [], Object[])

STIM..::..MatlabStimulus Method (String, array<>[]()[][], array<Object>[]()[][])
STIM Class See Also Send Feedback
Create/Change stimulus using MATLAB functions.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function MatlabStimulus ( _
    szFunc As String, _
    clsX As clsSTIMULUS(), _
    ParamArray varPar As Object() _
) As String

Parameters

szFunc
Type: System..::..String
Name of the MATLAB function you want to call (case sensitive!)
clsX
Type: array<clsSTIMULUS>[]()[][]

[Missing <param name="clsX"/> documentation for "M:ExpSuite.STIM.MatlabStimulus(System.String,ExpSuite.clsSTIMULUS[],System.Object[])"]

varPar
Type: array< System..::..Object >[]()[][]
Comma-delimited list of variant values with parameters of called MATLAB function. Numeric, string or empty data types will be accepted. Strings without valid MATLAB quoting ('...') will be quoted. Any value containing the data type 'Empty' will be converted to an empty vector ([]).

Return Value

Zero-length if MATLAB function was executed without any errors. Contains the error message if any error occured.

Remarks

On MatlabStimulus the function szFunc will be executed in MATLAB.
Passed parameters are:
  • stimVec: Stimulus vector. Empty vector on the first call after NewStimulus, result of previous calls. Appending of stimulus parts can achieved calling successively .MatlabStimulus.
  • stimPar: Stimulation parameters. Contains the structure STIMULUSPARAMETER, which is valid after .NewStimulus
  • all parameters in varPar()
    • The MATLAB function must have the following header: [newstimVec, newstimPar] = szFunc(stimVec,stimPar,varPar...)

    See Also

    STIM Class
    MatlabStimulus Overload


NewStimulus Method

STIM..::..NewStimulus Method
STIM Class See Also Send Feedback
Start a new stimulus. The stimulus array/vector will be cleared.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function NewStimulus ( _
    ByRef stNew As STIMULUSPARAMETER _
) As String

Parameters

stNew
Type: STIMULUSPARAMETER%
Use the variable set by RegisterChannel(). Clear .szStimFile to get an automatic generated file name in format stimXXXX_YY.ext (XXXX:stimulus index, YY:channel, ext: valid extension)

Return Value

Zero-length string if no errors occured.

Remarks

See Also

STIM Class


RegisterChannel Method

STIM..::..RegisterChannel Method
STIM Class See Also Send Feedback
Registers a channel (left, right or multichannel).

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function RegisterChannel ( _
    ByRef st As STIMULUSPARAMETER _
) As String

Parameters

st
Type: STIMULUSPARAMETER%
Stimulus parameters.

Return Value

Empty for no errors, error string otherwise. Additional changes in st:
  • .sTimeBase calculated using .lSamplingRate (only in acoustical mode)
  • .sTimeBase, .szFirstName, .szLastName read from the fitting file (only in electricalRIB mode)
  • .lSamplingRate calculated using .sTimeBase (only in electricalRIB mode)
  • .szImpType and .iImpType determined from fitting file (only in electricalRIB mode)

    • Remarks

    Register a channel (=ear, side: left=0, right=1, multichannel. Not acoustical (frequency) channel!).
    Usage:
  • Call it after Init() for each channel you have.

    • RegisterChannel is called by framework on connect. Don'''t call it again.

    st.lChNr must be valid on calling RegisterChannel:
  • In acoustical mode, set st.lSamplingRate [Hz] and st.lResolution [bit]. Then, the .sTimeBase [us] will be calculated from .lSamplingRate.
  • In electricalRIB mode, set .szFittFile to the name of a valid fitting file. From this file some fields of st will be set (e.g. first and last name and time base).

    • The field .lResolution will be ignored in this mode.

    Set before calling RegisterChannel:
  • .lChNr to a valid audio channel.
  • .lSamplingRate (only in acoustical mode)
  • all items of freqPar()
  • .szFittFile to a valid fitting file (only in electricalRIB mode)
  • default values for electrode, pulsenr, pulseperiod, offset

    • Activities:

  • Logging
  • Determining the number of audio channels for auto naming mechanism
  • Copy fitting file to the working directory
  • Update of STIMULUSPARAMETER

    • See Also

    STIM Class


ShowStimulus Method

STIM..::..ShowStimulus Method
STIM Class See Also Send Feedback
Show the stimulation vector.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function ShowStimulus As String

Return Value

Zero-length if no errors occured.

Remarks

The vector stimVec will be plotted (acoustical) or shown (electrical). ShowStimulusFlags defines the options how the stimulus will be shown.

See Also

STIM Class


STIM Properties

[image]

ExpSuite
STIM Properties
STIM Class See Also Send Feedback

The STIM type exposes the following members.

Properties

Name | Description
CreateWorkDir | Create Work directory on Init() (FrameWork: on connect)
DestinationDir | Root Directory (Settings/General/Output directory)
ID | Get the experiment ID.
MATLABServer | Set the computer name providing the Matlab object.
SourceDir | Source Directory of fitting files (Settings/Fitting Left)
UseMatlab | Use Matlab on Init() (FrameWork: on connect)?
WorkDir | Get the Work Directory.

See Also

STIM Class


CreateWorkDir Property

STIM..::..CreateWorkDir Property
STIM Class See Also Send Feedback
Create Work directory on Init() (FrameWork: on connect)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Property CreateWorkDir As Boolean
    Get
    Set

Field Value

Return Value

Remarks

See Also

STIM Class


DestinationDir Property

STIM..::..DestinationDir Property
STIM Class See Also Send Feedback
Root Directory (Settings/General/Output directory)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Property DestinationDir As String
    Get
    Set

Field Value

Return Value

Root Directory (Settings/General/Output directory)

Remarks

See Also

STIM Class


ID Property

STIM..::..ID Property
STIM Class See Also Send Feedback
Get the experiment ID.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Property ID As String
    Get
    Set

Field Value

Return Value

Experiment ID (Settings/Description)

Remarks

See Also

STIM Class


MATLABServer Property

STIM..::..MATLABServer Property
STIM Class See Also Send Feedback
Set the computer name providing the Matlab object.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Property MATLABServer As String
    Get
    Set

Field Value

Return Value

Remarks

See Also

STIM Class


SourceDir Property

STIM..::..SourceDir Property
STIM Class See Also Send Feedback
Source Directory of fitting files (Settings/Fitting Left)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Property SourceDir As String
    Get
    Set

Field Value

Return Value

Source Directory of fitting files (Settings/Fitting Left)

Remarks

See Also

STIM Class


UseMatlab Property

STIM..::..UseMatlab Property
STIM Class See Also Send Feedback
Use Matlab on Init() (FrameWork: on connect)?

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Property UseMatlab As Boolean
    Get
    Set

Field Value

Return Value

Remarks

See Also

STIM Class


WorkDir Property

STIM..::..WorkDir Property
STIM Class See Also Send Feedback
Get the Work Directory.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared ReadOnly Property WorkDir As String
    Get

Field Value

Return Value

Work Directory.

Remarks

WorkDirectory is the active directory, where all files will be saved/read. In electrical mode, fitting files will be copied to this directory.
WorkDirectory is valid after Init(), or Connect in FrameWork.

If the property CreateWorkDir is FALSE, WorkDir is the DestinationDir.
Otherwise, a new directory will be created in DestinationDir with the syntax: ID_YYYYMMDD_HHmmss, where:
  • ID: property ID
  • YYYYMMDD: Year , Month, Day
  • HHmmss: hour, minute, second

    • See Also

    STIM Class


Tracker Class

Tracker Class
Members See Also Send Feedback
FrameWork - Tracker support.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Tracker

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Tracker

See Also

Tracker Members


Tracker Members

[image]

ExpSuite
Tracker Members
Tracker Class Methods See Also Send Feedback

The Tracker type exposes the following members.

Methods

Name | Description
CheckTrackedInRange | Check if the sensor is within range now
CheckTrackedMaxValue |
CheckTrackedMinValue | Check if a sensor exceeded the minimum limit.
DontTrackMinMaxValues | Stops tracking the min/max values by tracker.
GetCurrentValues | Get Current Values of a sensor from tracker.
TrackMinMaxValues | Track Min or/and Max values of a sensor.

See Also

Tracker Class


Tracker Methods

[image]

ExpSuite
Tracker Methods
Tracker Class See Also Send Feedback

The Tracker type exposes the following members.

Methods

Name | Description
CheckTrackedInRange | Check if the sensor is within range now
CheckTrackedMaxValue |
CheckTrackedMinValue | Check if a sensor exceeded the minimum limit.
DontTrackMinMaxValues | Stops tracking the min/max values by tracker.
GetCurrentValues | Get Current Values of a sensor from tracker.
TrackMinMaxValues | Track Min or/and Max values of a sensor.

See Also

Tracker Class


CheckTrackedInRange Method

Tracker..::..CheckTrackedInRange Method
Tracker Class See Also Send Feedback
Check if the sensor is within range now

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CheckTrackedInRange ( _
    lS As Integer, _
    lStatus As Integer _
) As Integer

Parameters

lS
Type: System..::..Int32
Sensor index (0...first sensor)
lStatus
Type: System..::..Int32

[Missing <param name="lStatus"/> documentation for "M:ExpSuite.Tracker.CheckTrackedInRange(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.Tracker.CheckTrackedInRange(System.Int32,System.Int32)"]

Remarks

See Also

Tracker Class


CheckTrackedMaxValue Method

Tracker..::..CheckTrackedMaxValue Method
Tracker Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.Tracker.CheckTrackedMaxValue(System.Int32,System.Int32)"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CheckTrackedMaxValue ( _
    lS As Integer, _
    lStatus As Integer _
) As Integer

Parameters

lS
Type: System..::..Int32
Sensor index (0...first sensor)
lStatus
Type: System..::..Int32

[Missing <param name="lStatus"/> documentation for "M:ExpSuite.Tracker.CheckTrackedMaxValue(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.Tracker.CheckTrackedMaxValue(System.Int32,System.Int32)"]

Remarks

See Also

Tracker Class


CheckTrackedMinValue Method

Tracker..::..CheckTrackedMinValue Method
Tracker Class See Also Send Feedback
Check if a sensor exceeded the minimum limit.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function CheckTrackedMinValue ( _
    lS As Integer, _
    lStatus As Integer _
) As Integer

Parameters

lS
Type: System..::..Int32
Sensor index (0...first sensor)
lStatus
Type: System..::..Int32

[Missing <param name="lStatus"/> documentation for "M:ExpSuite.Tracker.CheckTrackedMinValue(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.Tracker.CheckTrackedMinValue(System.Int32,System.Int32)"]

Remarks

lStatus is a mask to check the requested dimension. Set to 63 to check all dimensions

See Also

Tracker Class


DontTrackMinMaxValues Method

Tracker..::..DontTrackMinMaxValues Method
Tracker Class See Also Send Feedback
Stops tracking the min/max values by tracker.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function DontTrackMinMaxValues ( _
    lS As Integer _
) As String

Parameters

lS
Type: System..::..Int32
Sensor index (0...first sensor)

Return Value

Empty string if no error ocured.

Remarks

See Also

Tracker Class


GetCurrentValues Method

Tracker..::..GetCurrentValues Method
Tracker Class See Also Send Feedback
Get Current Values of a sensor from tracker.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetCurrentValues ( _
    lTO As Integer, _
    lS As Integer, _
    ByRef tsResult As Tracker..::..TrackerSensor _
) As String

Parameters

lTO
Type: System..::..Int32
Time Out in ms. Special cases:
  • lTo = 0: send request only, don't wait
  • lTo = -1: don't send request, get received values requested ages before.
    • lS
    Type: System..::..Int32
    Sensor index (0...first sensor)
    tsResult
    Type: ExpSuite..::..Tracker..::..TrackerSensor %
    Current values from tracker.

    Return Value

    Empty if no errors, error message otherwise.

    Remarks

    See Also

    Tracker Class


TrackMinMaxValues Method

Tracker..::..TrackMinMaxValues Method
Tracker Class See Also Send Feedback
Track Min or/and Max values of a sensor.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function TrackMinMaxValues ( _
    lS As Integer, _
    ByRef tsMin As Tracker..::..TrackerSensor, _
    ByRef tsMax As Tracker..::..TrackerSensor _
) As String

Parameters

lS
Type: System..::..Int32
Sensor index (0...first sensor)
tsMin
Type: ExpSuite..::..Tracker..::..TrackerSensor %
Minimum values for all dimensions. The .lStatus field must have a set bit for each tracker dimension (order from LSB to MSB.
tsMax
Type: ExpSuite..::..Tracker..::..TrackerSensor %
Maximum values for all dimensions.

Return Value

Empty if no error, error message otherwise.

Remarks

See Also

Tracker Class


Tracker.TrackerSensor Structure

Tracker..::..TrackerSensor Structure
Tracker Class Members See Also Send Feedback
Tracker Sensor data.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Structure TrackerSensor

Remarks

See Also

Tracker..::..TrackerSensor Members


Tracker.TrackerSensor Members

[image]

ExpSuite
Tracker..::..TrackerSensor Members
Tracker..::..TrackerSensor Structure Fields See Also Send Feedback

FrameWork - Tracker support.

The Tracker..::..TrackerSensor type exposes the following members.

Fields

 | Name | Description
Public field | blnValid | TRUE if the values are valid
Public field | lStatus | Status of the sensor (used dependent on the data)
Public field | sngA | Azimuth angle in degrees
Public field | sngE | Elevation angle in degrees
Public field | sngR | Roll in degrees
Public field | sngX | X position in cm
Public field | sngY | Y position in cm
Public field | sngZ | Z position in cm

See Also

Tracker..::..TrackerSensor Structure


Tracker.TrackerSensor Fields

[image]

ExpSuite
Tracker..::..TrackerSensor Fields
Tracker..::..TrackerSensor Structure See Also Send Feedback

The Tracker..::..TrackerSensor type exposes the following members.

Fields

 | Name | Description
Public field | blnValid | TRUE if the values are valid
Public field | lStatus | Status of the sensor (used dependent on the data)
Public field | sngA | Azimuth angle in degrees
Public field | sngE | Elevation angle in degrees
Public field | sngR | Roll in degrees
Public field | sngX | X position in cm
Public field | sngY | Y position in cm
Public field | sngZ | Z position in cm

See Also

Tracker..::..TrackerSensor Structure


blnValid Field

Tracker..::..TrackerSensor..::..blnValid Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
TRUE if the values are valid

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public blnValid As Boolean

Remarks

See Also

Tracker..::..TrackerSensor Structure


lStatus Field

Tracker..::..TrackerSensor..::..lStatus Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
Status of the sensor (used dependent on the data)

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public lStatus As Integer

Remarks

See Also

Tracker..::..TrackerSensor Structure


sngA Field

Tracker..::..TrackerSensor..::..sngA Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
Azimuth angle in degrees

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public sngA As Double

Remarks

See Also

Tracker..::..TrackerSensor Structure


sngE Field

Tracker..::..TrackerSensor..::..sngE Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
Elevation angle in degrees

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public sngE As Double

Remarks

See Also

Tracker..::..TrackerSensor Structure


sngR Field

Tracker..::..TrackerSensor..::..sngR Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
Roll in degrees

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public sngR As Double

Remarks

See Also

Tracker..::..TrackerSensor Structure


sngX Field

Tracker..::..TrackerSensor..::..sngX Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
X position in cm

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public sngX As Double

Remarks

See Also

Tracker..::..TrackerSensor Structure


sngY Field

Tracker..::..TrackerSensor..::..sngY Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
Y position in cm

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public sngY As Double

Remarks

See Also

Tracker..::..TrackerSensor Structure


sngZ Field

Tracker..::..TrackerSensor..::..sngZ Field
Tracker..::..TrackerSensor Structure See Also Send Feedback
Z position in cm

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public sngZ As Double

Remarks

See Also

Tracker..::..TrackerSensor Structure


Turntable Class

Turntable Class
Members See Also Send Feedback
FrameWork - Turntable support.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class Turntable

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..Turntable

See Also

Turntable Members


Turntable Members

[image]

ExpSuite
Turntable Members
Turntable Class Methods See Also Send Feedback

The Turntable type exposes the following members.

Methods

Name | Description
GetAngle | Get current turntable position in degrees azimuth.
MoveToAngle | Move turntable to angle...
Show |

See Also

Turntable Class


Turntable Methods

[image]

ExpSuite
Turntable Methods
Turntable Class See Also Send Feedback

The Turntable type exposes the following members.

Methods

Name | Description
GetAngle | Get current turntable position in degrees azimuth.
MoveToAngle | Move turntable to angle...
Show |

See Also

Turntable Class


GetAngle Method

Turntable..::..GetAngle Method
Turntable Class See Also Send Feedback
Get current turntable position in degrees azimuth.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetAngle As Double

Return Value

Degrees azimuth

Remarks

See Also

Turntable Class


MoveToAngle Method

Turntable..::..MoveToAngle Method
Turntable Class See Also Send Feedback
Move turntable to angle...

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function MoveToAngle ( _
    ByRef sngAngle As Double _
) As String

Parameters

sngAngle
Type: System..::..Double %
Angle in degrees azimuth.

Return Value

Error text if an error occures.

Remarks

See Also

Turntable Class


Show Method

Turntable..::..Show Method
Turntable Class See Also Send Feedback

[Missing <summary> documentation for "M:ExpSuite.Turntable.Show"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Show As String

Return Value

[Missing <returns> documentation for "M:ExpSuite.Turntable.Show"]

See Also

Turntable Class


ViWo Class

ViWo Class
Members See Also Send Feedback

[Missing <summary> documentation for "T:ExpSuite.ViWo"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend NotInheritable Class ViWo

Remarks

Inheritance Hierarchy

System..::..Object
ExpSuite..::..ViWo

See Also

ViWo Members


ViWo Members

[image]

ExpSuite
ViWo Members
ViWo Class Methods See Also Send Feedback

The ViWo type exposes the following members.

Methods

Name | Description
AddParameter | Add a new parameter to the parameters array.
AddPreviewParameter | Add a preview parameter to the preview parameters array.
ChangeParameterByMIDI | Change a parameter by MIDI data.
ClearParameters | Clear all parameters.
Connect | Establish a connection to ViWo.
Disconnect | Disconnect from ViWo.
GetParameterCommand | Get the OSC command of a parameter given by its name.
GetParameterIndex | Get the index of a parameter given by name.
GetParametersCount | Get the count of parameters.
GetPreviewParameterCommand | Get the OSC command of a preview parameter given by its name.
GetPreviewParameterIndex | Get the index of a preview parameter given by name.
GetPreviewParametersCount | Get the count of preview parameters.
Init | Init this module at the application's start.
LoadPreviewParameters | Initiate loading of preview parameters from ViWo.
Send | Send an OSC command to ViWo.
SendAllParameters | Send all parameters to ViWo.
SendAllParametersToMIDI | Send all real and preview parameters to MIDI.
SendParameter | Send a parameter to ViWo
SendParameterToMIDI | Send a parameter to MIDI
WorldLoad | Load a world in ViWo.
WorldUnload | Unload a world in ViWo.

See Also

ViWo Class


ViWo Methods

[image]

ExpSuite
ViWo Methods
ViWo Class See Also Send Feedback

The ViWo type exposes the following members.

Methods

Name | Description
AddParameter | Add a new parameter to the parameters array.
AddPreviewParameter | Add a preview parameter to the preview parameters array.
ChangeParameterByMIDI | Change a parameter by MIDI data.
ClearParameters | Clear all parameters.
Connect | Establish a connection to ViWo.
Disconnect | Disconnect from ViWo.
GetParameterCommand | Get the OSC command of a parameter given by its name.
GetParameterIndex | Get the index of a parameter given by name.
GetParametersCount | Get the count of parameters.
GetPreviewParameterCommand | Get the OSC command of a preview parameter given by its name.
GetPreviewParameterIndex | Get the index of a preview parameter given by name.
GetPreviewParametersCount | Get the count of preview parameters.
Init | Init this module at the application's start.
LoadPreviewParameters | Initiate loading of preview parameters from ViWo.
Send | Send an OSC command to ViWo.
SendAllParameters | Send all parameters to ViWo.
SendAllParametersToMIDI | Send all real and preview parameters to MIDI.
SendParameter | Send a parameter to ViWo
SendParameterToMIDI | Send a parameter to MIDI
WorldLoad | Load a world in ViWo.
WorldUnload | Unload a world in ViWo.

See Also

ViWo Class


AddParameter Method

ViWo..::..AddParameter Method
ViWo Class See Also Send Feedback
Add a new parameter to the parameters array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub AddParameter ( _
    viwoparNew As ViWo..::..ViWoParameter _
)

Parameters

viwoparNew
Type: ExpSuite..::..ViWo..::..ViWoParameter
ViWo parameter

Remarks

Used on load or change of settings

See Also

ViWo Class


AddPreviewParameter Method

ViWo..::..AddPreviewParameter Method
ViWo Class See Also Send Feedback
Add a preview parameter to the preview parameters array.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function AddPreviewParameter ( _
    varArgs As Object() _
) As String

Parameters

varArgs
Type: array< System..::..Object >[]()[][]
Variant array containing: index (not used), OSC command, type, MIDI, Default, additional parameter 1 and 2, and the name

Return Value

Nothing yet.

Remarks

A new preview parameter will be added. This function is called by the callback from ViWo. Additioanally, the default value will be decoded to FW standards and saved in .Value. If a corresponding real parameter exists, its MIDI data will be updated to the new data of the preview parameter. This is necessary in case of existing settings and real parameters and changing MIDI controller.

See Also

ViWo Class


ChangeParameterByMIDI Method

ViWo..::..ChangeParameterByMIDI Method
ViWo Class See Also Send Feedback
Change a parameter by MIDI data.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub ChangeParameterByMIDI ( _
    lCtrl As Integer, _
    lVal As Integer _
)

Parameters

lCtrl
Type: System..::..Int32
MIDI controller
lVal
Type: System..::..Int32
MIDI value

Remarks

The old value of a parameter will be modified according to the assign MIDI controller. If the real parameter does not exist, it will be copied from the preview parameter. The new parameter will be sent to ViWo immediatly. If the settings form is open, the temporary parameters change only and the Settings form will be updated - so you can track the changes of a parameter in real time in ViWo and Settings.

See Also

ViWo Class


ClearParameters Method

ViWo..::..ClearParameters Method
ViWo Class See Also Send Feedback
Clear all parameters.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub ClearParameters

Remarks

See Also

ViWo Class


Connect Method

ViWo..::..Connect Method
ViWo Class See Also Send Feedback
Establish a connection to ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Connect ( _
    pbStatus As ProgressBar _
) As String

Parameters

pbStatus
Type: System.Windows.Forms..::..ProgressBar

[Missing <param name="pbStatus"/> documentation for "M:ExpSuite.ViWo.Connect(System.Windows.Forms.ProgressBar)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.ViWo.Connect(System.Windows.Forms.ProgressBar)"]

Remarks

Warning: This is not the "Connect" as used by framework. This function establishes the connection to ViWo and is called at the begin of the application.

See Also

ViWo Class


Disconnect Method

ViWo..::..Disconnect Method
ViWo Class See Also Send Feedback
Disconnect from ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Disconnect

Remarks

See Also

ViWo Class


GetParameterCommand Method

ViWo..::..GetParameterCommand Method
ViWo Class See Also Send Feedback
Get the OSC command of a parameter given by its name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetParameterCommand ( _
    szName As String _
) As String

Parameters

szName
Type: System..::..String
Name of the parameter

Return Value

String with the OSC command of the parameter. Empty if the parameter could not be found.

Remarks

See Also

ViWo Class


GetParameterIndex Method

ViWo..::..GetParameterIndex Method
ViWo Class See Also Send Feedback
Get the index of a parameter given by name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetParameterIndex ( _
    szName As String _
) As Integer

Parameters

szName
Type: System..::..String
Name of the parameter.

Return Value

Index of the parameter. -1 if the parameter could not be found

Remarks

GetParameterIndex searches for a parameter with the name szName. If there is no parameter with this name, the search will be continued in the preview parameters array. If a corresponding preview parameter can be found, it will be copied to the parameters array and its index will be returned. If there is no real parameter nor preview parameter with such a name, -1 will be returned

See Also

ViWo Class


GetParametersCount Method

ViWo..::..GetParametersCount Method
ViWo Class See Also Send Feedback
Get the count of parameters.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetParametersCount As Integer

Return Value

Count of parameters. 0 if no parameters available.

Remarks

See Also

ViWo Class


GetPreviewParameterCommand Method

ViWo..::..GetPreviewParameterCommand Method
ViWo Class See Also Send Feedback
Get the OSC command of a preview parameter given by its name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetPreviewParameterCommand ( _
    szName As String _
) As String

Parameters

szName
Type: System..::..String
Name of the preview parameter.

Return Value

String with the OSC command of the preview parameter. Empty if the parameter could not be found.

Remarks

See Also

ViWo Class


GetPreviewParameterIndex Method

ViWo..::..GetPreviewParameterIndex Method
ViWo Class See Also Send Feedback
Get the index of a preview parameter given by name.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetPreviewParameterIndex ( _
    szName As String _
) As Integer

Parameters

szName
Type: System..::..String
Name of the preview parameter.

Return Value

Index of the preview parameter. -1 if the parameter could not be found

Remarks

See Also

ViWo Class


GetPreviewParametersCount Method

ViWo..::..GetPreviewParametersCount Method
ViWo Class See Also Send Feedback
Get the count of preview parameters.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function GetPreviewParametersCount As Integer

Return Value

Count of preview parameters. 0 if no parameters available

Remarks

See Also

ViWo Class


Init Method

ViWo..::..Init Method
ViWo Class See Also Send Feedback
Init this module at the application's start.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub Init

Remarks

See Also

ViWo Class


LoadPreviewParameters Method

ViWo..::..LoadPreviewParameters Method
ViWo Class See Also Send Feedback
Initiate loading of preview parameters from ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function LoadPreviewParameters ( _
    szWorld As String, _
    pbStatus As ProgressBar _
) As String

Parameters

szWorld
Type: System..::..String

[Missing <param name="szWorld"/> documentation for "M:ExpSuite.ViWo.LoadPreviewParameters(System.String,System.Windows.Forms.ProgressBar)"]

pbStatus
Type: System.Windows.Forms..::..ProgressBar

[Missing <param name="pbStatus"/> documentation for "M:ExpSuite.ViWo.LoadPreviewParameters(System.String,System.Windows.Forms.ProgressBar)"]

Return Value

[Missing <returns> documentation for "M:ExpSuite.ViWo.LoadPreviewParameters(System.String,System.Windows.Forms.ProgressBar)"]

Remarks

The parameters will be added using AddPreviewParameter.

See Also

ViWo Class


Send Method

ViWo..::..Send Method
ViWo Class See Also Send Feedback
Send an OSC command to ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function Send ( _
    szAddr As String, _
    ParamArray varArgs As Object() _
) As String

Parameters

szAddr
Type: System..::..String
OSC address in format "/root/tree1/obj2/method3"
varArgs
Type: array< System..::..Object >[]()[][]
Parameters in an array.

Return Value

[Missing <returns> documentation for "M:ExpSuite.ViWo.Send(System.String,System.Object[])"]

Remarks

See Also

ViWo Class


SendAllParameters Method

ViWo..::..SendAllParameters Method
ViWo Class See Also Send Feedback
Send all parameters to ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function SendAllParameters As String

Return Value

String containing error report of not supported parameters.

Remarks

All (real!) parameters will be sent to ViWo. If a parameters is not supported by the loaded world (corresponding preview parameter can not be found) an error will be returned.
If no world has been loaded, this function terminates immediatly.

See Also

ViWo Class


SendAllParametersToMIDI Method

ViWo..::..SendAllParametersToMIDI Method
ViWo Class See Also Send Feedback
Send all real and preview parameters to MIDI.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function SendAllParametersToMIDI As String

Return Value

Nothing at the moment.

Remarks

Send parameters if a world is loaded. If a real parameter exist, its value will be used. If preview parameter exists only, the default value will be sent.

See Also

ViWo Class


SendParameter Method

ViWo..::..SendParameter Method
ViWo Class See Also Send Feedback
Send a parameter to ViWo

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub SendParameter ( _
    viwoPar As ViWo..::..ViWoParameter _
)

Parameters

viwoPar
Type: ExpSuite..::..ViWo..::..ViWoParameter

[Missing <param name="viwoPar"/> documentation for "M:ExpSuite.ViWo.SendParameter(ExpSuite.ViWo.ViWoParameter)"]

Remarks

The parameter viwoPar will be parsed, converted to ViWo's parameter range and send to ViWo
  • int, float: the value will be converted to a number and sent
  • color: the colors parts R, G, and B will be converted from 0..255 to 0..1 range
  • position: the value must be a string in form "X Y Z". It will be splitted and 3 values will be sent
  • string: the value will be sent as is

    • See Also

    ViWo Class


SendParameterToMIDI Method

ViWo..::..SendParameterToMIDI Method
ViWo Class See Also Send Feedback
Send a parameter to MIDI

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Sub SendParameterToMIDI ( _
    viwoPar As ViWo..::..ViWoParameter _
)

Parameters

viwoPar
Type: ExpSuite..::..ViWo..::..ViWoParameter
ViWo parameter.

Remarks

See Also

ViWo Class


WorldLoad Method

ViWo..::..WorldLoad Method
ViWo Class See Also Send Feedback
Load a world in ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function WorldLoad ( _
    szWorld As String, _
    pbStatus As ProgressBar _
) As String

Parameters

szWorld
Type: System..::..String
Name of the world
pbStatus
Type: System.Windows.Forms..::..ProgressBar

[Missing <param name="pbStatus"/> documentation for "M:ExpSuite.ViWo.WorldLoad(System.String,System.Windows.Forms.ProgressBar)"]

Return Value

Error message or empty if no error ocured.

Remarks

WorldLoad initiates loading of a world in ViWo and waits for a response from the world. If no response can be received within 30 seconds an error will be returned.

See Also

ViWo Class


WorldUnload Method

ViWo..::..WorldUnload Method
ViWo Class See Also Send Feedback
Unload a world in ViWo.

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Shared Function WorldUnload As String

Return Value

Nothing yet.

Remarks

See Also

ViWo Class


ViWo.ViWoParameter Class

ViWo..::..ViWoParameter Class
ViWo Class Members See Also Send Feedback

[Missing <summary> documentation for "T:ExpSuite.ViWo.ViWoParameter"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Friend Class ViWoParameter

Inheritance Hierarchy

System..::..Object
ExpSuite..::..ViWo..::..ViWoParameter

See Also

ViWo..::..ViWoParameter Members


ViWo.ViWoParameter Members

[image]

ExpSuite
ViWo..::..ViWoParameter Members
ViWo..::..ViWoParameter Class Constructors Methods Properties See Also Send Feedback

The ViWo..::..ViWoParameter type exposes the following members.

Constructors

 | Name | Description
Public method | ViWo..::..ViWoParameter | Initializes a new instance of the ViWo..::..ViWoParameter class

Methods

 | Name | Description
Public method | Copy | Copy the content of a source parameter to destination

Properties

 | Name | Description
Public property | Command |
Public property | Default |
Public property | Dirty |
Public property | MIDI |
Public property | Name |
Public property | Par1 |
Public property | Par2 |
Public property | Type |
Public property | Value |

See Also

ViWo..::..ViWoParameter Class


ViWo.ViWoParameter Constructor

ViWo..::..ViWoParameter Constructor
ViWo..::..ViWoParameter Class See Also Send Feedback
Initializes a new instance of the ViWo..::..ViWoParameter class

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Sub New

See Also

ViWo..::..ViWoParameter Class


ViWo.ViWoParameter Methods

[image]

ExpSuite
ViWo..::..ViWoParameter Methods
ViWo..::..ViWoParameter Class See Also Send Feedback

The ViWo..::..ViWoParameter type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Copy the content of a source parameter to destination

See Also

ViWo..::..ViWoParameter Class


Copy Method

ViWo..::..ViWoParameter..::..Copy Method
ViWo..::..ViWoParameter Class See Also Send Feedback
Copy the content of a source parameter to destination

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Function Copy As ViWo..::..ViWoParameter

Return Value

[Missing <returns> documentation for "M:ExpSuite.ViWo.ViWoParameter.Copy"]

Remarks

See Also

ViWo..::..ViWoParameter Class


ViWo.ViWoParameter Properties

[image]

ExpSuite
ViWo..::..ViWoParameter Properties
ViWo..::..ViWoParameter Class See Also Send Feedback

The ViWo..::..ViWoParameter type exposes the following members.

Properties

 | Name | Description
Public property | Command |
Public property | Default |
Public property | Dirty |
Public property | MIDI |
Public property | Name |
Public property | Par1 |
Public property | Par2 |
Public property | Type |
Public property | Value |

See Also

ViWo..::..ViWoParameter Class


Command Property

ViWo..::..ViWoParameter..::..Command Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Command"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Command As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Default Property

ViWo..::..ViWoParameter..::..Default Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Default"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Default As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Dirty Property

ViWo..::..ViWoParameter..::..Dirty Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Dirty"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Dirty As Boolean
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


MIDI Property

ViWo..::..ViWoParameter..::..MIDI Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.MIDI"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property MIDI As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Name Property

ViWo..::..ViWoParameter..::..Name Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Name"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Name As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Par1 Property

ViWo..::..ViWoParameter..::..Par1 Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Par1"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Par1 As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Par2 Property

ViWo..::..ViWoParameter..::..Par2 Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Par2"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Par2 As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Type Property

ViWo..::..ViWoParameter..::..Type Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Type"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Type As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class


Value Property

ViWo..::..ViWoParameter..::..Value Property
ViWo..::..ViWoParameter Class See Also Send Feedback

[Missing <summary> documentation for "P:ExpSuite.ViWo.ViWoParameter.Value"]

Namespace: ExpSuite
Assembly: FrameWork (in FrameWork.exe) Version: 0.9.52.0

Syntax

Visual Basic
Public Property Value As String
    Get
    Set

See Also

ViWo..::..ViWoParameter Class